Welcome to discussions

Quick Suggestions

  • Dan_Gabriel
    4 posts

    I did a quest from Reda and i got all the achievents made till now, about 20.

    @hroozenbeek it worked. Thank you!!!

  • Ubi-Borealis
    Ubisoft Support Staff 2812 posts
    Best Answer

    Hello there!

    I apologise for the delayed update. Following TU 1.2.0.1, the development team has marked this issue as resolved.

    If you are still having trouble unlocking achievements on PC following this update, please can you provide us with the following information:

    • Which achievements are you unable to unlock?
    • Have you tried repeating actions, if able to (such as in "Silent Viking" and "Seahorse")?
    • Have you been able to try completing additional quests? Some players have reported that completing settlement quests, such as Petra's archery challenge, has allowed them to trigger story achievements to unlock.
    • If you're able to provide any images/video that shows you have met the criteria but the achievement hasn't unlocked, this would be helpful. This could be an image that shows your completed quest log and missing achievement, or a video that shows you completing an action and the achievement not unlocking.


    We can then pass these reports to the development team for further investigation.

    @Jackov15 & @Lidi_Melo - Are you still missing achievements in-game after meeting the requirements following TU 1.2.0.1? If so, please can you provide us with the information requested above.

    @RedIndianRobin - We don't yet have any new information to share regarding the missing achievement pop-up in-game. We've reached out to the team to see if we can get any new updates to share with you all.

    @Arthefran - We don't yet have any new updates to share about making a public API for achievements. I've reached out to the team to see if we can find out any additional information.

    Thanks! 😊

    Official Response
  • Dan_Gabriel
    4 posts
    This post is deleted!
  • FlavioSSA
    11 posts

    @hroozenbeek Thank you!! That did the trick 👍

  • Cheva1ier.
    3 posts

    @Ubi-Woofer

    My problem is solved.

    It seems that I chose the wrong mission from Reeda.
    I took the "Kill the predators" mission and it didn't triggered the achievements unlocking.

    Only after I took the "Kill the rich merchant" mission I saw the results on ubisoft connect.

    Best Regards.

    P.S

    Thanks also the rest users who mentioned the solution once again.

  • hroozenbeek
    1024 posts

    @kreutzgang Yes, three of them are bugged: Take My Hand (Cent), The Enemy of My Enemy (Wincestre), and Disorder of the Ancients, see: Achievements for Assassin's Creed Valhalla on PC

  • kreutzgang
    635 posts

    @hroozenbeek thanks!

  • Matyivagyok
    1 posts

    Completed achievements are not popping up while I am in game, is it a known issue, or is there anything to do with it?
    In Ubisoft Connect options I have all the notifications enabled, so I assume achies should pop up in game as well, like it happened with all the previous ACs I have played.
    Or am I missing some options here?

  • Ginal93
    2 posts

    @andreserrano77 I have the same. I didn't receive achcivements even if finished tasks in Cent and eliminated all targets of the Order of Ancients.

    My another problem is related with fishing. After few seconds all fishes dissappear...
    There is not possible during my PC game to avenge the death players. They are nowhere...
    I finieshed all game and my statistic with completeness of progress (first possition) is 91%. Why not 100?

  • Ginal93
    2 posts
    This post is deleted!
  • phirophe
    4 posts

    I've been playing this game on PC for +180 hours and Ubisoft Connect doesn't allow me to unlock some of the achievements even though I've definitely completed each one's requirements. Specifically: Old School Treasure Hunt / Silent Viking / Orlog Champion / A Picture of Grace / Disorder of the Ancients / The Enemy of my Enemy . Is anyone else having the same problem?


  • Ryusennin
    71 posts

    @matyivagyok

    Challenges/Achievements popups are broken since the replacement of UPlay with UbiConnect. They will be enabled back "at a later date".

  • cococha2011
    5 posts

    Disorder of the ancient doesn't unlock for me either on PC

  • Si_W
    29 posts

    I'm not seeing Equine Attack pop on PC now, it did pop on PS4...

  • Gonzalez_1984
    3 posts

    Actually, 'Completionist All The Way!' missing was my own fault. Missed one angry bear in Jotunheim

  • ROTeFeL
    22 posts

    @ubi-woofer
    Hi,
    No, I just meant that I don't want to go after the "Good Catch!" achievement if there is any bug there, as it's the most time-consuming. Thanks! 😊

  • ABadCombination
    3 posts

    On Xbox and after eliminating all order of ancients members, still no achievement pop. Been 3 days since completion, and last achievement

  • the_real_dna
    16 posts

    @lockmort yeah it's kinda sad and definitely frustrating.. on the other side of this though, I wish Valve would budge a little bit and try harder to retain some of their long-standing relationships. Time will tell I guess. But in the end, Valhalla will inevitably come to Steam... eventually. But it could be several years before that happens. And when it does, I'll prob end up buying it again (during a sale) since all 9 of my other AC games are on there.

    And yes, if it were on Steam, it almost certainly would've had achievements.. from day 1

  • Ubi-Mark.
    Ubisoft Support Staff 996 posts

    Hello @gtrule,

    We're glad that the issue has been resolved for you. Happy gaming and if you have any additional questions, please let us know!

    @james885, @summortuus, @cococha2011 and @ABadCombination - I'm really sorry to hear that your achievement hasn't been unlocked. Can you please provide us with a few screenshots of this occurring, so we can investigate it further? Many thanks!

    Official Response
  • senthor2142
    3 posts

    @tolkyyn same for me.

  • james885
    10 posts

    @ubi-mark Thanks for the follow-up. Here are the screenshots I took from my Xbox and my Assassin's Creed Valhalla achievements list. I believe the "Disorder of the Ancients" achievement isn't unlocked for all Xbox players since January 15 2021, the day after Title Update 1.1.1 released. Since it's a platform-wide issue, can you escalate this issue to dev team?

    spoiler
    I took a screen shot of all my Assassin's Creed Valhalla achievements, I got 49 of 50 achievements, and the only one locked secret achievement is Disorder of the Ancients. But the list is too long, I've uploaded to Imgur:

Suggested Topics

Community Details

16
Online
138.5k
Users
24.2k
Topics
125.7k
Posts