Welcome to discussions

Quick Suggestions

  • hroozenbeek
    1024 posts

    @kreutzgang Yes, three of them are bugged: Take My Hand (Cent), The Enemy of My Enemy (Wincestre), and Disorder of the Ancients, see: Achievements for Assassin's Creed Valhalla on PC

  • Ubi-Borealis
    Ubisoft Support Staff 3625 posts
    Best Answer

    Hello there!

    I apologise for the delayed update. Following TU 1.2.0.1, the development team has marked this issue as resolved.

    If you are still having trouble unlocking achievements on PC following this update, please can you provide us with the following information:

    • Which achievements are you unable to unlock?
    • Have you tried repeating actions, if able to (such as in "Silent Viking" and "Seahorse")?
    • Have you been able to try completing additional quests? Some players have reported that completing settlement quests, such as Petra's archery challenge, has allowed them to trigger story achievements to unlock.
    • If you're able to provide any images/video that shows you have met the criteria but the achievement hasn't unlocked, this would be helpful. This could be an image that shows your completed quest log and missing achievement, or a video that shows you completing an action and the achievement not unlocking.


    We can then pass these reports to the development team for further investigation.

    @Jackov15 & @Lidi_Melo - Are you still missing achievements in-game after meeting the requirements following TU 1.2.0.1? If so, please can you provide us with the information requested above.

    @RedIndianRobin - We don't yet have any new information to share regarding the missing achievement pop-up in-game. We've reached out to the team to see if we can get any new updates to share with you all.

    @Arthefran - We don't yet have any new updates to share about making a public API for achievements. I've reached out to the team to see if we can find out any additional information.

    Thanks! 😊

    Official Response
  • kreutzgang
    635 posts

    @hroozenbeek thanks!

  • Matyivagyok
    1 posts

    Completed achievements are not popping up while I am in game, is it a known issue, or is there anything to do with it?
    In Ubisoft Connect options I have all the notifications enabled, so I assume achies should pop up in game as well, like it happened with all the previous ACs I have played.
    Or am I missing some options here?

  • Ginal93
    2 posts

    @andreserrano77 I have the same. I didn't receive achcivements even if finished tasks in Cent and eliminated all targets of the Order of Ancients.

    My another problem is related with fishing. After few seconds all fishes dissappear...
    There is not possible during my PC game to avenge the death players. They are nowhere...
    I finieshed all game and my statistic with completeness of progress (first possition) is 91%. Why not 100?

  • Ginal93
    2 posts
    This post is deleted!
  • phirophe
    4 posts

    I've been playing this game on PC for +180 hours and Ubisoft Connect doesn't allow me to unlock some of the achievements even though I've definitely completed each one's requirements. Specifically: Old School Treasure Hunt / Silent Viking / Orlog Champion / A Picture of Grace / Disorder of the Ancients / The Enemy of my Enemy . Is anyone else having the same problem?


  • Ryusennin
    93 posts

    @matyivagyok

    Challenges/Achievements popups are broken since the replacement of UPlay with UbiConnect. They will be enabled back "at a later date".

  • cococha2011
    5 posts

    Disorder of the ancient doesn't unlock for me either on PC

  • Si_W
    29 posts

    I'm not seeing Equine Attack pop on PC now, it did pop on PS4...

  • Gonzalez_1984
    3 posts

    Actually, 'Completionist All The Way!' missing was my own fault. Missed one angry bear in Jotunheim

  • ROTeFeL
    22 posts

    @ubi-woofer
    Hi,
    No, I just meant that I don't want to go after the "Good Catch!" achievement if there is any bug there, as it's the most time-consuming. Thanks! 😊

  • ABadCombination
    3 posts

    On Xbox and after eliminating all order of ancients members, still no achievement pop. Been 3 days since completion, and last achievement

  • the_real_dna
    19 posts

    @lockmort yeah it's kinda sad and definitely frustrating.. on the other side of this though, I wish Valve would budge a little bit and try harder to retain some of their long-standing relationships. Time will tell I guess. But in the end, Valhalla will inevitably come to Steam... eventually. But it could be several years before that happens. And when it does, I'll prob end up buying it again (during a sale) since all 9 of my other AC games are on there.

    And yes, if it were on Steam, it almost certainly would've had achievements.. from day 1

  • Ubi-Mark.
    Ubisoft Support Staff 1323 posts

    Hello @gtrule,

    We're glad that the issue has been resolved for you. Happy gaming and if you have any additional questions, please let us know!

    @james885, @summortuus, @cococha2011 and @ABadCombination - I'm really sorry to hear that your achievement hasn't been unlocked. Can you please provide us with a few screenshots of this occurring, so we can investigate it further? Many thanks!

    Official Response
  • senthor2142
    3 posts

    @tolkyyn same for me.

  • james885
    10 posts

    @ubi-mark Thanks for the follow-up. Here are the screenshots I took from my Xbox and my Assassin's Creed Valhalla achievements list. I believe the "Disorder of the Ancients" achievement isn't unlocked for all Xbox players since January 15 2021, the day after Title Update 1.1.1 released. Since it's a platform-wide issue, can you escalate this issue to dev team?

    spoiler
    I took a screen shot of all my Assassin's Creed Valhalla achievements, I got 49 of 50 achievements, and the only one locked secret achievement is Disorder of the Ancients. But the list is too long, I've uploaded to Imgur:


  • Ciaossu-
    25 posts
    @ubi-woofer Most achievements did indeed retroactively unlock, however, some inexplicably, did not, including:
    • "Take My Hand" - Complete the Cent Arc
    • "The Enemy of My Enemy" - Complete the Wincestre Arc
    • "Disorder of the Ancients" - Eliminate all targets of the Order of Ancients
    • "Completionist All the Way!" - Complete all territories

    I completed all arcs, I eliminated all targets, and completed all territories, so why did these achievements not unlock?

    same here. Achievements still unlock

  • Ubi-Woofer
    Ubisoft Support Staff 1029 posts

    Hello everyone!

    I have some updates for you regarding the additional couple of issues mentioned in this thread since the PC achievements were implemented for Assassin's Creed Valhalla.

    The developers have identified a fix for the PC achievements that were not unlocking correctly (Take My Hand; The Enemy of My Enemy; Disorder of the Ancients most notably) and this will be pushed in an upcoming update. It isn't yet confirmed which patch this fix will be applied in, and what the full contents of said patch are, but as soon as I know, I'll reply again here. The community team will also post the relevant patch notes over in the News & Announcements section when they become available.

    Additionally, regarding the time-limited challenge progression and Ubisoft Connect statistics not tracking correctly, a fix has been prepared for these issues and will be deployed in a future update. As above, as soon as I know the full details regarding the patch, I'll reply again here. The community team will also post the relevant patch notes over in the News & Announcements section when they become available.

    I hope to be able to spare specific details soon, but in the meantime, thanks for your patience. 🙂 I'll reply to a few specific replies below, as ever -

    @Kormac67 - Could you check for your achievement screenshots in the following directory, as that seems to be the default path for me in Ubisoft Connect (you can change it however from the settings):
    C:/Users/[USERNAME]/Pictures/Uplay
    If you have the setting enabled to automatically take a screenshot when you earn an achievement, that's where you should find those images stored. 🙂

    @Cheva1ier - Hey there! Can you please confirm whether you're still seeing any of your earned achievements locked on PC? (If the three above, please be aware that these are now scheduled to be fixed in an upcoming patch.)

    @FlavioSSA & @Dan_Gabriel - Glad to hear that @hroozenbeek's tip helped you out! 🙂 Thanks for the assist, @hroozenbeek!

    @Matyivagyok - The issue with achievement pop-ups in-game is a wider Ubisoft Connect topic, and not specific to Valhalla. I'm still following that discussion and will keep this thread updated if I learn more.

    @Ginal93 - Please keep your reports on-topic for the thread. You have mentioned multiple issues recognised or discussed in separate threads / megathreads in your post. In future, please seek these out and share your experiences there, but this time I'll link them for you for ease. 🙂


    @Si_W - Did you make a fresh attempt at an assassination from your horse on PC? This will be necessary as it is a repeatable action. Please let me know!

    @Gonzalez_1984 - If it's the bear I'm thinking of, he's certainly angry! Glad to hear you got it sorted. 🙂

    @ROTeFeL - I understand. You shouldn't experience any issues with unlocking that particular trophy/achievement itself as all you need to do is find one of each fish, not one of each size of each fish. We're hoping to resolve the issues with the missing big Flatfish / Mackerel and small Halibut / Sturgeon soon, as well as the issues with them despawning / not spawning. Keep an eye on the relevant megathreads for our updates there.

    @Ciaossu - Please see the information above regarding the first three! For the "Completionist All The Way!" achievement, have you collected all wealth and completed all world events in every location, across Vinland, Norway, England, Asgard and Jotunheim?

    Official Response
  • Kormac67
    656 posts

    @ubi-woofer Yes, I have found the screenshots and the setting in Ubisoft Connect where you can enable/disable the feature, thank you!
    I understood it as if the screenshors were saved to the cloud, maybe I took the text popup wrong.

  • Si_W
    29 posts

    @ubi-woofer yes, I have tried to assassinate an enemy from my horse on PC, but doesn't seem to pop...

Suggested Topics

Community Details

104
Online
192.5k
Users
32.4k
Topics
162.3k
Posts