ubisoft discussions

Quick Suggestions

  • luigispcrew
    99 posts

    @tchester1980 same issue bro

  • stallattack
    34 posts

    same issue, completed all region

  • Kormac67
    1095 posts

    @tchester1980 If you read the known issues list you would see it right there.

  • Tchester1980
    1100 posts

    @kormac67 That´s the problem. I was searching for it but didn´t found it. Maybe I missed it!
    Thank you, I will double check it again.

  • Jurld
    17 posts

    I guess I'm in the same boat with others. Take My Hand, Disorder of the Ancients are not unlocked.

  • IFrike
    22 posts

    "Take My Hand", "The Enemy of My Enemy" and "Disorder of the Ancients" are all locked for me too.

  • Ubi-MrM
    Ubisoft Support Staff 2858 posts

    Hello again everyone 🙂

    As I mentioned previously, I have raised the issue with certain achievements (Disorder of the Ancients, The Enemy of My Enemy, Take My Hand) not unlocking to the development team, and this has already been acknowledged in our Known Issues list due to them being able to reproduce this issue on their side:

    (Ubisoft Connect) "Disorder of Ancients", "The Enemy of my Enemy", "Take My Hand" Ubisoft Connect achievements despite meeting unlock conditions

    Two further achievements myself and my colleagues have raised to them as potentially having issues are the "Completionist All The Way!" and "Old School Treasure Hunt" ones, however they have not yet confirmed if they have reproduced issues with unlocking these. We haven't received as many reports of issues with those, so if you are unable to unlock these, please do let me know.

    I'll pass on the usernames of all of you affected by this issue, as well as the achievements you are missing if stated in your post. Any further reports received I'll forward as well, and I'll keep you all updated as much as possible here in this thread.

    Finally, as a quick request - Xbox players, I have seen you posting in this thread about issues with tracking/unlocking achievements on your platform, but this isn't the right place to report those issues as this thread is for the achievements on PC! 🙂 Please take to our megathread for issues with unlocking achievements on Xbox in order to report the achievements you are having issues with, and provide evidence of your fulfilment of the requirements. As Xbox is not our platform, we need to report these issues in a different way following investigation, so keeping these reports in one place is important.

    Thank you very much! 🙂

    _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _

    Moving onto individual replies -

    @Kormac67 Glad to hear that most of the achievements you were missing unlocked for you, with the exception perhaps of those I've acknowledged as under investigation above? Was there an error message when the game / Ubisoft Connect crashed that you recall?

    @hroozenbeek I would assume the unlock timing of your achievements was just by chance, as it may have taken a few minutes for them to synchronise, and the time between completing daily quests would have been enough. Regarding the remaining achievements, there's a great place to do Skadi's Hobby near the viewpoint closest to Kjotve's fortress. If you fast-travel to the viewpoint there, and then head south-east, there's the start of a huge slope that you can slide right down. I managed it in one attempt!

    @Vilemos Glad to hear everything seems to be in order for you! No hard feelings over the harsh words, I'm used to it! I know it's because you / others want your issues resolved so I don't take it personally 🙂

    @Chottodare As I mentioned in my original announcement post, the wider issues with Ubisoft Connect and pop-ups for challenges / achievements etc. are still under investigation. This isn't an issue specific to Assassin's Creed Valhalla.

    @auridulis No worries! We'll keep everyone updated via these forums and our social media accounts. I believe it's on the Known Issues list now after I discussed the issue with our community team, but referring to the absence of revenge quests specifically:

    Avenge quests are nowhere to be found

    @robthebob11 @Ruxleyford514 I'm sorry to hear that this has happened! Could you provide a screenshot showing that the achievement is unlocked for you already? If you happen to have a screenshot of the achievement itself as it unlocked, that would be very helpful too. I'll report this and see if it's a recognised issue once I have those images from you both.

    @RedIndianRobin I've removed the expletives from your post - I'm happy to assist if you're encountering issues with unlocking the achievements you've earned, but I'd like to ask that you kindly refrain from speaking to me and other staff in that manner. Can you please advise if you have tried completing a daily contract from Reda, as well as repeating the actions required as necessary as I outlined?

    @eguy_4 Which specific achievements aren't unlocked for you please? Could you also provide a screenshot showing that you have no tracked actions towards the daily / weekly challenges despite trying to contribute?

    @Si_W If you're having issues with unlocking trophies on PS4 / PS5, please start a new thread dedicated to these and I can investigate there. This thread is just for issues with the achievements on PC. 🙂 Glad to hear that on PC, everything seems in order aside from the achievements with recognised issues.

    @ROTeFeL Regarding "Good Catch!", I recently completed this myself on PS4, so I'm not aware of any issues with it. There are reported issues with coastal fish spawns and a few missing fish for the fishing hut tasks, but in terms of that particular achievement itself, I believe it is obtainable. What are you struggling with?

    Official Response
  • Fireseed
    17 posts

    @Ubi-Woofer I encountering the exact same issue as @eguy_4 
    You requested a screenshot, don´t know how this really helps, but here it is, fresh taken from today shortly after playing the game:


    For me also all statistics does not update properly, maybe these issues are connected. 🤔

  • xcodex94
    1 posts

    @ubi-woofer I also have a problem with the same three achievements on pc: Disorder of the Ancients, The Enemy of My Enemy, Take My Hand

  • Ubi-MrM
    Ubisoft Support Staff 2858 posts

    Thanks for the image, @Fireseed! I've sent it across to the developers for them to review. Out of curiosity, if you view your progress in the challenges on the Ubisoft Connect website, does your contribution still show as 0? If so, this is possibly a larger issue with Ubisoft Connect and its tracking as a whole, but I cannot be sure, so if requested by them I'll also be forwarding the information to the Ubisoft Connect team. I haven't encountered this issue myself, as you can see below, but I'll be happy to forward any additional reports. Creating a separate thread for the limited-time challenges would probably be best however, so that we can ensure this thread doesn't stray too far off-topic.

    @xcodex94 Thanks for your report! I've sent the details you've provided to the developers now. 🙂

    Official Response
  • EpicHobo69
    13 posts

    Hi! Appreciate the addition of achievements, just gotta say that im also having the issue where Cent and Wincestre arc trophies arent unlocking even though i have done them a long time ago. Also my Uplay these days keeps saying it "failed to synchronise achievements with cloud", is that an issue on client or server side?

  • Kormac67
    1095 posts

    @ubi-woofer There was no error message.
    There just was a message telling the game had sent a screenshot to Ubi Connect, then it froze for a moment and crashed. It did send a crash report you possibly can link to the devs.
    I still have no idea what the screenshot should do in Ubi Connect - there is no function "show screenshot of achievement" there.

  • Gonzalez_1984
    3 posts

    Hi, I'm missing following achievements:
    'Take My Hand'
    'Disorder of the Ancients'
    'Old School Treasure Hunt'
    'Completionist All The Way!'

  • andreserrano77
    8 posts

    i think the only missing achievements from my side are the well known:

    • "Take My Hand" - Complete the Cent Arc
    • "The Enemy of My Enemy" - Complete the Wincestre Arc
    • "Disorder of the Ancients" - Eliminate all targets of the Order of Ancients

    Already reported by other users

    All the others are allready unlocked and the remaining missing ones are really missing (not done)

  • VasilyZaitsev42
    19 posts

    Now that achievements are added to pc, it seems not all are working. I have 3 still locked after completing the game. Cent arc, wincestre arc, and kill all order people. Those should have unlocked during the story but didn't.

  • Ubi-Wan
    Community Representative 636 posts

    @vasilyzaitsev42 Hello there! Sorry to hear about this. I suggest reaching out to our dedicated support team so this can be looked into more closely.

    Official Response
  • kreutzgang
    635 posts

    Are the achievements bugged in this game? I'm missing some, like "complete x arc", or "eliminate all order of the ancients", which I've done. While the latter may refer to DLC (shouldn't though ...), the former def makes no sense, as I completed all arcs.

  • Cheva1ier.
    3 posts


    I downloaded the patch on the 14th of January but today i was available to logged-in and see if the achievements can be unlocked.
    I read all the posts from that day also because i didn't want to miss any important answer.
    But unfortunately my achievements remained locked.
    I have succeeded at least 33 of them cause i am at 92% of the main story with 150 hours in the game.
    Tried to travel to Norway and Vinland but nothing changed.
    Also i made a quest from Reeda without any luck.

    So how should i proceed ?

  • Tolkyyn
    127 posts

    I've done every Reda quest available since my Eivor got to England, yet the "Viking for Hire" challenge is just blank, nothing. Yet another bug. At least those of us on PC can see the challenges. To have done the required quests and not get credit for them is a bit infuriating.

Suggested Topics