Welcome to discussions

Quick Suggestions

  • Gimbii
    1 posts

    I am having the same issue. Bought the gold edition, it is pre-loaded and in my game library, but wont give me the option to start the game. Uplay and Epic games both just say the game isnt available yet. Ive tried restarting uplay and verifying the files, still nothing.

    Can someone please offer a real solution? just spent $100 for what is suppose to be a AAA game. This is pathetic. i've seen indie games have better launches

  • jenbailey79
    5 posts

    @ubi-baron It's showing as installed but unavailable in Epic Games, but in Ubisoft Connect, it doesn't appear at all. How can I play?

  • jenbailey79
    5 posts

    @ubi-baron When I tried to launch from the desktop icon, I got this:
    undefinedundefined

  • XxZeiferxX
    3 posts

    @pineappleoz I'm worst. I already asked for refund. Impossible to log into Uplay at all.

  • jenbailey79
    5 posts

    @ubi-baron It's after the launch time in my time zone, I've verified 3 times, restarted Epic Games and Ubisoft Connect. What can I do?

  • FunctionFaraj
    1 posts

    same issue here untill now

  • jenbailey79
    5 posts

    @functionfaraj Did you do anything that fixed it? It's still not working for me.

  • jenbailey79
    5 posts

    @ubi-baron It looks like it's going to run for me now. I'm not sure if it's just that the time elapsed, but I also disabled an additional time zone I had set up on my computer, so maybe that was it? Just in case that helps someone else.

  • ggears90
    1 posts

    Its 12PM est for me and i should have been able to play an hour ago. it says i can launch it BUT when i do NOTHING LAUNCHES.


  • Ubi-Keo
    Ubisoft Support Staff 1165 posts

    Sorry for the late response, due to the high volume of contacts it has taken longer than usual to respond. 

    As this is an old thread and the game is now released I have locked it.

    Official Response

Suggested Topics

Community Details

97
Online
142.1k
Users
25.1k
Topics
130.1k
Posts