Welcome to discussions

Quick Suggestions

  • Grundged
    8 posts

    In the codex, Viking is spelled Vikingr. 🤦

  • yerimiese_
    88 posts

    guys help, i have a quick question, im playing valhalla in original PS4, but i have a lil bit of problem.
    so i already turn on my blood fx on the settings but there's no blood in game whatsoever, i watch gameplay on youtube and they all have that blood fx like blood splatter when u hit an enemy, but in my case, the blood didn't appear at all. i already turn off the blood fx and turn it back on but that doesn't help. well maybe it's not big of a deal but with all that gory finisher and u don't see a blood coming out, it's kinda weird.
    any help?

  • longjohn119
    547 posts
    In the codex, Viking is spelled Vikingr. 🤦


    That's not a mistake ..... That's the proto-germanic spelling

  • longjohn119
    547 posts

    "3. When climbing up you get about halfway and you jump off to the side.

    4. Not sure if this is a glitch or not but there is no enemy identification when flying as the raven. You only see the DPS in red and cannot mark them...Also there is no map for the boat or songs is this coming as you go forward."

    3 is actually normal behavior for an AC game ..... It happens because the same button for climb is also used to leap backwards so it you go up as high as you can if you keep pushing the climb button it will switch to a leap behind .... however if there is nothing behind you to grab then you go tumbling to the ground ....

    4 is just the way they programmed it because people were complaining about the way it lit everything up in Odyssey and made it too easy supposedly .... I liked the way Odyssey did it because I could get these clear across a fort shots on NPCs that normally you couldn't see because they were so far away they were a blur because of so few pixels they just blend into the background

  • CapCheeks
    40 posts

    This double scabbard for two handed weapons is driving me nuts.undefined

  • P2kanathip
    10 posts

    1.Got a duplicate of Galloglach Armor. One with 1 upgraded slot, another one with 3 upgraded slots. it's in Spalding bandit lair northeast of Ravensthorpe.

    2.When I'm assassinate an enemy, I'm the one lying down.

  • TrekNyne
    4 posts

    Trying to push shelves aside to reveal passages and can't release them after. Have to restart game.

    Honestly this game is a pile of garbage for $144 CAD. SO MANY GLITCHES. You can tell it was rushed.

    Last time I buy a Ubisoft game at launch, which are usually polished.

    This is the worst AC game I've played by far for sloppiness.

  • larrykop1967
    65 posts

    The only glitch i've had so far was in the "To Serve the Light! mission, when we got in the boat, Hytham just stood there and wouldn't row, i ran around jumping in and out for 5 minutes then he just sailed off all of a sudden, with me swimming behind trying to catch up.

  • Makanjyuu
    8 posts

    No pics, but:

    1) I've had several instances of audio desyncing with lip movements, starting & stopping & getting cut off abruptly because another line wants to start by the time the previous one actually starts playing.

    2) I went up the mountain north of Fornburg (or whatever it was called) & after getting around a tall pillar of rock about halfway up, Eivor began randomly getting stuck in an easing-along-a-narrow-ledge position for much of the rest of the time I was in Norway. It seems to have stopped now that I'm in England, but I'm only up to founding Raventhorpe so far.

    Playing as male Eivor on a physical copy on PS4.

  • Dokkaebi666Love
    1 posts

    I have a bug that you have to move a shelve in one of the Stavenger loot, the one you have to go from below the house, i cant move the shelve and i think it got glitched, i already tried everything and judging some videos i found on youtube i believe there is no way to pass from that point to get the loot. Kinda annoying since im going 100% game.

  • sattium85
    72 posts

    The helmet is automatically hidden after every loading of the game. After each load of the game in the character settings, the helmet becomes hidden.

  • mrsleep0000
    10 posts

    Trying to push shelves aside to reveal passages and can't release them after. Have to restart game.

    Push C to release the shelves

  • Ethanreves682
    2 posts

    When trying to close the door to jotenheim in asgard, the door will not shut and the mission is not advancing.

  • KingOranve
    1 posts

    I found a very very big bug. When doing the Seas of Fate mission, I get on the ship and nothing happens. This is the quest where you go to make a new life in England. So please, fix this as soon as you can.

  • Ethanreves682
    2 posts

    UPDATE: completely starting the mission over seemed to resolve the issue.

  • Mechy01
    1 posts

    Going under the waterfall for one of the books of knowledge, I started to go into the cave and was greeted with the "Area Unavailable" words right in the middle of the screen. I backed up... went in and out of the game...then I just figured let me save the game and go in anyway....well, nothing stopped me. I did have to break down what looked like the end of the map but I think it was suppose to be ice....not sure....but yea...that's mine.

  • Nightally
    5 posts

    @five20192020
    1: almost none of the world events can be completed
    2: getting attacked by a boar, while on a horse, crashed the game
    3: random pits in the ground where you can't get up if you fall down
    4: NPC interaction not working unless you blow the horn a few times
    5: getting killed by bosses makes you move slow instead of dying and every NPC stops moving
    6: dude stuck in a chair
    7: dude eating an apple or something, but his hand is empty
    8: 2 dudes fighting, but they're like 2 meters apart
    9: loading a save creates another save or overwrites or something, I'm confused
    10: can't even start some world events because the NPC can't talk
    11: treasure description tells me to go somewhere and see something far away, but the thing I'm supposed to see is too far away to render. I'm on max settings with a 3080.
    12: using the skill to switch which hands your weapons are in, while holding a torch, then throw the torch. It throws your weapon instead and you can't pick it up
    13: doing raids doesn't give you any indication of when you have completed it. Not sure if bug or crappy lack of feature
    14: horse can climb like skyrim spiderhorse
    15: sound cutting out every now and then

    I'm still in the starter area. Putting the game on hold until they fix the world events

  • Ghh272
    1 posts

    I'll be playing and eivor will move by himself and the camera angle will move own its own and then disconnects my controller. It isn't my controller ive tried 3 of them and it does the same thing and doesn't do it on different games

  • Gamgin
    1 posts

    I can not access the Ubisoft club, store, or Redas. On PS4. (0x7000015f)

Suggested Topics

Community Details

123
Online
140.7k
Users
24.8k
Topics
128.5k
Posts