ubisoft discussions


  • moved Glitches found in Valhalla. Share yours

    0 likes/83 replies/1628 views
    ubisoft:x-posts, 47

    Hiding someone you've just assassinated in a hay cart and they suddenly turn into a rigid carboard cutout, lol. Then there's the magicians who magically levitate items with the flick of a finger, including cats! There's ghosts too. I'll smash a crate or vase and alert someone nearby when there's....nobody....there!!!! And finally, on a more serious note, a lot of the animation is just plain horrible and hopefully just a "placeholder" for when they decide to finish this title. Aside from that it's kinda fun!

  • larrykop1967
    ubisoft:x-posts, 77

    I completed a raid at a monastery, and there is some normal wealth i assumed that i left there, i went back to get it, but the game says i need to force open the door by raiding, which i've already done. i cant force open the door by myself.

  • Superfly_Boss
    ubisoft:x-posts, 105

    There's a certain event in Glouchestershire arc where you are given this temporary outfit to wear. I have finished the arc but the outfit will not come off. It is impossible.

  • Freeman0017
    ubisoft:x-posts, 3

    I have no picture, but during a couple of raids to npcs, a crewman and an enemy, started circling eachother runing in a tight circle like 2 dogs chasing eachothers tails

  • PedrosoNeves
    ubisoft:x-posts, 7

    there are glitinch holes on the arms of the raven set

  • PedrosoNeves
    ubisoft:x-posts, 7

    @pedrosoneves glitching*

  • Yorky100
    ubisoft:x-posts, 1

    Hi i am trying to buy Helix Credits and all it says is connection error any advice please

  • Atramoria
    ubisoft:x-posts, 1

    "The Big Finish" fight against The Builder on Xbox One S. Got about halfway through the battle (after cutscene) and one of the Builder's attacks knocked me through the center of the floor, into an underwater pit. Game glitched from there and had to restart. Every hit after that sent me back through the ground.

  • VanRaposU
    ubisoft:x-posts, 14


    I'm playing on PS4 and have been experiencing A LOT of glitches and bugs so far. Like, I played Odyssey on launch day too and I don't remember being THIS bad.
    The most annoying (and worrisome) of them all is one that completely crashes the game. The screen just freezes and the game shuts down. I don't even know what prompts it: sometimes it happens on cutscenes, sometimes during battles and once it happened while I was just walking on my settlement.

    The funniest glitch I had, though, was one that spawned infinite horses, lol. When you are on a mission with a companion and call your horse, usually the game will spawn a horse for your companion too. In this case, the NPC couldn't decide between sharing a horse with me or getting their own, so I tried mounting the horse the game spawned for them. As a result, another horse appeared. I repeated the process until I had a whole herd lol

  • Gamebent
    ubisoft:x-posts, 26

    I encounter at least a dozen bugs/glitches every single day.
    Twice I got the blue screen random crash.
    Once I finished a quest while on a rowboat, and when I turned it in, the rowboat vanished and I fell in the water.
    Yesterday I had to follow an A.I. character on a mission. He stayed in the same motionless standing pose the whole time we traveled over land, jumped up onto rooftops, parkoured over rooftops, and arrived at the destination.
    During one mission, one of the A.I. characters didn't move his mouth one single time during cutscene dialogue.
    I could go on, but my fingers will get tired.
    This is the most disappointing Assassin's Creed game I've played, and I've played them all.

  • curtishard89
    ubisoft:x-posts, 13
  • curtishard89
    ubisoft:x-posts, 13

    Like this by any chance?

    Running RTX 3090, 4k, 120hz , running latest Nvidia driver.
    It's not game breaking, it's just annoying, seems to only happen within indoor areas.

  • xxxsnaz
    ubisoft:x-posts, 3

    I want to vinland and bought a [censored] bow, cuz the makers were lame and had me grind for 40hrs only to go to a new place and not be able to use my gear, and so I bought a bow there and now the bow function doesn't work at all. And I read I might have to restart the game. Bs industry built to sell newer parts I hate you! 40hrs wasted to go to vinland and lose me bow. Went back to England bow still doesn't work.

    I want my 60$ back I dont want to replay!

  • TheLegendher001
    ubisoft:x-posts, 2

    I had a glitch where enemies wouldn't attack me and it went away. Now I just can't talk to residents of the settlement. I'm 30+ hours in with so much exploring done and would hate to have to restart

  • TheLegendher001
    ubisoft:x-posts, 2

    I had a glitch where enemies wouldn't attack me, then a glitch where I can't talk to half the npcs in the settlement

  • TheRedHammer44
    ubisoft:x-posts, 4

    Glitches so far:
    Corrupted saved data happened 3 times. Lost around 6 hours of game play total.
    Trying to assassinate from above and froze mid air above target, had to map jump to fix.
    Horse spawned on back legs only, and ran around like that.
    Random floating object.
    Animation glitch when drinking potion to Asgard.
    Crashed a few times.
    Had Sigurd follow me around like a companion for a while.
    Was spotted while in a hay pile.

  • TheRedHammer44
    ubisoft:x-posts, 4

    Also during a Raid crew acted like raid was done and left me with one chest to open that requires crew. Could not start a new raid.

  • KeyAbuser
    ubisoft:x-posts, 1

    Cant finish the mission walls and shadows as stoke and erke dont reappear at the villa, restarting game/area does nothing

  • Hortense82
    ubisoft:x-posts, 5

    Found Nali the cat, won’t appear on ship after joining crew, never returns & now world event won’t complete, I just want symbol gone
    as it’s complete & won’t reset no matter what?

  • Janus_FIN
    ubisoft:x-posts, 3

    For me the drinking contest with Petra is bugging out. You start with Petra on the screen with Eivor vanished (it's the conversation scene). Then you get your horn hud, none for her, and eventually it loads the contest and you're about a horn down.

Suggested Topics