Welcome to discussions

Quick Suggestions

  • MissMDee
    4 posts

    @mechy01 this happened to me as well. In the first area before you leave to go to England

  • MattyPollo
    9 posts

    I cannot progress through the mission “Rumors of Ledecestre”. When I try to talk to Ceolbert I don’t have the option. He’s just standing in the church and I can’t interact with him. This is a game breaking bug as I cannot progress further into the game.

  • VanRaposU
    14 posts

    @janus_fin
    Same.
    Plus the orlog game is glitched. They just stare at each other and the game never begins lol

  • L8v3lyn
    39 posts

    @grundged isnt it correct? Not sure tho.

  • L8v3lyn
    39 posts

    @larrykop1967 u can raid again

  • JTN49
    1 posts

    Some time after starting an alliance quest with the people north of my camp, where you have to find out who the traitor is, I was able to assassinate any enemies without alerting the others. In areas where I should be attacked on sight, walking or killing in front of enemies did nothing and I was able to assassinate them right next to one another.

  • Splattersheep
    1 posts

    I'm stuck using a bow. After I shot an arrow I can't take out my axes, I can't jump or use any items.

  • trickjc
    4 posts

    I can't interact with some of my NPCs in Raventhorpe. I assume it started after the settlement raid by Rueds vikings, or after The Way of the Berserker mission, because that's what other people are saying. But I bought my shipwright when I got back to Raventhorpe and I can't talk to the woman out front. Also cannot talk to my barracks NPC or set up my jomsvikings.

  • Darkness2Kawaii
    1 posts

    I had a glitch with one of the main story missions where you need to kidnap the wife of one of the kings to find his location and when you capture her you need to carry her to camp outside of the fortress.
    So when I was carrying I noticed that I needed to cross water so I used a small boat and put her on it a few seconds later she obvious falls off and starts swimming, so I was like okay let me just grab her out of the water but you can't so she was literally swimming for 15 minutes and I was forced to wait till she was on the shore so I could grab her and when she almost reached the shore she was swimming to the other side of the lake so another 15 minutes of waiting.

    This has to be the most dumbest gamedesign in valhalla.
    So if it happens to anyone else just reload your latest save it is so much quicker.

  • Ehllfhire1
    86 posts

    @five20192020 the whole damned game is one giant dookie.

  • Almonatorr
    2 posts

    By chance bumped into Halfdan at Picheringa and spoke to him before I was supposed to for the quest 'Lost Glory'. As I progressed through the quest, I've been sent to speak to Halfdan and he just won't speak to me. I've tried to continue the quest anyway with help from a walkthrough as there aren't any quest prompts for it. It completely broke the quest. I've tried loading and fast travelling. Nothing seems to fix

  • sattium85
    72 posts

    There's an ability that lets you dual wield two handed weapons, the second scabbard there is for when you dual wield. Only issue is that it appears at all times even if you don't have a second two handed weapon equipped. Hopefully they'll fix that pronto, it's annoying.
    undefined

  • Hagen3162020
    3 posts

    Game freezes completely when I try to start the Lundun quest line. Freezes after the loading screen. Very frustrating, I cannot progress through the story. I’ve even tried going back to the settlement and completed a handful of other regions and then went back to Lundun. Still doesn’t work...

  • shyam3010
    84 posts

    @styl_fly Yeah I've experienced that problem with the 3 Grantebridgescire treasures too. Three individual small gold icons appear on the map in the river (very shallow so easy to navigate). I went to collect those three treasures but there's nothing there at all.

  • shyam3010
    84 posts

    @theredhammer44 Are you playing on PS4?

  • shyam3010
    84 posts

    @vanraposu Hey, have a look at the post I made a week ago regarding crashes on PS4. Would you say the same thing is happening for you?

  • Hagen3162020
    3 posts

    My game freezes every time I try to start the first mission for the Lundun Quest line. Tried multiple things and nothing works.

  • ImaginaryRuins
    385 posts

    Ha! Where should I begin?

    1. The torch sometimes doesn't have flame effect.
    2. Bjorn unassigned from the raiding crew automatically each time
    3. Leg. animal trophies no showing in Eivor's room
    4. Duplicated armors due to the tattooist shop
    5. 3 bugged treasure hoard maps (Ledecestrescire, Oxenfordscire, Ecescire)
    6. Several types of fish (big) not spawning at all
    7. Multiple keys not disappearing from Inventory after using them.
    8. Several quest items remaining in the Inventory after the quest lines
    9. Runes not sorted correctly in the Inventory
    10. Some main quests done are not showing their names and content in the log
    11. Codex (in the menu, not the item) is missing 1 Person, 1 Location, and 1 Faction
    12. Raven can still scan opals collected despite playing offline
    13. The wolf and fox companions in the settlement are gone
    14. Duplicated Asguardian ship cosmetics due to the fishing store


    Playing on Xbox One, patched 1.0.4

  • stanny91175
    1 posts

    Save error after killing The Scabbard A.K.A Leofgifu, the save data became corrupted and nothing else done in the game from this point has been saved.

    Secondly, the use horn tab does not call any vikings to assist the character.

  • lon_wolf917
    5 posts

    I Cannot finish the world event where you need to push or scare the man on the boat. The boat is there but no man on it. Any solutions?

Suggested Topics

Community Details

15
Online
131.1k
Users
22.7k
Topics
118.1k
Posts