Welcome to discussions

Quick Suggestions

  • theKosarev
    Original poster 17 posts

    @nophxgvn Oh my! 37 FPS! I've tested also on RTX 2070 Super Asus Rog in 4K @ Ultra (not ultra high), it was avg 55 FPS with i7-3820 ;))

  • theKosarev
    Original poster 17 posts

    Well... i7-3820 better than i7-10700K, hmmm ;))

    undefined

  • NoPhxGvn
    8 posts

    @thekosarev you have to keep the scaling at 1.0 or it's not an even comparison.

  • red1s_th3_n1nja
    1 posts

    My spec:

    CPU: i7 10700K
    GPU: MSI GeForce RTX 2060 Ventus OC 6GB
    RAM: 16GB DDR4 HyperX Fury RGB 3600Mhz (Dual Channel)
    Motherboard: MSI Z490 Tomahawk
    SSD: NVME Samsung EVO 970 1TB
    CPU Air Cooler: be quite Dark Rock Pro 4
    Power Supply: be quite System Power 9 600W
    Case: NZXT H710i

    HEY, UBI! How about some optimization? I hope a lot of patches come SOON? Bcs I CANT PLAY THIS GAME WITH 40-60 FPS DROPS EVEN ON LOW! ON MY RIG! OKAY?! I spend some money for a god dmn ULTIMATE edition. I was played Odyssey on Ultra settings with perfect and stable 70-90 FPS. Can i get at least 60 FPS on ULTRA? Not on LOW?!

  • Ehllfhire1
    86 posts

    @thekosarev indeed. They came expecting to crow about their card and they bought a pinto. My 2070 is handling everything maxed no issues.

  • longjohn119
    706 posts
    Yeah, man! You're right, I'm also playing in 4K but resolution set to x 0.70


    Yeah there seems to be a glitch in the auto setup routine that sets the resolution scale below 100% ..... I have a 2080 Super Seahawk X hybrid watercooled and was getting better framerates than Odyssey with the same basic settings and then I noticed it was set for 80% resolution so I cranked it back up to 100% and the framerates dropped to something more in line with what I get in Odyssey ..... It's weird because in some cutscenes it dips below 60 and some it's in the mid 70s but in gameplay it's been staying above 60 FPS ..... Because of the watercooling I have a little higher than normal performance for a 2080 Super because my temps are so low (about 53C) that my boost clock locks at 1995 Mhz all by itself .....

  • longjohn119
    706 posts
    And here is how it performed on my HTPC.

    10700K
    32GB RAM
    970 Evo Plus NVMe
    EVGA 2080 Super


    undefined


    Turn down Volumetric Clouds a notch and you should see some of the "hitching" ( those spikes in the graph) go away ..... You won't really notice any difference in visuals but the performance is much better .... Volumetric clouds is a real FPS killer and tends to Hitch a lot on max setting

  • theKosarev
    Original poster 17 posts

    @longjohn119 Thank you for that tip bro!

  • NoPhxGvn
    8 posts

    @longjohn119 I didn't plan to play with that low of a framerate. Just more of a comparison between my two systems at the same settings.

  • SinfulDanTheMan
    59 posts

    @diiorio have you tried keeping it on borderless instead of full screen? i can alt-tab out and back in no problem (on 2080 super)

Suggested Topics

Community Details

124
Online
218.7k
Users
36.9k
Topics
183.0k
Posts