Welcome to discussions

Quick Suggestions

  • blumpz
    8 posts

    Mine works, BUT it loves to disconnect every few minutes, therefor slowing down the game considerably along with it. That also being said, the Odin's Sight seems to cancel immediately after use. I don't know how they get these bugs when they have a new AC game out bout every year now. They're just carrying over a lot of the same code. So why do they still get major bugs such as these? Smh

  • lenx2000
    Original poster 10 posts

    How did you connect your controller?
    Do i have to assign it on the ubisoft connect?

  • RevoWution
    4 posts


    Same issue here. DualShock 4 works perfectly fine wirelessly via my PC's bluetooth connection for AC: Syndicate, but AC: Valhalla fails to even detect the controller.

    Both games are launched via Ubisoft Connect. Weird...

  • Goafar
    3 posts

    I've been trying to get my mouse to work, any mouse to work, I've tried every mouse I have and still can't pick a gender and move on with the game.
    I've just retired from work medically unfit and you can imagine this is doing wonders for my stress and anxiety.
    Get me out of bed when a patch comes will ya, otherwise I'm just retreating from the world.
    Yes, first world problem but it is still money and disappointment.

  • blumpz
    8 posts

    @lenx2000 was using xbox controller, not ps4. i didnt hit anything but the home button to turn it on. make sure its on before u start the game. some games dont recognize it if u wait til game is loaded before turning it on

  • blumpz
    8 posts


    I don't understand how this is an issue post-launch. On a game you release just about every single year. Smfh guys!!! You're slipping hard on this one!!!

  • Draeoth
    27 posts

    im having an issue with a wireless xbox one controller. if its connected before the game launches i end up waiting 15 minutes on the save icon screen and another 15 minutes after clicking continue. if i connect my controller after i loaded my save file the save icon screen is like 15 seconds and loading my save file is almost immediate. however shortly after the controller connects the game freezes and i have to use the task manager to close the game. i have tried going into the settings and changing the controller setting from hybrid to controller and it didnt solve the issue.

  • blumpz
    8 posts

    @ubi-spud it def doesn't resolve it. mine seems to do it more WITH the wire in it than without. 😕

  • diiorio
    40 posts

    Most pc games including this one is designed for the xbox one controller. It wil lsolve many of the patch through ps4 work around issues. So if you touch the controller it auto switches to it.

    Worth investing in one for the pc.

  • blumpz
    8 posts

    @diiorio I agree. Esp since Microsoft owns Xbox AND the Windows platforms both. But I'm having these issues as well as the guy with the PS4 controller and I use an Xbox 1 wireless controller. I've tried both wired and wireless setup for it and the issue happens MORE with the wire plugged in than without it and it does happen with the wireless mode, just not as frequent as when its hooked up via wire. I don't see how this major issue gets passed alpha, yet alone beta testing on a triple A title by a well established game production company such as Ubisoft and their Assassins creed games. I'm not just saying its a major issue because its MY issue either, but to have non-working controls for a game IS a major issue lol. Anyway, lets hope the devs on the UI Programming team can sort out this mess and get us all back on the path to Valhalla!

Suggested Topics

Community Details