Continue your odyssey

Welcome to discussion

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • SinnerTV
    7 posts

    @dukyyyy Yeah it's unbelieveablel. You should think that with such a big game company they would know how to make a game start up without bugs.

  • ur_mate
    Original poster 4 posts

    @sinnertv. It is weird becuase my mate has it on xbox with no issues. PC version cost $20 more in Australia and doesnt even load

  • Kalbsfleisch
    1 posts

    Yeah same here, just the picture with the two axes and nothing more, even after the Update and everything you can do for troubleshooting

  • SinnerTV
    7 posts

    @ur_mate It's wierd and i think it willt ake Ubisoft a long time to troubleshoot, because so many people got problems with the launcher start up acting differently.

  • Snowkevke
    4 posts

    Hi Guys,

    I had the same issue and i use a MSI gaming taptop.
    I closed Dragon Center, and that resolved the issue for me.
    I've read another post where they told you to shut down afterburner if you use that.

    Hope it helps for you.

  • uriah256
    3 posts

    Same here on PC. Pre-downloaded but still won't launch, says it is not available until 11/10/2020 - well it's 7AM, so it should have unlocked seven hours ago. Guess I'll have to try again after work, but it's going to be a looooong day waiting. Game companies should understand that people get excited for their games and pre-order them because want to play them when they release. I might only have an hour or two before work, but it would have been nice to set up the game, start a first mission, and look at it running a bit before having to head out.

  • K4tadiope
    3 posts

    @ur_mate I had the same issue. I checked the game files no problem detected but it won't launch.

    I desinstalled Ubi Connect and the game
    I force the reinstallation of the last NVIDIA drivers (the one for this game)
    I reinstalled Ubi Connect as an admin and reinstalled the game
    I launched it and now it works !!

    Hope it helps

    Intel(R) Core(TM) i7-9700 CPU @ 3.00GHz  3.00 GHz
    32,0 Go
    NVIDAI RTX 2070 SUPER

  • EfeTozan
    6 posts

    if you have ssd and game location is in hdd then it won't work. i had same trouble but i fixed it. transfer to ssd, select locate game in ubisoft connect, locate game in your ssd and play.

  • CoachSlippy0010
    1 posts

    It keeps saying thats its not available for me until 11/10/20 and I cant even get to the load screen, never had this problem with Steam what a freaking joke right now

  • Ubi-Swaggins
    Ubisoft Support Staff 340 posts

    Hey folks,

    I'm sorry to hear that you are encountering crashes when trying to launch the game.

    Can you raise a support ticket on our website with your MSinfo and DXDiag, so we can look into this further?

    Official Response
  • Dx2.LFT
    38 posts

    ubisoft is doing release stream on ubisoft nordic in twitch, all go to spam there mby they start to take this issue seriously and trying to even fix it

  • SinnerTV
    7 posts

    @ubi-swaggins IF you read what we say, ti is not a CRASH. It is a loading problem. It simply just stops loading the game, and freezes. therefore we do not have any crash logs to submit.

  • Chay_mo
    3 posts

    @ur_mate $20 more and absolutely no chance of a refund 😐

  • Sir_Aonarch
    2 posts

    My game isn't loading either.

    I tried adding a Windows Defender exception for the .exe and installed the newest C visual drivers.

  • SinnerTV
    7 posts

    @efetozan Insane that it actually makes a difference. But you are completly right. It now works for me. Thx!

  • SinnerTV
    7 posts

    @ur_mate Look at EfeTozan post. This might fix your problem.

  • K4tadiope
    3 posts

    @efetozan Yes you are right I forgot to mention that I moved the first install from HDD to SSD.

  • Sp1nM0ve
    1 posts

    Ymir ate too much ice cream

  • ur_mate
    Original poster 4 posts

    @ubi-swaggins I have tried to submit the sx and ms info file but there is no submit button.
    All it says is "* Chat is currently unavailable. Please choose another support method."

    Can you suggest how I log a ticket ?

    I went to this URL "https://support.ubisoft.com/en-AU/Cases/New"

    undefined

  • valentinbouthel
    1 posts


    hello I have encountered a small problem with the games
    the games do not want to launch it gives me an error message
    (unable to initialize graphics system. GPU does not support DX12)
    the configuration of my pc is an intel core i7 with a getforce gtx 960M graphics card
    I don't understand why the game doesn't want to start

Suggested Topics

Community Details

28
Online
128.7k
Users
22.2k
Topics
114.8k
Posts