Welcome to discussions

Quick Suggestions

  • TripWire_279A
    1 posts

    Well I play games on Steam, Origin and couple other launchers without ever having a game crash for any reason. Anything i play on ubisoft+ crashes constantly. Times vary 15 minutes to an hour or 2. Whatever the issue is its with the ubisoft system not my pc,drivers are all up to date clock is synced,files verified,overlay cloud stuff turned off,firewall off you name it i've checked it.Bottom line is it only happens with ubisoft that would be the clue. Just saying

  • guest-zNxIW5uM
    1 posts

    DANNEGGIATOCD IL XICE SOGNO IN MISSIONE LA FARE FA MI NON

  • Steventhegamer9
    1 posts

    My gane crashes every 20 minuts or so and it says that it mabye is because you need to update the game and software buth if already updated every thing so pls fix this

  • UltraBlacktiger
    6 posts

    Hey all,
    im playing AC valhalla on playstation 4 The game crashes at times so ive changed the resolution down to 1080i.

    im also having issues with the mysterious berserker mission. The bear won't move from the river. I've tried everything from reinstalling the game, database rebuild and since the update they haven't sorted it. I hope ubisoft put in a second patch in to sort this mess out.

  • DamasusIII
    1 posts

    I know many crash issues with AC Valhalla on PS4. When it occurs, it shows a blue screen with error and I have to restart. Always happen during an automatic save. But no save files are shown as corrupted. So I tried to clear cache, rebuilt the database, delete the app and reinstalling it, but the problem don't disappear. As I have 85 hours of game, I would like not to lose everything.
    Under 1.02, it used to crash only after I was able to go to Asgard, and then it could crash after around 4 hours of game. After 1.04, I hoped it would be resolved, as it was said that saving problems were corrected. But since the last update, it became worse. It crash in automatic save every 2 hours.

  • Blessi_
    1 posts

    My game crashes to desktop when I try to do the fury from the sea quest. After I talk to Finnr and the cut scene plays, it crashes.

  • JovialPompano12
    2 posts

    ive had issues with the game while playing lag mostly an quick game freezing here an there an didnt get to defend settlement played a few hrs longer to only liad back to that an fall through map

  • digidoggie18
    1 posts

    Brand new ps4 pro not even a month old.. getting full crashes every hour with error code ce-34870-0... Does it while playing, does it while scrolling through menu's and does it while cut scenes are playing. Also buttons do nothing sometimes and character gets stuck on flat ground sometimes.. this game is an absolute bug disaster almost like right before they revamped.. again.. frustrated that this is what we continue to get from ubisoft even with a day -3 patch 😡😡😡

  • Filippo_lipiffo
    1 posts

    @chilledcat hi, I have the same problem in digital copy but Olav doesn't move even if I close the game completely, what do you suggest to do?
    Thanks

  • Chento.D
    2 posts

    The Trouble Brewing segment titled: "Find and Rescue the Thegns" is bugged as heck! You rescue all of them, kill every guard, and they just follow you around. There's no dialogue, no map marker - nothing!

  • VILLARANGTAIV
    13 posts

    Same! Can't pick the Opal in Walden!!!

  • Ramis
    1 posts

    @shawbucks
    Restart the game or load from save file. This did fix the targeting bug for me, this is a problem in general not only for this key. This happen after i alt+tab to desktop. (PC)
    it is not a permanent solution but it reset the situation back to normal.

  • Satinata90
    1 posts

    @shadow-thomas

    guys, i have the same bug 😞 but it's getting worse. i did what others said and it worked (i used fast travelling and i spoke to the first Npc i have met - i was quite happy that everything was ok again.

    but, when i am moving forward with the story... or when i am reentering the game, the pitch black screen bug thingie appears again. And it's very frustrating... 😞

    also, i cannot manage to end this mission at all. The mad man appears to be unavailable...

    do you know a link where or whom can i write about this problem?

  • Bullis04
    2 posts

    @swd31102 i have the same exact issue (ps4) if you have figured it out please lmk!

  • Bullis04
    2 posts

    I have an issue where the shipyard, barracks, and stable no longer work. The icon to let me talk to them wont appear. I was hoping with the update it would patch it but it didnt. Any suggestions will be appreciated!
    (ps4)

  • ChefRP
    2 posts

    I can't progress in the game anymore because I am unable to assassinate the needle. He just stands there as I hit him and can't do anything else. I have done the other quest in the territory, and switched to different territories and back but nothing will work.

  • winston-spenny
    1 posts

    @ghost000016 have you solved your problem?because I have the same issues

  • Fursten13
    2 posts

    @chefrp i have the exactly same problem. It is so annoying! Tell me if you have fixed it

  • trevor.tarr
    1 posts

    I am on the mission where you have to defend the settlement after winning the ragnarsons allegiance. I originally died, when I respawned the mission had not started again so I did a different quest. Now when I start my game, it starts me at the defend mission but I only fall through the map and can do nothing else.

  • crewe52
    1 posts

    Have finished viking for hire contracts but cannot speak to reda no prompt appearing.

Suggested Topics