Welcome to discussions

Quick Suggestions

  • uncleBarry420
    2 posts

    Hey there haven't managed to get past first mission where you have to find your friends. When I get to near the peak of the snowy mountain it just freezes no error message or anything then crashes game. Also in the first cut scene when you are still young and village gets attacked it was very buggy the characters and items in the cut scene where all floating and going everywhere and audio would cut in and out. Hope some one can help. I have tried re installing.

  • Dswish62
    2 posts

    Playing quest - Brewing rebellion
    Mission - Reach Buckinghams longhouse
    I am unable to force open the doors to the longhouse. The NPC,s just stand there and will not move to help force the door open. I am unable to continue the mission.

  • Dswish62
    2 posts

    Bug/Glitch
    Playing Brewing rebellion
    Reach Buckinghams longhouse
    Cannot force open doors to the longhouse during mission, NPC,s just stand there and wont help force open the doors. Cannot continue mission

  • leeper21
    6 posts

    SO, I have made it to England with only some cosmetic bugs and minor glitches nothing to crazy, but shortly after i made it to England I can only get 1 to 2 hours of gameplay in before the game freezes and crashes ask me to send an error report then my SSD becomes unresponsive and I have to restart my computer to play anything off that drive. other games won't work western digital dashboard stops detecting it and windows also cant do anything with it tried it on 2 different drives the first one couldn't even boot the game to play before that would happen it would freeze my drive up loading the world in, has any one else had this problem?


  • leeper21
    6 posts

    Update Its Actually gotten worst it only takes 15 to 20 minutes now before it locks my SSD up and iv'e got to restart.

  • uncleBarry420
    2 posts

    Have a problem with realy buggy cut scene characters t posing and floating around during first scene I have a clip but cant upload for some reason my game is unplayable

  • gnbass
    2 posts

    One of my Jomsvikings has a weird symbol over their head, like an upside down tree. Ever since I noticed it I found i can no longer talk to the barracks lady or the longship people. I can't customize my ship or my raid team. Anyone have a fix?


  • ATwigForYou
    1 posts

    I can’t even call my horse/longboat. I can’t assassinate, or use my special attack. I’m on pc. And I’m pretty sure I’m not [censored]. I tried looking up known issues but the game is just too new so there’s nothing.

  • Dhampir_Lau
    1 posts

    Hello!

    I have came across this bug which is caused by one of the world events, "Mushroom madness".
    I spoke to the madman and I counted the stones 3 times and when Eivor went high on mushrooms my screen went completely black. I was able to still move and talk and I saw the world around me while using Odin's sight but after that everything went black again.
    It goes away when I talk to someone but comes back when I die or open my save.
    Please help this is driving me crazy, I've tried everything!
    I play with Xbox one.

  • elfkicker666
    3 posts

    I have been unable to force open the longhouse in Buckingham in the "Brewing Rebellion" quest. My companions are right next to the door, but aren't helping me opening when the "force open" command comes up. Have tried loading from previous saves, but I'm still having the same issue on my xbox one.

  • suti383
    3 posts

    Hi, I am playing AC Valhalla on Ubisoft for hours now and I am facing serious problems. Game stopped saving after a while besides the fact that I see saving icon im the game time to time. After desynchronization, main character started to wakenup at the same place, after the end of first Asgard mission, well travelled. And now main character is not moving, so playing the game is impossible. Besides the hours of lost of time, I cannot even walk. What should I do? 

  • huff5041
    1 posts

    The Mission Sons of Ragnar is stuck it would let me talk to Ubba. Have tried restating xbox and pledging to a different area and it still stuck.

  • EdgiestThrone49
    2 posts

    Playing assassins creed valhalla and my game crashed whist doing the walls of templebrough quest (playing on xbox one s) and I lost quite a lot of progress.
    Really frustrating. Before it crashed there were a few glitches and freezes aswell.

  • tommy-shots
    2 posts

    I have got to View Above All. First of all there were no enemies and the door wouldn't close. Turned it off last night and reloaded and I'm at the door surrounded all the enemies, including the main one, but the door still won't close.
    I have tried to close it when the enemies are all killed, with me killing the main enemy. I tried to close it when there I hadn't killed everyone but it still won't close.
    I'm 22 hours in but any save before this mission is 2 hours into the game.

  • tommy-shots
    2 posts

    @tommy-shots Playing on PS4

  • guest-M0XyiUqH
    1 posts

    @frozensypher I'm having trouble with my disc, it keeps saying dirty and spitting the disc out. I've tried a few times aswel it plays for abit then does it again. The ps4 plays other discs so must be just this game. What do I do to sort this out
    OK

  • KnightHawk8282
    4 posts

    I am now froze at the start menu can't get back into my game. Xbox one. It also thinks it is a pc version

  • gian22.
    1 posts

    Hi everyone,
    I have a problem in the animus anomaly near ragnarssons watch.
    The first ray that should be focused on the first unstable platform is turned away so i can't reach it...
    There is no way to complete it.

  • marram93
    3 posts

    The character's get stuck after the cutscene on Unwelcome after freeing the prisoners. I can't get past this scene. Tried old saves, re-validating files and still can't get past this bug. Can't play anymore of the game until this is fixed.

  • ArmChairWorrior
    1 posts

    Not sure if its just for me, but i am unable to activate the witch fight side quest in Spalda Fens, Grantebridgescire. Ive fought her before but when she killed me and i reloaded the option to fight her dissapeared.

    Side note: why is the Bear Claw Axe a Way of the Raven item and not Bear item like all the other pieces of the set?

Suggested Topics

Community Details

97
Online
141.8k
Users
25.0k
Topics
129.8k
Posts