Welcome to discussions

Quick Suggestions

  • gian22.
    1 posts

    Hi everyone,
    I have a problem in the animus anomaly near ragnarssons watch.
    The first ray that should be focused on the first unstable platform is turned away so i can't reach it...
    There is no way to complete it.

  • marram93
    3 posts

    The character's get stuck after the cutscene on Unwelcome after freeing the prisoners. I can't get past this scene. Tried old saves, re-validating files and still can't get past this bug. Can't play anymore of the game until this is fixed.

  • ArmChairWorrior
    1 posts

    Not sure if its just for me, but i am unable to activate the witch fight side quest in Spalda Fens, Grantebridgescire. Ive fought her before but when she killed me and i reloaded the option to fight her dissapeared.

    Side note: why is the Bear Claw Axe a Way of the Raven item and not Bear item like all the other pieces of the set?

  • anjokyn
    1 posts

    I am stuck when I have to chose male or female character.
    I hold the button A (xbox) and nothing happens

  • Danjodark
    1 posts

    The quest "stones of madness" is also buggy. The guy stands in the ring not out of this and he didnt transfer in to a stone and every rollback make the screen black and you must speak to somewhere you can see the normal vision but the quest is still buggy.

  • Vissenkom1107
    3 posts

    So apparantly this game is full of bugs. Pretty big ones too. To see a horse hoovering in the air is not the worse, but not being able to continue the game is unacceptable. I am stuck at Valkas Hut, Valka just stands there making some potion or whatever. I have read that as soon you enter the hut, a cutscene comes up. But nothing happens for me, plus a lot of other players as you can read. Why is this still not fixed? Why aren't you working on it? I paid €100 for this game!!!! Fix it goddamnit!!!

  • shadow.thomas
    1 posts
    Hello!

    I have came across this bug which is caused by one of the world events, "Mushroom madness".
    I spoke to the madman and I counted the stones 3 times and when Eivor went high on mushrooms my screen went completely black. I was able to still move and talk and I saw the world around me while using Odin's sight but after that everything went black again.
    It goes away when I talk to someone but comes back when I die or open my save.
    Please help this is driving me crazy, I've tried everything!
    I play with Xbox one.

    I have the same issue on the same platform. Fast travelling via Atlas and back again fixes this but it means I can't complete this world event.

  • Ayuzawanika
    1 posts

    @sebastian9240 same problem...

  • jt122506
    2 posts

    @shadowpenguin-8 I'm having the same issue! Like how did they do so bad at this game? Does no body test this? I broke asgard. And now I cant talk to ubba? Ridiculous. I want my money back for real!

  • jt122506
    2 posts

    This is such an unfinished game its honestly sad to see ubisoft fall apart so quickly from such a top tier game producer...to this?? Cant talk to ubba. By passed the jotun fight on the bridge and broke the game had to go to a previous save. If ubisoft is in need of testers I think they have alot to choose from right here in their own threads. This is so unacceptable! I have never posted about a ubisoft game but this is disappointing and I feel ripped off for the $80 I spent buying a beta basically.

  • Death128965
    1 posts

    Ok so stone of madness broke my game made it black i fixed that. Now I can't talk to npcs same cause the stone of madness [censored] [censored] quest.
    Are you guys at ubisoft fixing this or should I just return the game. Only other fix I've found is restart game file and after 40hrs I absolutely do not think that is viable fixing it? And patching it? Soon like today?

  • liselita90
    2 posts

    I'm stuck in defend your settlement. The game loads, but once it opens i just keep falling and die over and over again I can't move or do anything. Also the picture quality is horrible .I'm playing in a PS4. I tried to erase those saving and restart in an older save but it just keep happening the same. Other game games play fine.

  • ShadowStorm0420
    1 posts

    Playing on ps4 keep getting server crashed every ten to twenty min up tell today now the images are flashing. For instance the tree in the background keeps flashing off screen then reappearing green then normal color also the wolf I bought with helix credits spawned 4 more in the same area while working on the bakers quest as I returned with the crooks goods. Thoughts?

  • jacoblamar9
    1 posts

    Here’s a list of the bugs I’m dealing with and have found.

    -no auto save
    -no save offline
    -not able to manual save or having manual saves just straight up disappearing
    -error messages with seeing posted pictures online
    -unable to start “Bartering Quest”, both with Sigard and Ivar route
    -unable to obtain 50% of found mask
    -unable to obtain found opals
    -unable to obtain found runes
    -unable to use any “Y” (I’m on Xbox) interact button when talking to people

  • KnightKang
    1 posts

    After the mission “Love Betrayed” (where they burn the wicker man) the skull mask doesn't come off, anyone experiencing the same issue?

  • stef23462
    3 posts

    Hello all
    Homecoming quest, when you got to escort hunwald to his home, got to his front door and now he will not follow me or walk the last 2 yards, anyone else is having this problem ? Anyone knows a way to fix it

  • stef23462
    3 posts

    Hey
    The quest homecoming,
    Escorting hunwald home and soon as you get to his front door, he stops moving and just stands there and the quest disappears off the map but still there in your quest log
    Any help would be appreciated

  • EEs_Dartangnon
    1 posts

    My goodness, this game is great accept when it won't load and crashes constantly. Was hoping to play to escape on my lunch break and I am still waiting for the game to load. Now I don't have time to play. This happened a lot when it first launched as well .Help, how can we enjoy if it constantly crashes? The sound keeps cutting out as well.

  • GILLYBEAN1979
    1 posts

    Started the Sons of Ragnar storyline and currently stuck on Speak to Ubba....he is standing in the road. The boat has been upside down and now is on the castle keep. Cant speak to him or do anything!

  • That0neBiscit
    1 posts

    On the Xbox anytime I dive into water or even just touch water with the character model itself the game freezes then chrashes me game is up to date and my console too is this a known bug or is their a fix for this.

Suggested Topics