Welcome to discussions

Quick Suggestions

  • Hacsauce111
    Original poster 8 posts

    @cussingfawn969 I resolve the problem I look in my order history and saw that the Purchase got declined but for some reason it didn’t update till the next morning around 11 I had to repurchase the game works fine though another 119 dollars down the drain though I’d say it was worth it

  • Hacsauce111
    Original poster 8 posts

    @ubisoft I am haveing problem with on skill in the game called Bow to Melee link ever time I try to Acquire the skill it freezes up my game and it crashes [spoil alert] I am currently in Asgard as one of the dreams where it is happening idk if that has to do with it but none that less I’d like to get the skill but it won’t work freezes before I get it then I have to restart the game ig ima stay away from it till it hopefully get resolved in the next update hopefully it get fixed

  • XXXsuperdogXXX
    2 posts

    I’m on an older Xbox One.. it works on and off. But typically when I start the game, I get booted back to the Home Screen with a message “ give it another try, if you keep seeing this restart your Xbox press and hold the power button up to 10 seconds.. but that never works. Please fix this.

  • Ubi-Baron
    Ubisoft Support Staff 740 posts

    @xxxsuperdogxxx Thank you for reporting this to us.

    Are you using a physical version of the game or a digital version?

    Official Response
  • Reaper82184
    1 posts

    On xbox 1 when I go to launch the game it freezes at launch screen with AC emblem.
    Then it freezes my Xbox 1. Causing me to have to do a hard console reset. (NOT healthy for Xbox 1)
    I was playing it just fine the first day I got it. (digital download) Then the game froze in first chapter right after killing the "bad guy" and getting your revenge. Nothing worked to fix it except a hard reset of console. Tried reloading game and I get above problem of freezing at lunch screen every time... Only way to fix... Hard Reset...
    I have tried this 4 times now. Nothing is fixing it. Even uninstalled and reinstalled the game overnight. Still having same issue...

    Essentially this game has caused my Xbox 1 to not work. $100 wasted bc I can't play this game...

    Thank you.

  • guest-3pcZuaGx
    1 posts

    Can anyone help I’m using a disc version of Valhalla on a old Xbox one and it crashed on me mid mission now every time I try to load up the game I press a to start then it says checking for add one.and make me press start again

  • GKLogan
    1 posts

    I have an Xbox Series X and disc version of the game. It won’t load. Ir gets to the load screen showing the save icon, stays there for 15 seconds or so, then drops back to the Xbox Home Screen. I’ve checked for updates, I’ve restarted the console, I’ve ejected the disk and reinserted it. Nothing is working!

  • guest-mIFdQkSF
    1 posts

    This is happening to me as well. Instead of going to home screen it stays on a black screen, also before that when I was playing the game, the screen turns black and white and it won't come of until I talk to someone, also many other glitches

  • guest-Np06kMCv
    2 posts

    Logged in this morning and noticed corrupt save game data, logged out and now I cannot even log back in stuck on loading screen. I have logged completely out a few times and still same just hangs on loading screen. Not sure at this point what to do or try if anything other than to uninstall and reinstall and start over my worry of doing this will it happen again. ?

    Game I purchased Assassin Creed Valhalla Ultimate Edition. Current Version

    Console: Xbox Series S

    I have over 270 game hours played.

    Game Saved Data Currently Shows.

    My Account 20.2mb.
    Reserved Space Installed on Internal 32mb.

    Advice needed....

  • guest-Np06kMCv
    2 posts

    @guest-np06kmcv Ignore my previous post, all working ok and all corrupt save data resolved and logging in resolved.

    Not sure how this has changed. I went to UbiSoft customer support and followed the advice. unlinked and reset my password. When i went to load game AC Valhalla loaded ok and all corrupt save data gone and back to normal saved data. Or could be game was updating or servers down.

    Glad i have not got to restart I was very close of uninstalling game and restarting.

    ? Current game play 307H. Any advice on how it is best to save and can the game saves be backed up on thumb drive/usb

Suggested Topics

Community Details