Welcome to discussions

Quick Suggestions

  • Ubi-Baron
    Ubisoft Support Staff 730 posts

    Thank you for reporting this to us.

    The first thing we'd advise, if you haven't already is restoring the licenses via the steps in the guide here

    Official Response
  • duffjason
    1 posts

    @ubi-baron I have restored licenses but this did not work.

  • mj-MojoR1sing
    2 posts

    Same here, Hope that it gets fixed soon, bought the ultimate edition and didn't get any of my DLC. @Ubi-Baron How long could it take?

  • bitebug2003
    98 posts

    Same (PSN)

    In the Store - Owned tab, only the Ubisoft Connect Rewards are shown, but not the Berserker gear etc.

    I have reached England, and I would have expected them to be available now

    Restoring licences didn't solve the issues

  • Brynjar_Odinson
    22 posts

    i recieved my stuff. you have reach your home first and visit some of the people wich havbe a quest marker. then you recieve your preorder bonus

  • Sercan419095
    3 posts

    @ubi-baron
    Same here. Did all of that and nothing changed. Stili dont have the content

  • ndleoflex
    3 posts

    Same here, reached England. Even restarted the game from the beginning on a new save to try and reach the first point where we receive the berserker gear but no luck. I've done all of the things mentioned above. I have the ultimate edition on PS4 and it was also pre-ordered the PS Store. Hopefully this gets resolved soon and we won't have to start again from the beginning...

  • Brynjar_Odinson
    22 posts

    @ndleoflex really strange. ultimate version (PC) here and i recieved all after shipping to 1st village after freeing my crew

  • ndleoflex
    3 posts

    @brynjar_odinson I was wondering when I'll get the DLCs and then when I reached England I decided to look it up online and then I realized something's wrong.

  • Feldriar
    5 posts

    Super strange. Gonna make a new game and see if that resolves the issue. If not I'll let you know.

  • ndleoflex
    3 posts

    @feldriar no point, already tried that. Reached the quest after Family Matters and still nothing.

  • GUN08880
    3 posts

    Having the same problem on PS4, ultimate pack DLC's downloaded but nothing received yet. In England already. Is Ubisoft working on a solution?

  • Lexhen.
    2 posts

    @Ubi-Baron Yeah same tried to reload then restarted both after restoring the licenses and to no avail.
    none of the content i own is showned on the store, except the tatoos that you redeem for free.

    What's worse is that i m not sure if i should progress because if i have to restart to eventually unlock i would be heart broken...

  • GUN08880
    3 posts

    Resored licenses on PS4, did not work.

  • thunderwolf0909
    3 posts

    not work for me too. If i want to access on the extension menu i have the error : 0x20000015

  • CyberWolf-N7
    22 posts

    I'm not getting my content either , have sent support ticket ,
    Also in game store click buy helix you get error , must be there end issues ,
    No email either for way of berserker , no Beowulf dlc not showing up either .
    I'm PS4 to .

  • Tediz870102
    1 posts

    Same here not receiving dlc item, what the point fir the ultimate edition ?

  • Botil
    1 posts

    Same here, but content from Ubi connect is showing

  • gir1fromnowhere
    1 posts

    I pre ordered the ultimate edition physical copy and am having the same issues on ps4. I entered the code and all the packs are showing in my purchased section on the playstation store. All downloaded and installed. Just wanted to make sure you were aware it's a physical copy issue as well as it seems most of the posters here have the digital copy.

  • Krughal
    17 posts

    Same issue here. PS4 as well. Pre-ordered Collector's Edition, but no berserker gear or missions.
    They show up in playstation store, are installed, but the game does not recognise them.

Suggested Topics

Community Details

121
Online
142.4k
Users
25.2k
Topics
130.4k
Posts