Welcome to discussions

Quick Suggestions

  • GUN08880
    3 posts

    Having the same problem on PS4, ultimate pack DLC's downloaded but nothing received yet. In England already. Is Ubisoft working on a solution?

  • Lexhen.
    2 posts

    @Ubi-Baron Yeah same tried to reload then restarted both after restoring the licenses and to no avail.
    none of the content i own is showned on the store, except the tatoos that you redeem for free.

    What's worse is that i m not sure if i should progress because if i have to restart to eventually unlock i would be heart broken...

  • GUN08880
    3 posts

    Resored licenses on PS4, did not work.

  • thunderwolf0909
    3 posts

    not work for me too. If i want to access on the extension menu i have the error : 0x20000015

  • CyberWolf-N7
    22 posts

    I'm not getting my content either , have sent support ticket ,
    Also in game store click buy helix you get error , must be there end issues ,
    No email either for way of berserker , no Beowulf dlc not showing up either .
    I'm PS4 to .

  • Tediz870102
    1 posts

    Same here not receiving dlc item, what the point fir the ultimate edition ?

  • Botil
    1 posts

    Same here, but content from Ubi connect is showing

  • gir1fromnowhere
    1 posts

    I pre ordered the ultimate edition physical copy and am having the same issues on ps4. I entered the code and all the packs are showing in my purchased section on the playstation store. All downloaded and installed. Just wanted to make sure you were aware it's a physical copy issue as well as it seems most of the posters here have the digital copy.

  • Krughal
    17 posts

    Same issue here. PS4 as well. Pre-ordered Collector's Edition, but no berserker gear or missions.
    They show up in playstation store, are installed, but the game does not recognise them.

  • Feldriar
    5 posts

    @ndleoflex You were right haha. Read it too late and tried it. Oh well. In a Ubisoft Chat queue now, let’s see what comes out of there.

  • Feldriar
    5 posts

    Just got off the chat with Ubisoft Support and she told me she escalated it to the team behind the game. We can just continue playing the story as the add-ons will be downloaded as the bug is fixed. No need to start over!

  • Ubi-Spud
    Ubisoft Support Staff 704 posts

    Hey there! Can you let us know what you are missing, exactly? The Beserker set is usually added before you ever get to England, for example.

    Official Response
  • mj-MojoR1sing
    2 posts

    @feldriar Thanks mate, Hope they fix the bug soon and we all can enjoy our berseker pack and wolf buddy 😉

  • Mortiferous89
    3 posts

    Im missing everything included in the beserker pack, the gear, longship, settlement and runes. Im not sure if im missing the ultimate pack story missions as im not sure where to even pick those up at this stage

  • TheFlash0412019
    18 posts

    @ubi-spud I am also missing the beserker set for my ps4 I've done everything the information said to do

  • Feldriar
    5 posts

    Hello brothers,

    Ubisoft contacted me with a workaround. It worked for me!

    1. Start the game and spawn in
    2. While in-game, unplug your Ethernet cable (or go to system settings -> network settings -> connect to the internet and uncheck the box)
    3. Wait 5-10 seconds
    4. Plug the Ethernet cable back in or recheck that same box you unchecked in the network settings of your console.

    Good luck and have fun with your addons!

  • bitebug2003
    106 posts

    @feldriar I can confirm this works

    As soon as you switch off the network - the items / quests get added

    Thank you 🙂

  • Br1tish_Legacy
    10 posts


  • Iamvikingd4ve
    1 posts

    I too am missing items I got the collectors edition put in the codes on my ps4 and they haven't shown up in game

  • Lillithv
    1 posts

    I would like to add myself to the list of people missing items (PS4) - none of my stuff showed up 😞

Suggested Topics