Welcome to discussions

Quick Suggestions

  • Cruelbacon
    2 posts

    @drajzool I have this same bug, I'm stuck there now

  • gezajozsi
    1 posts

    Exact same thing... there is a setting supposedly that if you set everything to ultra and try loading it again it fixed it for me.
    Basically load the game back in ultra and try the sequence again. (just the resque part after the fight)
    Then readjust your settings. good luck chaps

  • Drajzool
    Original poster 4 posts

    @gezajozsi THIS WORKED BUT WHY. WHY DID THIS WORK. But thank you

  • Cruelbacon
    2 posts

    @gezajozsi *cries in GTX 1050*

  • Drajzool
    Original poster 4 posts

    @gezajozsi I also just found out the game runs smoother on Ultra High over Low. This game is weird.

  • klue-
    2 posts

    stuck here aswell. been trying to fix it since last night, currently reinstalling then i will try the ultra gfx swap method

  • LonelyGod64
    1 posts

    Same bug for me. I've tried everything I could think of, even starting up my save from Norway again and re-playing the Layla part. Every time it cuts to the loading screen it takes a very long time (Like 20 seconds on SSD) and then I get Eivor, Sigurd and Dag all standing inside each other, only able to use the pause menu, and put on/ take off my cloak. Was really looking forward to exploring England after 6+ hours in Norway lmao. Guess I should have just stayed with Harald.

  • klue-
    2 posts

    @klue reinstalling did nothing. so i switched to ultra gfx while i was stuck and for some reason it worked... idc how.. im finally playing again

  • J88020269b
    6 posts

    I'm literally stuck on the loading screen for Layla.. It doesn't load at all.. I can move the character around and switch the tips, but the main game does not load.

  • Drajzool
    Original poster 4 posts

    @lonelygod64 Read Gezajoszi's reply, swapping graphics to all ultra fixes the problem!

Suggested Topics

Community Details

125
Online
142.9k
Users
25.3k
Topics
131.1k
Posts