ubisoft discussions

Quick Suggestions

  • 55 Likes/1982 Replies/146076 Views
    5 posts

    Actually nothing.. To me it doesn't change anything the game is still crashing..it always crash to desktop no matter what..I will stop trying, i don't want to cause issue with the pc just for this game, it's a shame because we all paid money for a product that isn't working...

  • TAJ1964
    5 posts

    Having played the game, since it was launched last year, I have had no problems worthy mentioning - until after update 1.1.1 was uploaded a few weeks ago. Last week, my game crashed to the desktop twice. Yesterday, it crashed to the desktop 5 (five) times during less than 2 hours of gameplay.

    Several bugs and glitches have shown up on screen. Eivor cannot use certain stairs, without suddenly being not able to move forward - unless she climbs the walls instead. Eivor sometimes hover above the ground, when she kneels. Lumps of grass floating in midair. NPC stuck in cliffsides, treetrunks or housewalls. Or the most crazy one so far; tracking a zealot and chasing him down, only to find the guy lying dead on the ground - and his horse turning cartwheels high up in the air above him! Having confirmed "the kill", the horse stops moving, but stays put up in the air.

    Updated my graphics driver; did not solve the problem. Installed an older version of said driver; did not solve the problem. I am currently not able to play the game for more than 5 minutes, before it crashes. And I have no idea to the reason why....

  • Ubi-Mark.
    Ubisoft Support Staff 2941 posts

    Hello @TAJ1964,

    Sorry to hear about your experience.

    Can I kindly ask you to share with us your full PC specs? Additionally, can you please try the troubleshooting steps in this article? It will help to eliminate any potential software conflicts.

    Last but not least, can you please provide us with a few short videos showing these bugs you mentioned? Once received, we will be able to pass it along to the development team.

    If you have any additional questions, please let us know.

    Official Response
  • sonic_casper
    2 posts

    Broken/BUG! Mission: In The Abscence Of An Ealdorman.

    I have played almost 240 hours in this game and came to a standstill in the mentioned mission above. I have done what I always do in ALL Assassin's Creed games, exploring the world as soon as possible early on. In the mentioned mission I find the Ealdorman in the cellar of the castle and need to search for proof of his death. Unfortunately I have been there way before and took a brooch which is in my inventory. The mission still wants me to find some proof (which is that brooch) and because of that I cannot come further in the mission. I have completed every thing there is in the game except for some small side missions.

    I updated my game to the latest patch but it is still the same problem. When can I expect to get that bug fixed so I can continue the story?

    Thanks in advance
    Casper S.

  • Ubi-Wan
    Community Representative 636 posts

    @sonic_casper Hello there! Thanks for sharing, however please be sure to update the megathread dedicated to the issue you've mentioned with your report, as we'd like to keep all responses in one place! I'd also like to note that the issue itself is still under investigation at this time.

    Official Response
  • ildafkam
    12 posts

    The game crashes randomly - sometimes every few hours, sometimes more frequently. I can’t recall a game that has crashed so frequently and I’ve been playing computer/video games for over 24 years. Running it on a 10700K, RTX 2080 Super, Windows 10.

  • TAJ1964
    5 posts

    Morning, Ubi-Mark.

    Thank you for your answer. My specs are:

    AMD Ryzen 7 3800X 8 core CPU, 64 GB RAM, NVIDIA GeForce GTX 1070 8 GB, Windows 10 Pro 64 bit.

    I have been running the game for 80+ hours with graphics set to ultra high and experienced no problems - until mentioned bugs and glitches appeared.

    Sorry, I have no video or pictures of any of the incidents I have encountered. I will take a look at the troubleshooting, you recommended.


  • ildafkam
    12 posts

    Neither the latest patch nor the latest Nvidia driver (which is supposed to address an issue where the game crashes after extended gameplay) have helped.

  • TAJ1964
    5 posts

    Just to follow up on my first reply.

    Regarding specifications - forgot the motherboard. ASUS ROG STRIX X570-E Gaming.

    Ran a verification of the game files. Everything in order, no errors.

    No problems with my Ubisoft Connect or any other Ubisoft game - currently logged 405 hours with The Division and not encountered a single problem of any kind.

    I always run all my games with administrator rights.

    Background applications are at an absolute minimum - and I use a gaming booster with my videocard, that closes unnecessary system services and optimize memory.

    Tried to attach the latest DX Diagnostics, but apparently I do not have "the privileges" to do that...?


  • TraceCollins
    4 posts

    @ubisobuggy I have lost count of the CTD, freezes or totally resetting my computer I have had. Yes way to many technical issues to justify the money I paid for this train wreck of a game.

  • slopmyjoe
    1 posts

    Same issue, my PC is way above the recommended specs, game files are verified, all drivers are updated, i've tried RAM and CPU over and underclocks... nothing.
    It may be the propriety launcher which is causing the issue, looking at the log files i can see it disconnecting prior to the crashing. Further more as soon as it crashes out the launcher reconnects straight away.

  • Ubi-Mark.
    Ubisoft Support Staff 2941 posts

    Hello Vikings,

    Thank you for bringing this to our attention! This issue has been already reported and the development team is currently working on a fix! Once we have an update, we are going to let everyone know through the patch notes.

    Apologies for any inconvenience caused by this and if you have any additional questions, please let us know.

    Official Response
  • trickphilbert
    6 posts

    @nicksheperd I noticed the crashes too. I never had the crashes with Red Dead, Skyrim, Call of Duty, or Witcher 3, Dark Souls. I agree it must be Ubisoft.

  • RedIndianRobin
    188 posts

    @ubi-mark After 3 months you are finally addressing this. Holy [censored]!

  • Asryan2a
    73 posts

    Well after disabling overlay and all the game ran without crash for multiple sessions but I just got the same crash right now... same liverkernel 141

    @Ubi-Mark I've posted many times about it. I mailed the support as well and they asked me for more details. Details i've provided each time and after few days without answers I got an email saying you had no responses from me and thus the ticket will be closed. That's really annoying.

    But glad to see that 4 months after the release somone finally aknowledged there is a BIG issue with that game!

  • Keyzeey
    2 posts

    so i was playing the game fine for 2 days and now i cant get past a loading screen im glad to see its a issue with the game and not my pc

  • Durrf
    7 posts

    @ubi-mark Thank you!

  • WolfManViper75
    1 posts

    Is this the "Display driver nvlddmkm stopped responding and has successfully recovered." that displays in Event Viewer that crashes the game?

    This is why my game crashes, anyone able to fix this scenario or do I need a separate bug reported as I'm not sure if this is UbiSoft or Nvidia's issue?

    This is from GTX2060 .. . .

  • ChuckKatse
    353 posts
    This post is deleted!
  • ChuckKatse
    353 posts

    @wolfmanviper75 Same thing happening to me nvlddmkm stopped responding and successfully recovered. Use GeForce GTX 1070. Game Ready Driver 457.51 dated Dec 2, 2020. Any driver later than that causes screen flickering and glare when playing AC Valhalla. Tired the newest driver yesterday and still screen flickering and glare so I reverted back to 457.51. Game crashed a lot after that. Might have to do a clean install and see if that fixes the problem.

Suggested Topics