ubisoft discussions

Quick Suggestions

  • 55 Likes/1982 Replies/148177 Views
    A Former User
    0 posts

    @jetchon Hey there, really sorry to hear that the game is crashing. Could you please run through our PC troubleshooting guide, and contact us if the issue persists?

  • sunejoergensen
    20 posts

    Valhalla has now run butter smooth with no stutter, freeze, bsod or caches for 10 hours with this setup on my 3090/3900x (before is was unplayable):
    1. Remove all background task
    2. Run program with realtime priority
    3. See Hardware Unboxed video
    So for me it is not the graphics driver and beside Legions ran perfectly on my system for 40 hours and 100% completion.
    I have also noticed that on my system I can only start Ubisoft Connect in admin mode ...

  • NickSheperd
    Original poster 4 posts

    If you're experiencing frequent crashes on PC with Ubisoft+, check to make sure your PC's time-clock is synced up with your timezone. If it's off even by a minute, the Denuvo in the game gets really angry and force closes the game. I found this solution on reddit and it fixed the crashing for me.

  • Peystaz
    8 posts

    @sunejoergensen I have a 2070, that's maybe why we don't need the same thing to make the game running good 😉

    So far, only have one crash for 10 hours of playing so way much better than before 🐶

  • DaikengoXX
    2 posts

    To me: I player for 3 hours straight without anymore freezing.
    - I installed the latest Nvidia drivers using DDU
    - I updated Windows to the latest version.
    - High settings, 2560x1440, full scren, vsync and gSync activated through nv control panel, Rtx 2080 vanilla, I7 9700k, 32 GB RAM.
    The only annoying thing Is that mu GPU goes up to 100% when in game, CPU 60% only.
    I Hope It can be helpful to somebody sharing my settings.
    I Guess the game still needs a big optimization work GPU side.

  • TheOlympian78
    2 posts

    Hello folks

    Since launching the game for the first time on Tuesday, I have been having a lot of trouble getting it to consistently run for more than a few minutes at a time or, in some cases, even just launch it.

    I have encountered freezing in the following places:

    • At the title screen (before the main menu)
    • Right after pressing "A" to enter the menu (when the game is checking for additional content)
    • Before the main menu appears (black screen with blue loading icon)
    • After choosing to continue my game
    • In the loading screen where I can run around
    • Right after loading into the world
    • A few seconds/minutes after loading into the world
    • While roaming around the world

    Most of this was incidental (i.e. no apparent cause).

    Another instance: (Minor spoilers)

    About five of these instances also triggered the crash report window in Ubisoft Connect, and I made sure to send the report each time. The majority of the time, the game would freeze and not close out, and I would be forced to kill it in Task Manager. A few times the game freezed my entire PC (couldn't even move my mouse), and once I even got a Blue Screen of Death (didn't take down the error code, unfortunately).

    I've also encountered a Windows notification (or rather, several of them at once), telling me that "ACValhalla.exe has been blocked from accessing Graphics hardware". I have searched for solutions to this online, and have tried nearly all of them: added a custom timeout for the GPU in the Registry, ran Hardware Troubleshooting, and tried updating the graphics driver through Device Manager (Which just tells me I already have the latest drivers installed).

    A few times while trying to launch the game via Ubisoft Connect the smaller window that appears would have the default blue image instead of the AC:V one, and nothing would happen for a few minutes (after which I would close it). I suspect this is a Connect issue, and reinstalling the launcher usually fixes this for a few launch attempts.

    What I've tried:

    • Reinstalling Ubisoft Connect (6+ times)
    • Repairing VCRedist and rebooting (8+ times)
    • Restarting Windows (10+ times)
    • Verifying game files (8+ times)
    • Reinstalling the latest NVIDIA graphics drivers (2 times)
    • Reinstalling AC:V (2 times)
    • Deleting the \Documents\cache folder (8+ times)
    • Running the game as administrator (Both through the context menu and the ACValhalla.exe Compatibility Settings)
    • Running the game in compatibility mode for Windows 7 and 8
    • Enabling/Disabling fullscreen optimisations
    • Changing high DPI settings (Program DPI (set to "When I launch the program") and High DPI scaling override (set to "Application"))
    • Disabling any/all screen overlays (e.g. RivaTuner SS, Geforce Experience Overlay, etc.)

    One thing I haven't tried:

    • Doing a clean boot, as described in the Ubi FAQs. Will update this post once I have done this.

    Overall I've played about 12 hours, and spent about 6 hours trying to get the game to run. While all of this is very annoying, what I've been able to play has been fantastic, and I would much rather find a fix than stop playing.

    Another (possibly unrelated) issue: I'm getting almost the same performance (between 30 and 45 FPS) both at Low and at Max settings (1080p). Don't know how that works.

    Any help would be appreciated.

    CPU: AMD Ryzen 5 PRO 4650G w/ Radeon Graphics (3.69 GHz)
    GPU: MSI Armor GTX 1070 6GB (OC Edition, no further OC'ing done by me)
    RAM: 16GB (8 + 2x4 GB - Not an ideal setup, but all I have available at the moment)
    OS: Windows 10 Pro x64 (Build 18363)
    Graphics Driver: GeForce Game Ready Driver v457.30
    Game Version: 1.02
    Storage Device: HDD (Don't have enough space on my SSD to install the game there)

    dxdiag file: https://drive.google.com/file/d/18Nkn-ibTjLOXCnCt0pGhBWeOTTC0g0ol/view?usp=sharing: (https://drive.google.com/file/d/18Nkn-ibTjLOXCnCt0pGhBWeOTTC0g0ol/view?usp=sharing)
    msinfo file: https://drive.google.com/file/d/1LztgPRWmRVBR6JUdsOhfPyYoeo4-FhTp/view?usp=sharing: (https://drive.google.com/file/d/1LztgPRWmRVBR6JUdsOhfPyYoeo4-FhTp/view?usp=sharing)

  • TheOlympian78
    2 posts

    @theolympian78 Looks like I can't get the links to work properly... it's drive(dot)google(dot)com followed by the rest as it is written now.

  • babooshka_
    5 posts

    @emmaj95 Has anyone managed to find any solution?

  • MaciekEl
    1 posts

    I have the same issue. Played 10h until today's morning. The game freezes after 10-15seconds of playing, i have to shut the game down using task manager. Do i have to wait tor a patch?

  • andicole0
    4 posts

    It looks like it may be the latest version of Windows 10 Insider preview.

  • Ubi-Swaggins
    Community Manager 438 posts

    @andicole0 I am sorry to hear you have been running into start-up crashes.

    Is this crash on the splash screen of the game?

    Official Response
  • CriTCalH
    4 posts

    Exactly the same by me, but I don´t have Ubi+ and I don´t think that´s the problem. Just the game released too soon with many bugs. Maybe not 100% compatible with the newest hardware (RTX3080) 😞

  • CriTCalH
    4 posts

    @redindianrobin Unfortunately I can´t downgrade drivers, at least not to that release, they are so old to recognize RTX3080 :(. I am trying to downgrade at least 4 releases older than the newest one.

  • RedIndianRobin
    188 posts

    @critcalh Ah sorry to hear that man. Hopefully a new driver fixes this issue. Nvidia has been crap lately with their drivers.

  • andicole0
    4 posts

    @ubi-swaggins Yes, goes past Ubisoft Connect then the green splash screen and a crash before it goes full screen. If I revert to the previous version Win 10 Insider Preview it is OK.

  • residex9
    1 posts

    Hey Guys,

    anyone else got the issue that the game just freezes sometime? On release day all worked fine for me. But since the second day the game keeps freezing after a few minutes. All i can do from that moment is to kill the task. Also tried to run it as admin, different screen types etc.

    RTX 2080ti 12GB VRAM
    INTEL i7-9700k 3.60 GHz
    32 GB RAM

  • rcmedia69
    4 posts

    The game freezes and I can't proceed past the first couple of seconds of the game, sometimes the game doesn't load at all.
    The frame rate is incredibly slow and the audio sounds like everything is in slow motion... it's absolutely 100% unplayable in every sense of the word.
    I've done everything Ubisoft recommends as far as troubleshooting the problem (*I uninstalled, re-downloaded, re-installed, verified the game files, cleared the cache etc.... nothing helps).

    I'm using a late 2019 model top of the line Acer Nitro 5 with 32 GB GSkill DDR4 Gaming RAM, brand new Western Digital 'Black' PCI Nvme SSD drive, Nvidia GeForce GTX 1650, Intel i7-9750H CPU @ 2.60GHZ
    This computer never has problems with high end games until AC Valhalla.

    I tried to get a refund through Ubisoft but they have refused saying I have played the game too long so far (?)
    I have done nothing except try to get the game to actually run, which it won't at all.
    So I am calling Visa this morning to get a chargeback.
    I'd recommend others do the same as Ubisoft seems very unethical in their return policy.
    They cannot fight a VIsa chargeback.
    If your game doesn't work then you purchased a faulty product and Visa will give you your money back.

  • RuZty5
    1 posts

    Been having the same issues.

    Crashes every 10 minutes, some times I have to end the process through task manager, some times it crashes to desktop.
    It even crashed my whole computer a couple of times and restarted my whole system.

    I've updated the game, verified the game, updated drivers, turned off optimize fullscreen, white listed the program, ran it as administrator etc etc.

    Nothing helps 😞

  • emmaj95
    66 posts

    @babooshka_ I still have not yet

  • ThisIsFrostiK
    5 posts

    @rcmedia69 It is playable for me on PC but it has a lot of bugs... i7 8700K 16GB Ram RX 5700XT. Did you try to contact them via cus.support chat? I do believe that the problem lies somewhere with your laptop...The Nvme drive that you mentioned is it primary or secondary drive?

Suggested Topics