ubisoft discussions

Quick Suggestions

  • 55 Likes/1982 Replies/143049 Views
    2 posts

    Before 1.04 dropped, I rary experienced any crashes, at all. Ever.

    After it dropped, I can get them every few minutes.

    However, I generally found that I can play for a few more hours if I clear all the cache files in Valhalla's documents folder.

    With one big exception so far...

    I got all 11 tablets to get Excalibur, and when I get within 400 miles? Km? Whatever the numbers in this game mean...

    Whenever I get within the general vicinity of where the sword is, the game consistently crashes every single time I get too close.

    To help investigate the issue...

    I start from the south, at the synch point directly south of the nearby tablet cave... I pass that cave on my way there...

    And as I go up some hills and into some woods, the game crashes. Every. Single

    I've adjusted settings all I over the place, I'm currently having the game verify itself...

    But damn... this sword had better be really amazing if it apparently breaks the game this much. Xp

  • MadDoctor45
    2 posts


    The game has corrupted all but one of my save files and set me back by several HOURS

  • epheriss
    3 posts

    I have same problems. Before no game crashes. Now game is crashing in every 15 minuts. Duplicate items still not fixed. Remove this patch omg.

  • OzoneHeals
    22 posts

    @incabuloss same here. now it's just a waiting game to see if they fix it or not.

    1 posts

    Same problem here, on PC, I have 50+ hours zero crashes......after 1.04 it crashes every 5 mins.

  • epheriss
    3 posts

    They should remove this patch.

  • Suzuki-Stumpy
    2 posts

    Since today's update of Valhalla it's proving impossible for me to play for any length of time. Suffering constant crashes to desktop now whereas (apart from the occasional glitch) it worked perfectly fine on the previous patch.

  • Naltus99
    8 posts

    having same issue on ps5 version 40hrs wasted


  • killerpanties
    2 posts

    Thanks for nothing. The game started frequently freezing now after this patch. What did you do?!?! I'm fighting a templar, 3 reloads, and finally when I'm about to kill him the game freezes, that [censored] me off. Do something! Never had this level of incompetency with any of the Assassin's Creed games.

    The templar I was fighting was Kendall but I doubt that has anything to do with it.

  • Venusaurrrr
    1 posts

    So just downloaded the latest update. I get to the main menu. Press continue on my save

    In the world where your character is stood in the void with aurora sky that's all fine then the game just crashes to desktop

    Anyone else having this issue ?

  • sw78792
    1 posts

    @venusaurrrr I'm having the same issue with my game. I updated it and as soon as it seems like I'm leaving the void loading screen the game crashes. Looking on the forums it seems like it's happening everywhere on all devices: PC, Xbox, and PS.

  • four2nothin
    1 posts

    I know how it sounds weird but yes, I am VERY confident that my game is crashing because of my poor internet speeds.. I noticed both Assassin's Creed Valhalla and Watch Dogs Legion both run and work well when the internet isn't acting up, and RARELY crash. I can play for hours or all day without any issues. However, when my embarrassingly awful internet acts up to where I'm getting Dial up speeds (Lower than 1mbps), both games experience regular crashes. I am subscribed to Ubisoft Connect + and have installed both games through this app which is why I assume they crash at low speeds, however I don't understand why single player games would have this issue? And the crashes are ALWAYS random, never triggered by anything in particular.

    I know some might say to get better internet, and believe me, I would if I could. However, what I have is my only option.. (Satellite)

    Anyway, if somebody could please tell me if this happens to them also, or if there is a work around, or if by chance I AM wrong, how I might fix it that would be great! I've tried verifying integrity, updating graphics card, lowering graphics, and opening / forward ports to the best of my ability etc, but like I said; I'm confident it's because of low internet speeds. In fact, I've taken my computer to a friends with reliable internet and as far as I remember it NEVER crashed. Or at least, rarely.

    My PC:
    RTX 2070s
    Ryzen 7 3700x
    16gb RAM

  • matheryn11
    1 posts

    Ever since the last patch im getting crash to desktop with every one of my saves and have to send a crash report

  • AlphaPredator23
    1 posts

    Everyday my game freezes or crashes with no warning. It gets annoying and I just want to have fun and progress in the game. Please Help

  • Bob__Gnarly
    49 posts

    I would get the odd game freeze/crash before the latest patch, but now it's unplayable. Cannot raid or any big battle for that matter, the game will end up freezing requiring me to Ctrl + Alt + Del close the game. I have a well above average PC and should be able to play this game on max settings.

    I did not realise this was a full blown beta test, did I miss the fine print?

  • BonzoSPB
    17 posts

    @camokillo Patch applied - crashed after 10 minutes. I've a RTX 2070.

    I can safely say this is the most unreliable game I've ever experienced. I think at least 25% of my 9 hour gameplay has been repeating quests due to crashes.

    I get the sneaky feeling that the next Nvidia update will fix this.

  • mattfourmat
    2 posts

    I have tried everything, updated my GPU driver, downgraded them, someone suggested syncing my clock on windows i've done that, I have verified the files, now reinstalled the game, reduced graphics settings... submitted a support case with my DXdiag and msinfo but had no response at all.... not great

    my graphics card is a Sapphire Pulse 5700xt
    cpu ryzen 3900x

    Has anyone with this issue found a fix?

  • o8sideus
    10 posts

    I am in the same boat as you - although not as frequent. The game did not crash on me at all up until playing with 1.0.4, only a few bugs (sidequest from a dude in Ravensthorpe got bugged out, dual swap/weapon drop bug, and then fighting Fenrir, when he threw me in the air I teleported high in the sky across Asgard and was endlessly falling up there for a good 5 minutes while I smoked before I alt-F4'd and restarted the fight). Now, seems like the bugs that plagued everyone else are starting to hit me. Guess they wanted everyone to feel the pain.

  • OzoneHeals
    22 posts

    @incabuloss still can’t play the game since the 1.04 update

Suggested Topics