ubisoft discussions

Quick Suggestions

  • 55 Likes/1982 Replies/139832 Views
    5 posts

    I have the same problem. I'll be playing and occasionally it just quits to the title screen and I have lost my progress for the last 30 minutes or so. Really frustrating. Please let us manually save as well. Why is that so hard. You can do it in AC Odyssey. Such a huge oversight. Please change this.

  • mikeswcal
    5 posts

    Also fix the missing quest markers. When I map quest objective I should be able to see it on the map..sigh......

  • m0t0wnfilly
    2 posts

    My game freezes. i have to do a hard close on the game. I notice that when it freezes my memory is up pretty high. It does this quite often too. I'm on PC. It's getting to be a real pain. And I haven't gotten a crash report after waiting a couple of minutes to see if the game will just crash on it's own.

  • Tecchizzato
    4 posts

    Since 1.0.4 the games crashes every 90 minutes to me. I updated windows 10 and all the drivers. Got an i9 9900 and a 2080Ti. Drivers 457.51. The problem is that after a variable time close to 90 minutes the games freeze, the sound continues and after maybe 10 seconds pc reset to bios. It is and hard crash as windows doesn't save any log anywhere. Event viewer is clean, it just say system restarted. I never had this problem with 1.0.2. I did buy valhalla but i have also Uplay+ now. The thing i want to try is to have uplay connect on the second monitor to see if it is the cause of the crash, as for WD Legion when it crashes it looks like that is uplay connect fault.
    The thing i don't get is if Ubisoft at least is aware of the problem.

  • falo2k
    23 posts

    Yep, getting these crashes now since the latest patch. They were not an issue before - game just hard locks about 30-60 minutes in. Often seems to be after a save so I wonder if that's related.

  • k87965t
    1 posts

    I have been trying to complete the last missions of the main story mode, but the game freezes and forces me to manually end it via task manager. This is happening during pretty much any scripted dialogue meaning that i cannot progress any further. This is a big problem and is very frustrating.

  • camokillo
    13 posts

    Did anyone have any luck with the new Radeon drivers just released today? installing now..

  • uFamas
    25 posts

    I just did one of those rage inducing Cairns, validated it then took a screenshot and that caused the game to CTD.
    Upon loading the last save the Cairn stones are laying on the ground and I can do it all over again FFS 😠

  • uFamas
    25 posts

    Used Harpoon ability on a Zealot and the game hardlocked.

    Also just cleared the entire Thieves Warren camp and upon proceeding the quest the game once again CTD.
    Loaded back in and the entire camp is untouched as the last save is right before the camp.🙄

  • milkybandit
    5 posts

    At least you get something. Here's all I get on my screen, since nothing loads once I fast travel:


  • A Former User
    0 posts

    Hi everyone! I experienced the same problems you described after the 1.04 update with constant freezes after 15-20 minutes into the game. I have my old desktop PC with an i7 2600k and Nvidia 1060 OC, and a gaming laptop with Ryzen 9 4900 and RTX 2060. The solution that worked for my case is the following:

    • Update the drivers of your card.
    • Delete the cache directory in "My Documents>Assassin's Creed Valhallla>cache".
    • Play the game NOT in "Full Screen" but in "Borderless Windowed" mode and Vsync OFF
    • In the "Graphics" options choose a lower setting, in my case "High>Medium".
    • If the game asks for a new save, create a new manual save.

    After these settings, I can play more than 4 hours continuously without any of the aforementioned problems.

    I hope that helps. Stay safe and enjoy an otherwise fantastic game!

  • XenticPL
    3 posts

    Every 1 hour or so my game crashes after 1.04 update. It just freezes and I need to kill the process through menager.

    Before the patch 1.04 the game had never crashed.

    Any fix?

  • Coach811981
    40 posts

    Do you still hear sound when the game is frozen?

    Alot of people still have that issue amongst other things.

    There's a big thread on this, have a look when you have the time:

  • blemiglute
    9 posts

    @davidho719 Thx but i don't know how to do that.. i never turned it on myself anyway..
    Been playing 2 dayx without crashes, and when entering wincestre, 2 freezes every 10 minutes of playing...

  • xIHighVoltageIx
    4 posts

    Same error

    try this driver...they works fine for me...i dont know its a nvidia problem or valhalla problem

    Nvidia Driver 457.30

  • sattium85
    107 posts

    i have the same thing after patch 1.04 get random freezes, here is my theme

  • UbiKobold
    Ubisoft Support Staff 891 posts

    Hello, and I hope you all are having a good day! I am sorry that these crashes have been happening! Due to the error provided, please try re-installing the supporting software for your game. Afterwards, make sure to immediately restart your PC or the steps will not register as complete. Then, verify your game files and test your game out again.

    However, if this continues, please create a Support ticket and attach your MSinfo and DxDiag files.

    Official Response
  • shyam3010
    84 posts

    @rcviper047 Yeah, Valhalla is the problem. Too many people are experiencing crashes with this game for it to be down to anything else. I’ve instead been playing Skyrim and it hasn’t crashed AT ALL.

    Also, I’d strongly suggest you don’t play Valhalla until Ubisoft fix the crashing problem, since a lot of people are reporting that their saved data is being lost upon crash.

    I’ve made a post a week ago about the crashes, you might want to check it out

  • RCViper047
    17 posts

    @shyam3010 @UbiKobold @xIHighVoltageIx @sattium85

    I've noticed that the crashes/freezes I have reported isn't a rare problem...sadly.

    I did what UbiKobold wrote and made a reinstall of the support files (with pc restart, verifying files after new start). I want to say additionally that I have also an update of my gpu driver (nvidia 460.79) since yesterday.

    After I started Game in Launcher, I noticed that game installed the support files again....just for 1 or 2 seconds visible the installation bar.

    Ingame I was able to end the mission for Halfdan and to travel around without a crash. Played 30 minutes.

    Honestly, I cant say at this moment if UbiKobold's suggestion was the key or if I had just luck.

    Maybe I will try a few hours until the game would crash again. I would post again. Then I would stop to play ACV until Ubisoft found and fixed the problem.

  • Keelorpse
    3 posts

    @wanimar Still freezes on me frequently. Usually, just when I am about to defeat a zealot... This is probably the buggiest, glitchiest, most unstable PC game I've ever seen.

Suggested Topics