ubisoft discussions

Quick Suggestions

  • 55 Likes/1982 Replies/137959 Views
    Cheeriouss
    1 posts


    @Ubi-Woofer i am experiencing the Exact same crashes that @Parlagulf reported the the post above, on AC Valhalla.
    my setup is a rtx3080 with a ryzen 5600x.
    the game is unplayable, ive experienced the crashes playing for 5 minutes, and playing for 50mins, even hours, its totally random.
    Can you please fix this with a patch???? im questioning myself if i should buy the season pass or not, i will not for shure if this problem continues, since its unplayable, right?

  • Ubi-Viral
    Ubisoft Support Staff 2336 posts

    Hey folks. Sorry to hear that you have all been experiencing crashing issues. I have merged this thread with the mega thread about posting.

    If you are yet to please try the steps HERE.

    If your issue continues after this, please let us know.

    Thank you.

    Official Response
  • S7igma957
    173 posts

    @normski7a Just play more and you will see that nothing helps! I've tried disable GFE and launcher overlay and this is all useless! Game crashing randomly but only when you do something.
    I think all this crashed because of denuvo protection.

  • normski7a
    10 posts

    @s7igma957 I've played 5-6 hours the past 2 days. Not a single crash. I might just re-enable the overlay and turn on sharpening to test it out.

    **EDIT** I re-enabled the Geforce overlay and enabled sharpening through that, I was able to play fine. I then disabled the overlay again and enabled the same sharpening values through the nvidia control panel. Crashed after 10 minutes, guess I'll be removing the game .exe from nvidia control panel again.

  • S7igma957
    173 posts

    @normski7a I allredy have 3 crashes today when using skill Throwing Axe Fury.

    I think all those crashes because of denuvo. As i know this protectiion connected to animation.
    For example when i'm using Kick Of Tyr skill game never crash. It's sad that community need to post all this issues!
    I skiped playing and will be waiting for patch because this is horrible! I can't use skills i want because of crash!
    Ubisoft have huge team of testers, so let them do they work!




  • Macabraham
    12 posts

    @ubi-woofer

    I appreciate your effort, but I too suffer from this problem and while I can of course provide the requested files I can't help but wonder what's the point?

    • This issue isn't new in AC Valhalla, it's existed in previous AC games for years.
    • This topic is 11 months old and nothing is fixed.
    • How are we going to believe your developers will take PC gamers seriously when your CEO clearly dislikes PC gamers (to put it friendly)? He believes 95% of them are pirates and as such will never take them seriously, here's a source.


  • S7igma957
    173 posts

    Ok!
    GFE overlay disabled
    Game launcher overlay disabled

    Game keep crashing randomly! Are you kidding?
    I play many games, like Doom Eternal, Metro Exodus, Resident Evil Village, Wolfenstein with RT and DLSS on, and only AC Valhalla is crashind!

    I will not launch game again, until you patch the game!


  • kolliasl21
    10 posts

    After taking some time off AC Valhalla and playing other games without any issue, I decided to return and continue. After grinding for hours for ymir blood stones in jotunheim with just one crash, I finally reached the boss fight with Fenrir. I reached about 40% remaining health and then Fenrir got stuck underground... Very frustrating but ok. I had to reload from a savefile and try again. I reached about 40% health again and this time the game freezes!!! That's it. Uninstalled ubisoft connect and AC Valhalla immediately. With the same rig I did 220 hours of AC Odyssey without a single crash. What a waste of time and money. The game was 100% stable before 1.3.0. And I didn't do any changes at all on my system. Not even the graphics driver. After updating to 1.3.0 the game broke. I'm done with it.

  • S7igma957
    173 posts

    Disable ingame overlay in launcher helps me play without СTD.
    Tree days and not a single crash!
    GFE still on!

  • zylonq
    1 posts

    Hello, i bought ac Valhalla on 24/10/21 and I played it for 3 days until I couldn't start it up anymore.
    when I start it up in de Ubisoft connect launcher it shows me the splash screen/loading screen of ac Valhalla but after a few seconds, it crashes and closed the game with a message from Ubisoft launcher that it has crashed and sends a crash report.
    I have tried different things like updating drivers, verifying game, running as administrator, reinstalling, and more but it's still crashing when I start it up I also have the system requirements and it worked just fine for a few days

    Could you guys help me?
    Thanks in advance 

  • vviesturz
    1 posts

    have same problem

  • Dawn-Treader
    2 posts

    Just to confirm I have the same problem starting today. Tried restarting, verifying game files, even rolled back drivers. Nothing gets the game to launch without crashing.

  • enesteban
    1 posts

    same here, started today after the ubisoft connect october update.

  • arczicz
    2 posts

    @zylonq Hi guys. It's a temporary solution, but it works for me. Go to (Ubisoft Connect) Settings - General and uncheck "enable in-game overlay for supported games". Happy gaming!

  • Dawn-Treader
    2 posts

    @arczicz Thanks! That lets the game launch for me at least. So for now it is a solution.

  • remy_77760
    1 posts

    I have the same issue since UbisoftConnect update on 10/27/2028...

  • MaoSlayer69.LoW
    3 posts

    It could be ubisoft connect update or windows update which happened to be at the same day 27.10.2021

  • novaopus
    4 posts

    I have same problem did you solve ? it happens after ubisoft connect updates *27 oct releases.

  • novaopus
    4 posts

    AC valhalla and Far Cry 6 both games chrashes when home screen loading, it happens after new ubisoft connect version updated '27 oct version.

  • Braccobaldo4
    2 posts

    @novaopus i have save problem, i try reistall game but not work it, for AC Valhalla, and i try reinstall ubisoft connect but not solved
    Any one have solution for this problem




Suggested Topics