Continue your odyssey

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • chilledcat
    4 posts

    Same issue. Only a it's every 2ish hours of gameplay. It's so frustrating especially when it sends me back after just completing a quest causing me to have to redo most of it.

  • N00l3ilici0us
    4 posts

    It's the XMP setting in your bios that is causing this if I had to guess. I have the very same issue turned the XMP profile off in bios and viola.no more crashing. Ubi needs to fix this I have reported. Please repot this if it it your problem.

  • N00l3ilici0us
    4 posts

    @hergelee01 It's the XMP setting in your bios that is causing this if I had to guess. I have the very same issue turned the XMP profile off in bios and viola.no more crashing. Ubi needs to fix this I have reported. Please repot this if it is your problem.

  • N00l3ilici0us
    4 posts

    @ubi-swaggins It's the XMP setting in your bios that is causing this if I had to guess. I have the very same issue turned the XMP profile off in bios and viola.no more crashing. Ubi needs to fix this I have reported. how about pushing this up the chain of command?

  • RedIndianRobin
    186 posts

    @n00l3ilici0us This is possible. Some games are very sensitive to RAM overclocks. But then again, downgrading drivers eliminates all crashes so there's something wrong with API coding I reckon.

  • KATB0XSUICIDE
    6 posts

    @camokillo Same man. I can't get this thing to run for more than a few minutes. Tried even rolling back drivers for my 5700XT and nada...

  • ParadoxSax
    2 posts

    Increasing the swap helped me. I noticed that the game crashes when my 3GB swap is 100% full. Having increased the swap up to 6GB, the dropping stopped.

  • Badmad2008
    3 posts

    Can we change the button for laying an explosive trap to L3 instead of R3?
    It interferes with oden sight when around enemies.
    the traps blow up when any AI is around then including friendlies which ruins the trap and alerts enemies

    Also would like to see more options for settings allowing players to customize their experience in Valhalla (ie marking enemies with raven option, increasing difficulty/timing of parrying, making a drengr version of stealth etc) This was done recently with the Ghost Recon breakpoint update and would be greatly appreciated in Assassins Creed Valhalla.

  • nouvfrosch
    2 posts

    been playing fine for hours until yesterday, right around the time Reda's shop started to show nothing, and then when they release the new pack i believe? and after that my game would crash to desktop whenever they wanted, every so often. Quest breaking and not completing, mission not registering properly. I dont know if it's just coincide with the timing, but I somehow pretty sure it has something to do with the latest store update? But yea overall possibly due to ubisoft plus or something.

  • camokillo
    12 posts

    @krvolocan I too have noticed that after they updated I crashed less often. I've tried disconnecting my internet and going in offline mode. Seems to help a bit. Somewhat playable. Crashes even less frequently. Then I increased my virtual memory on my pc to be 8GB instead of the standard. That kind of helped too but the crashes are more now when I'm accessing the world map. It'll just freeze and minimize the application. SUCKS SO BAD DUDE!

  • camokillo
    12 posts

    Has anyone had luck with the new patch they just released today?

  • RedIndianRobin
    186 posts

    @camokillo Game crashed in loading screen with this patch with the latest drivers. I can play fine if I downgrade drivers.

  • KillerKabron
    1 posts

    Ive done a time sync, all files verified and checked my system, nothing is wrong, yet i crash 10 seconds while in game. Everything was ok the day before and now i have a broken game

  • camokillo
    12 posts

    @redindianrobin Do you have an nvidia card or Radeon?

  • camokillo
    12 posts

    @killerkabron what graphics card you got?

  • incubeezer
    1 posts
    @killerkabron what graphics card you got?


    I am on an RTX 3090 and I also experience crashes about a half hour in.

  • RedIndianRobin
    186 posts

    @camokillo Nvidia 1060 6GB.

  • teh_DK
    1 posts

    Getting constant freezes after the update today. Have never had a freeze before today, and now it happens consistently after what seems to be 10-15 minutes. (PC)

    Sucks.

  • azxd333
    2 posts

    what a joke of a company ubisoft is.. its been so long and still haven't figured it out.
    is there a way to request a refund for my ubisoft+ subscription ? this is ridiculous.
    either crashes at loading screen or 5 secs in or 5 mins in , BUT it always crashes. it might work with an RTX4090

  • azxd333
    2 posts

    @n00l3ilici0us
    didn't fix it, thanks for sharing though

Suggested topics

Community details

9
Online
123.2k
Users
21.2k
Topics
109.1k
Posts