Welcome to discussions

Quick Suggestions

  • kirbc
    14 posts

    @zherathos are you playing it through Ubisoft+?

  • longjohn119
    626 posts

    How many of you got the "Patch Tuesday" Windows Update??? I have mine on pause and I've only had one CTD and it didn't even throw up a "phone home" to Ubisoft message it just quit out of no where but no freezes ...... Couldn't get my troops to show up and help me in a raid but no freezes

  • Extra1ite
    7 posts

    DO SOMETHING WITH THAT
    undefined

  • Zherathos
    4 posts

    @kirbc Yes I am

  • kirbc
    14 posts

    @zherathos then don’t 😆 😭

  • Peystaz
    8 posts

    @kkhanz unfortunately, my PC is new and everything is fresh instal from monday night.

    Can't have more clean installation for everything actually 🙂

  • Zherathos
    4 posts

    @kirbc I am guessing the error is caused by some kind of DRM disconnecting me because it can't validate at all times? Would explain why I don't have any system error messages

  • kirbc
    14 posts

    @zherathos in all seriousness, Ubisoft doesn’t seem to care about it, watch dogs legion has it and people still has issues with it. Lesson learned, never pay Ubisoft plus to play brand new games, especially if those games comes with denuvo. Don’t know why you have to always be connected online to play it. I can understand having an internet connection every time you start the game. But having it to alway connect online is ridiculous. If youre disconnected denuvo crashes the game once you have been disconnected for more than 10 minutes

  • longjohn119
    626 posts

    @peystaz
    While that may be true if you didn't have Windows Updates on pause then you got an **mandatory** update Tuesday that took affect after you did a restart/reboot so it may not have had an affect until Wednesday when everyone seems to have suddenly started having problems ...... Go in Settings --> Updates and Security --> View Update History and I bet you have an update

  • Bondkek
    2 posts

    @kirbc yup ubisoft+ here also

    hope it will be fixed next patch cuz i think im gonna love this game

  • Sipi_Hun
    1 posts

    same here freezing game

  • longjohn119
    626 posts

    @longjohn119
    Other things that may help (and certainly won't hurt) is to go into Windows Defender and make an exclusion for the Valhalla folder ..... Also it would be helpful to know basic system specs because Intel CPUs got a big microcode update in Tuesday's Windows Update .... There was 112 fixes in this update so it's likely a couple of them are buggy and have unintended consequences Microsoft missed

  • allijaytor
    12 posts

    game freezes, i was just climbing mountains and now it freezes...it happened thrice now anyone who encountered this?

  • Woodsghostman
    1 posts

    Same here, Ryzen 5 2nd Gen, RTX 2060, 32GB ram.
    I've started the game yesterday so i'm still stuck in the first village.
    Unplayable.

  • Peystaz
    8 posts

    @longjohn119
    yes indeed, some updates are here.

    And didn't activate automatic back up (yes rookie mystake ;)). So will not be able to test before this update. Will see if I want to try to reinstal windows from scratch or not to test that.
    thanks for you time.

  • allijaytor
    12 posts

    they need to fix these bugs asap...damn, 1 min into game and it freezes! tried everything but to no avail.... i guess i wont be playing the game until they fix the bugs zzzzzzzzzz

  • TheWitchDoctorr
    1 posts

    @nicksheperd

    Hi everyone, have been having this trouble since launch, exactly the same as describes, played the game for 30mins then crash to desktop but the program was still open and music could still be heard. The fix that worked for me was rolling back the drivers from beta Radeon drivers to the previous stable driver version, haven't crashed since. I also reduced some of the settings in certain areas which makes the game run at a stable 65-70FPS on a Ryzen 7 3700x and a RX 5700XT at 1440p.

    Hope this helps someone out there, good luck.

  • CloakedDrifter
    3 posts

    @thewitchdoctorr I have the same build. Are you talking about the 20.9.1 drivers being the latest stable? That's what I'm using. All settings are default or off in Adrenalin software. Any other settings info you'd be willing to offer that might help? Maybe I'll just do a clean reinstall of gpu drivers, even though I haven't changed anything since I originally clean-installed them a few weeks ago.

  • PrinceznaAriel
    3 posts

    @thewitchdoctorr its not our problem i think.. we have problem with Ubi+ cause we have problem with connection lost to ubi server and our game crashed if doesnt connected. but thank u for help.

  • Ubi-Swaggins
    Ubisoft Support Staff 420 posts

    Hey folks,

    Sorry to hear that you are encountering crashes while using Uplay+

    Can you provide us with your MSinfo and DXDiag files via our support website?

    Official Response

Suggested Topics

Community Details

57
Online
196.4k
Users
33.3k
Topics
166.2k
Posts