Welcome to discussions

Quick Suggestions

  • Zherathos
    4 posts

    @kirbc I am guessing the error is caused by some kind of DRM disconnecting me because it can't validate at all times? Would explain why I don't have any system error messages

  • kirbc
    14 posts

    @zherathos in all seriousness, Ubisoft doesn’t seem to care about it, watch dogs legion has it and people still has issues with it. Lesson learned, never pay Ubisoft plus to play brand new games, especially if those games comes with denuvo. Don’t know why you have to always be connected online to play it. I can understand having an internet connection every time you start the game. But having it to alway connect online is ridiculous. If youre disconnected denuvo crashes the game once you have been disconnected for more than 10 minutes

  • longjohn119
    609 posts

    @peystaz
    While that may be true if you didn't have Windows Updates on pause then you got an **mandatory** update Tuesday that took affect after you did a restart/reboot so it may not have had an affect until Wednesday when everyone seems to have suddenly started having problems ...... Go in Settings --> Updates and Security --> View Update History and I bet you have an update

  • Bondkek
    2 posts

    @kirbc yup ubisoft+ here also

    hope it will be fixed next patch cuz i think im gonna love this game

  • Sipi_Hun
    1 posts

    same here freezing game

  • longjohn119
    609 posts

    @longjohn119
    Other things that may help (and certainly won't hurt) is to go into Windows Defender and make an exclusion for the Valhalla folder ..... Also it would be helpful to know basic system specs because Intel CPUs got a big microcode update in Tuesday's Windows Update .... There was 112 fixes in this update so it's likely a couple of them are buggy and have unintended consequences Microsoft missed

  • allijaytor
    12 posts

    game freezes, i was just climbing mountains and now it freezes...it happened thrice now anyone who encountered this?

  • Woodsghostman
    1 posts

    Same here, Ryzen 5 2nd Gen, RTX 2060, 32GB ram.
    I've started the game yesterday so i'm still stuck in the first village.
    Unplayable.

  • Peystaz
    8 posts

    @longjohn119
    yes indeed, some updates are here.

    And didn't activate automatic back up (yes rookie mystake ;)). So will not be able to test before this update. Will see if I want to try to reinstal windows from scratch or not to test that.
    thanks for you time.

  • allijaytor
    12 posts

    they need to fix these bugs asap...damn, 1 min into game and it freezes! tried everything but to no avail.... i guess i wont be playing the game until they fix the bugs zzzzzzzzzz

  • TheWitchDoctorr
    1 posts

    @nicksheperd

    Hi everyone, have been having this trouble since launch, exactly the same as describes, played the game for 30mins then crash to desktop but the program was still open and music could still be heard. The fix that worked for me was rolling back the drivers from beta Radeon drivers to the previous stable driver version, haven't crashed since. I also reduced some of the settings in certain areas which makes the game run at a stable 65-70FPS on a Ryzen 7 3700x and a RX 5700XT at 1440p.

    Hope this helps someone out there, good luck.

  • CloakedDrifter
    3 posts

    @thewitchdoctorr I have the same build. Are you talking about the 20.9.1 drivers being the latest stable? That's what I'm using. All settings are default or off in Adrenalin software. Any other settings info you'd be willing to offer that might help? Maybe I'll just do a clean reinstall of gpu drivers, even though I haven't changed anything since I originally clean-installed them a few weeks ago.

  • PrinceznaAriel
    3 posts

    @thewitchdoctorr its not our problem i think.. we have problem with Ubi+ cause we have problem with connection lost to ubi server and our game crashed if doesnt connected. but thank u for help.

  • Ubi-Swaggins
    Ubisoft Support Staff 420 posts

    Hey folks,

    Sorry to hear that you are encountering crashes while using Uplay+

    Can you provide us with your MSinfo and DXDiag files via our support website?

    Official Response
  • jetchon
    3 posts

    Q.Q I thought $20 was a steal for $1000 worth of games, loving the game too 😢

  • KKhanz
    3 posts

    @peystaz damn that sucks. I actually upgraded my GPU to NVIDIA RTX 2080 super and PSU on monday as well as added an SSD, and was freezing consistently. I think part of the problem was that in the task managar, the % GPU usage for Ac valhalla never went above 0.1% (and i think it still doesnt). But the clean install for my drivers fixed the problem for me.

  • sunejoergensen
    13 posts

    I have RTX 3090 and AMD 3900x with 32GB where Watchdog Legions has run butter smooth with raytracing for 40 hours and 100% completion.
    Valhalla is a complete mess not in the GPU where its stable 17-21 ms in Ultra 5120x1440, but in the CPU where it was up to 200 msec (average 16% load) equal 5 fps, totally unacceptable.

    Removing Rivatuner, Afterburner, iCUE and all other background "stuff" did help a lot, but this has not been a problem ever also not in e.g. Origin and Odyssey.

    But it still goes into a freeze every 30 min or so and can only be killed in the task manager.

    BTW: Running from a NVMe the total load time is less than 10 sec.

  • Ryuukaze_Ichi
    4 posts

    I'm on Uplay+ as well.

    In my case, I *know* there's an internet problem that I can't solve.

    I haven't had the issue in the last couple days, probably because my ISP finally fixed the problem. Or at least, it isn't as bad.

    But in the future, I don't want my game to just crash if I lose internet connection unexpectedly. I don't think the game should exit in that case.

    I could understand if you have an always-only requirement for Uplay+, but in that case maybe you just pause the game until the connection returns? It's much better than losing my progress for something out of my control.

    If you guys have server problems and all your Uplay+ customers can't play, I think it'll get pretty ugly.

    So far, if this is related to Uplay+, this is the only real downside I've found for the system. I'm on XB Game Pass, too, and they don't have this problem.

  • longjohn119
    609 posts
    I have RTX 3090 and AMD 3900x with 32GB where Watchdog Legions has run butter smooth with raytracing for 40 hours and 100% completion.
    Valhalla is a complete mess not in the GPU where its stable 17-21 ms in Ultra 5120x1440, but in the CPU where it was up to 200 msec (average 16% load) equal 5 fps, totally unacceptable.

    Removing Rivatuner, Afterburner, iCUE and all other background "stuff" did help a lot, but this has not been a problem ever also not in e.g. Origin and Odyssey.

    But it still goes into a freeze every 30 min or so and can only be killed in the task manager.

    BTW: Running from a NVMe the total load time is less than 10 sec.


    Try turning down Volumetric Clouds a notch, for some reason the highest setting causes hitching/stuttering with the CPU and you;ll see a lot of spikes in the CPU graph..... I noticed that the first time I ran the benchmark and dropping down a notch fixed it for me

    RTC 2080 Super Seahawk X hybrid watercooled R7 3700X CPU X570 MB 32 GB 3600 DDR

  • SoulBrotherNr3
    20 posts

    @nikosbe83 hey man, same thing happens to me, can't seem to figure it out

    enough ram, low temps, i don't get it.

Suggested Topics

Community Details

41
Online
192.3k
Users
32.4k
Topics
162.1k
Posts