Welcome to discussions

Quick Suggestions

  • goot_official
    1 posts

    My game was running absolutely fine on launch and the days after but today for some reason, I launch the game, click continue, start moving for 5 seconds and then the game quits to desktop without an error message or ability to send a crash report. I have restarted the game, validated the files and reinstalled the entire game with the same issues.

    While my PC is quite low-spec, the fact it was working for a couple of days proves that isnt the issue.
    CPU: Intel Core i5 9th Gen
    GPU: GTX 1050
    RAM: 8GB DDR4
    STORAGE: 500GB SSD.

  • Ubi-Spud
    Ubisoft Support Staff 702 posts

    Hey there, thanks for getting in touch! I'm sorry that the game is crashing, especially after working previously! Could please try a clean boot, and then this FAQ if that fails?

    Official Response
  • Zherathos
    4 posts

    @kirbc Yesterday I bought the game cause my Uplay+ was running out and decided to cancel my subscription because I rarely play Ubisoft+ games (combined with the crashing issues for both AC and Watch Dogs Legion it made it easier to do so). I played all night without a single crash or hickup so I guess this confirms that it is most likely to have been caused because of it disconnecting me. Thanks for your reply btw, I haven't heard a single thing from Ubisoft, I can't expect them to respond instantly ofcourse but I tried sending mails and contacting customer support but I haven't received one response yet.

  • Ubi-Spud
    Ubisoft Support Staff 702 posts

    Hey there, thanks for getting in touch! I'm sorry that the game is no longer launching. Could you please run through the steps outlined in our guide, and get back to us if the issue persists? 🙂

    Official Response
  • Eisvogel63
    1 posts

    Re: [Unable to launch the game at all](/topic/79172/unable-to-launch-the-game-at-all)

    Have the same problems, can't start the game.

    Want my money back!

  • palmerc309
    3 posts

    @ubi-spud I will try it out today, I use HWinfo64 and my CPU does no run hotter than 70 C and my GPU 65 C I am on a full custom loop. I will try monitoring with F1 and report back. Thanks for the quick response!

  • spamtomas
    1 posts

    exact same issue, game just closes itself, uplay shows disconnected then reconnects, Dont get this with other uplay games,watchdogs for instance plays for hours no issues

  • palmerc309
    3 posts

    @Ubi-Spud I just tested it out with F1 and it did not have my CPU temps but my GPU temps were max 56 C. Again this does not happen in any other game.

  • kalpdal86
    8 posts

    @valantorcid I also downgraded after reading your post and it worked. Have been playing for 5 hours without any crashes. The latest Nvidia driver seems to be the problem.

  • Psych0_Trauma
    59 posts

    Guys, it's not the drivers, it's the patch. Regardless of that, there is an issue with the environment textures that is causing a memory leak. Drop it down to medium or high, I know that sucks...but with them not ever putting achievements into this game i'm not surprised they screwed something else up.

  • Ubi-Ginge
    Ubisoft Support Staff 257 posts
    Temporary solution is to play in borderless mode. Playing in borderless won't outright crash the game but it will freeze it and when it does, tap the Windows key and the game will unfreeze. The game doesn't freeze/crash at all in Windowed mode though.


    Thanks for sharing this information RedIndianRobin
    Hopefully this helps other players as well

    Official Response
  • Sunqfu.
    7 posts

    @kynahret I am having the same problem. This problem should be resolved as soon as possible.

  • toadman13
    1 posts

    Mine freezes in the inventory menu.

  • Sunqfu.
    7 posts

    @toadman13 my game randomly freezes and minimizes and only cursor remains on the screen. It doesn't fix without closing the game from the task manager.

  • CrutonCruiser
    4 posts

    @peystaz debug mode worked for me!!! FINALLY!!! I tried everything. Thank you so very much

  • andicole0
    4 posts

    Managed to get started the last couple of days but today it crashes during start up. What's going on? my PC is a dedicated games pc and the last thing I did was to play Valhalla, now it won't start!

  • Oatsoda1981
    6 posts

    @ubi-ginge It didn't work for me. I've been playing in borderless mode. I do hope it helps some out thought because this is insanely frustrating.

  • NiX1080
    2 posts

    I am experiencing the same issue. If I play in borderless as was suggested here earlier then the cut scenes dont load for me 50% of the time. So I either crash every 10 mins of game play, or I cant progress in the game. This launch is giving me flashbacks to Unities PC release....

  • emmaj95
    66 posts

    @andicole0 Many many people have had this issue since day 1, but now that the game has been out for a few days it looks like more people are reporting the issue despite having been able to start the game before. Its really weird and Ubisoft has yet to address the problem.

  • longjohn119
    616 posts
    @peystaz debug mode worked for me!!! FINALLY!!! I tried everything. Thank you so very much

    That's a sign it's a problem with the drivers and the RTX 3000 series ..... You should put in a ticket with Nvidia so they are aware and can release a patch or fix it in the next regular update .....

    It's quite common for this to happen with a new generation of graphics card and new games but Nvidia is pretty good about fixing these kinds of issues unlike AMD which is why I recently switched back after all the issues I had with a RX 5700 .... Unfortunately that meant a used 2080 Super but it's one of the better ones and it boosts to 1995 Mhz and stay there for hours without an overclock so it performs pretty good .... I'm not having any performance problems and it's as good as I get with Odyssey, for me it's all the other bugs and a completely broken Aim Assist as to why I won't be playing it anymore until it's patched .... I'd rather wait a week or two than have an otherwise good experience ruined by bugs ......

Suggested Topics

Community Details

114
Online
193.1k
Users
32.6k
Topics
162.9k
Posts