Continue your odyssey

Welcome to discussion

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • RuZty5
    1 posts

    Been having the same issues.

    Crashes every 10 minutes, some times I have to end the process through task manager, some times it crashes to desktop.
    It even crashed my whole computer a couple of times and restarted my whole system.

    I've updated the game, verified the game, updated drivers, turned off optimize fullscreen, white listed the program, ran it as administrator etc etc.

    Nothing helps 😞

  • emmaj95
    66 posts

    @babooshka_ I still have not yet

  • FrostiK-rus
    5 posts

    @rcmedia69 It is playable for me on PC but it has a lot of bugs... i7 8700K 16GB Ram RX 5700XT. Did you try to contact them via cus.support chat? I do believe that the problem lies somewhere with your laptop...The Nvme drive that you mentioned is it primary or secondary drive?

  • rcmedia69
    4 posts

    @frostik-rus the WD Black NVME SSD drive is my primary drive and it's the same drive where Windows is installed (*it's a 2TB SSD).
    .

  • babooshka_
    5 posts

    @emmaj95 This is a joke. And not a funny one. Ubisoft should get it together. This is not what I paid for while subscribing to uplay+.

  • olmstead88
    2 posts
    This post is deleted!
  • CriTCalH
    4 posts

    @axesdenyed Welcome to our crew, we all have the same problem :). U can try synchronize time zone with your local time like someone said before but honestly I don´t think it can help.

  • DRock_Kill
    3 posts

    Here I have the same issues, downgrade driver doesn't work for me...

  • LordCaliban007
    2 posts

    Same issues here. I've been playing fine since launch day with no real issues. Good Framerates, no issues with quests or anything and I put about 14 hours in so far. Last night the game freezes on me on exit and I had to use the keyboard in Task Manager to force close it. Try to start it up today and it crashes on the launcher. I've tried verifying files, uninstall/reinstall, graphics card reinstall, repairing the distribution files, etc. Nothing is working to even get back into the game.

  • R3dl1nes
    5 posts

    @lordcaliban007 am having this SAME issue no real issues until i got pass that 29 hr mark then game freezes and locks or crashes to desktop i do send the error reports in too i cant seem to get it working either

  • BnnZzzZZ
    1 posts

    I'm unable to play this game. It randomly freezes with sound on the background.
    I had to open task manager to close it. Sometime, i had to restart.

    Give us a patch.

  • Ryk0s
    2 posts

    @shetland_pony I'm having the same exact problem. Odd thing is though is that I played off and on for the last 3 days and had like one crash. Today I have had... uncountable freezes, 90% during dialog. I have changed every setting and back again, tried going offline in Uplay (helped a little). I just don't get it, what the heck changed in the last few days? I had played a several hour long play session with no issues and now I can't go 15 min without a crash. I'm using a Threadripper 1950X with 64Gb of ram and a Titan xp video card. Stable always, so must be the game. Anyone knowing anything to fix or improve this would be super helpful, got to beat this before 10 Dec 🙂

  • R3dl1nes
    5 posts

    @r3dl1nes forgot to mention only seems to crash on me when am raiding or fighting only =/

  • Natix39
    1 posts

    Hey, I just downloaded Assasin's Creed Valhalla today, and it worked just fine the first hour, but then after I got a tattoo, it froze I restarted my pc and it did the exact same thing after 5 seconds, when I entered the game. I have tried verifying the files, but nothing seems to work.

  • Supraryoot
    5 posts

    Hi everyone,

    Since the launch of the game I have experienced crashing/freezing of the game, particularly when I was in looking in the map or looking at my skilltree and sometimes in the main menu. After trying alot of different things like the <a href="https://support.ubisoft.com/en-GB/faqs/000025947/ ">troubleshooting guide</a> I came across a post from someone that stated it might have to do with the game's synchronisation.

    So what worked for me is to delete Ubisoft Connect with all the local files as well and the game AC:Valhalla (make sure to <a href="https://support.ubisoft.com/en-GB/faqs/000025801/">back-up</a> your savegames first!). Then I reinstalled Ubisoft Connect again and now the important part: Before downloading and installing AC:Valhalla again, make sure cloud synchronisation in Ubisoft Connect is turned off and stays off!

    When I enter the map or my skilltree in-game after I done the above steps, I get this error message instead of crashing/freezing:
    undefined

    I have never got error messages before, it just crashed/froze. Just press 'Ok' and for me at least, I can still play the game without crashing/freezing.

    Hopefully this can help you and Ubisoft to play the game without crashing and finding a solution to solve the error.

    Kind regards,

    Supra


  • BendelaBoombr
    42 posts


    for me it didn't solve =C

  • Supraryoot
    5 posts

    @supraryoot

    Can't edit my original post, so here are the links how they should be:

    Trouble-shooting

    Savegame-back-ups

  • Riki_Martini
    9 posts

    I've been playing on PC and every time I upgrade my villiage (after the initial blacksmith) I get stuck in a blackscreen. There's no loading logo and I can hear sound, as if I'm able to react, but each time I have to reload the most recent save. I think it's similar to the bug I had with Kjotve's fight where the cutscene doesn't load in enough time. The blackscreen gives me the option to use the menu and load the most recent save, which resolves the gameplay issues, even though I might miss out on a cutscene.

    On top of that, I'm very regularly getting game freezes in the middle of normal play. I can't attribute this to any particular game event, but now that I'm in England, I have to quit playing the game because the screen is freezing for a very long time and the Esc menu doesn't work. No input available. Nothing to do but Ctrl+Alt+Esc, crash, and reload.

  • FrostiK-rus
    5 posts

    @rcmedia69 This might be the issue... sometimes system drives are not very good to install the game on. Could you, perhaps, try another drive (if you have one)?

  • FrostiK-rus
    5 posts
    This post is deleted!

Suggested Topics

Community Details

37
Online
130.5k
Users
22.6k
Topics
117.3k
Posts