Welcome to discussions

Quick Suggestions

  • CriTCalH
    4 posts

    Exactly the same by me, but I don´t have Ubi+ and I don´t think that´s the problem. Just the game released too soon with many bugs. Maybe not 100% compatible with the newest hardware (RTX3080) 😞

  • CriTCalH
    4 posts

    @redindianrobin Unfortunately I can´t downgrade drivers, at least not to that release, they are so old to recognize RTX3080 :(. I am trying to downgrade at least 4 releases older than the newest one.

  • RedIndianRobin
    186 posts

    @critcalh Ah sorry to hear that man. Hopefully a new driver fixes this issue. Nvidia has been crap lately with their drivers.

  • andicole0
    4 posts

    @ubi-swaggins Yes, goes past Ubisoft Connect then the green splash screen and a crash before it goes full screen. If I revert to the previous version Win 10 Insider Preview it is OK.

  • residex9
    1 posts

    Hey Guys,

    anyone else got the issue that the game just freezes sometime? On release day all worked fine for me. But since the second day the game keeps freezing after a few minutes. All i can do from that moment is to kill the task. Also tried to run it as admin, different screen types etc.

    RTX 2080ti 12GB VRAM
    INTEL i7-9700k 3.60 GHz
    32 GB RAM

  • rcmedia69
    4 posts

    The game freezes and I can't proceed past the first couple of seconds of the game, sometimes the game doesn't load at all.
    The frame rate is incredibly slow and the audio sounds like everything is in slow motion... it's absolutely 100% unplayable in every sense of the word.
    I've done everything Ubisoft recommends as far as troubleshooting the problem (*I uninstalled, re-downloaded, re-installed, verified the game files, cleared the cache etc.... nothing helps).

    I'm using a late 2019 model top of the line Acer Nitro 5 with 32 GB GSkill DDR4 Gaming RAM, brand new Western Digital 'Black' PCI Nvme SSD drive, Nvidia GeForce GTX 1650, Intel i7-9750H CPU @ 2.60GHZ
    This computer never has problems with high end games until AC Valhalla.

    I tried to get a refund through Ubisoft but they have refused saying I have played the game too long so far (?)
    I have done nothing except try to get the game to actually run, which it won't at all.
    So I am calling Visa this morning to get a chargeback.
    I'd recommend others do the same as Ubisoft seems very unethical in their return policy.
    They cannot fight a VIsa chargeback.
    If your game doesn't work then you purchased a faulty product and Visa will give you your money back.

  • RuZty5
    1 posts

    Been having the same issues.

    Crashes every 10 minutes, some times I have to end the process through task manager, some times it crashes to desktop.
    It even crashed my whole computer a couple of times and restarted my whole system.

    I've updated the game, verified the game, updated drivers, turned off optimize fullscreen, white listed the program, ran it as administrator etc etc.

    Nothing helps 😞

  • emmaj95
    66 posts

    @babooshka_ I still have not yet

  • FrostiK-rus
    5 posts

    @rcmedia69 It is playable for me on PC but it has a lot of bugs... i7 8700K 16GB Ram RX 5700XT. Did you try to contact them via cus.support chat? I do believe that the problem lies somewhere with your laptop...The Nvme drive that you mentioned is it primary or secondary drive?

  • rcmedia69
    4 posts

    @frostik-rus the WD Black NVME SSD drive is my primary drive and it's the same drive where Windows is installed (*it's a 2TB SSD).
    .

  • babooshka_
    5 posts

    @emmaj95 This is a joke. And not a funny one. Ubisoft should get it together. This is not what I paid for while subscribing to uplay+.

  • olmstead88
    2 posts
    This post is deleted!
  • CriTCalH
    4 posts

    @axesdenyed Welcome to our crew, we all have the same problem :). U can try synchronize time zone with your local time like someone said before but honestly I don´t think it can help.

  • DRock_Kill
    3 posts

    Here I have the same issues, downgrade driver doesn't work for me...

  • LordCaliban007
    2 posts

    Same issues here. I've been playing fine since launch day with no real issues. Good Framerates, no issues with quests or anything and I put about 14 hours in so far. Last night the game freezes on me on exit and I had to use the keyboard in Task Manager to force close it. Try to start it up today and it crashes on the launcher. I've tried verifying files, uninstall/reinstall, graphics card reinstall, repairing the distribution files, etc. Nothing is working to even get back into the game.

  • R3dl1nes
    5 posts

    @lordcaliban007 am having this SAME issue no real issues until i got pass that 29 hr mark then game freezes and locks or crashes to desktop i do send the error reports in too i cant seem to get it working either

  • BnnZzzZZ
    1 posts

    I'm unable to play this game. It randomly freezes with sound on the background.
    I had to open task manager to close it. Sometime, i had to restart.

    Give us a patch.

  • Ryk0s
    2 posts

    @shetland_pony I'm having the same exact problem. Odd thing is though is that I played off and on for the last 3 days and had like one crash. Today I have had... uncountable freezes, 90% during dialog. I have changed every setting and back again, tried going offline in Uplay (helped a little). I just don't get it, what the heck changed in the last few days? I had played a several hour long play session with no issues and now I can't go 15 min without a crash. I'm using a Threadripper 1950X with 64Gb of ram and a Titan xp video card. Stable always, so must be the game. Anyone knowing anything to fix or improve this would be super helpful, got to beat this before 10 Dec 🙂

  • R3dl1nes
    5 posts

    @r3dl1nes forgot to mention only seems to crash on me when am raiding or fighting only =/

  • Natix39
    1 posts

    Hey, I just downloaded Assasin's Creed Valhalla today, and it worked just fine the first hour, but then after I got a tattoo, it froze I restarted my pc and it did the exact same thing after 5 seconds, when I entered the game. I have tried verifying the files, but nothing seems to work.

Suggested Topics

Community Details

119
Online
191.5k
Users
32.1k
Topics
161.2k
Posts