Welcome to discussions

Quick Suggestions

  • mikeswcal
    5 posts

    Also fix the missing quest markers. When I map quest objective I should be able to see it on the map..sigh......

  • m0t0wnfilly
    2 posts

    My game freezes. i have to do a hard close on the game. I notice that when it freezes my memory is up pretty high. It does this quite often too. I'm on PC. It's getting to be a real pain. And I haven't gotten a crash report after waiting a couple of minutes to see if the game will just crash on it's own.

  • Tecchizzato
    3 posts

    Since 1.0.4 the games crashes every 90 minutes to me. I updated windows 10 and all the drivers. Got an i9 9900 and a 2080Ti. Drivers 457.51. The problem is that after a variable time close to 90 minutes the games freeze, the sound continues and after maybe 10 seconds pc reset to bios. It is and hard crash as windows doesn't save any log anywhere. Event viewer is clean, it just say system restarted. I never had this problem with 1.0.2. I did buy valhalla but i have also Uplay+ now. The thing i want to try is to have uplay connect on the second monitor to see if it is the cause of the crash, as for WD Legion when it crashes it looks like that is uplay connect fault.
    The thing i don't get is if Ubisoft at least is aware of the problem.

  • falo2k
    23 posts

    Yep, getting these crashes now since the latest patch. They were not an issue before - game just hard locks about 30-60 minutes in. Often seems to be after a save so I wonder if that's related.

  • k87965t
    1 posts

    I have been trying to complete the last missions of the main story mode, but the game freezes and forces me to manually end it via task manager. This is happening during pretty much any scripted dialogue meaning that i cannot progress any further. This is a big problem and is very frustrating.

  • camokillo
    13 posts

    Did anyone have any luck with the new Radeon drivers just released today? installing now..

  • uFamas
    25 posts

    I just did one of those rage inducing Cairns, validated it then took a screenshot and that caused the game to CTD.
    Upon loading the last save the Cairn stones are laying on the ground and I can do it all over again FFS 😠

  • uFamas
    25 posts

    Used Harpoon ability on a Zealot and the game hardlocked.

    Also just cleared the entire Thieves Warren camp and upon proceeding the quest the game once again CTD.
    Loaded back in and the entire camp is untouched as the last save is right before the camp.🙄

  • milkybandit
    5 posts

    At least you get something. Here's all I get on my screen, since nothing loads once I fast travel:


  • grpantsch
    2 posts

    Hi everyone! I experienced the same problems you described after the 1.04 update with constant freezes after 15-20 minutes into the game. I have my old desktop PC with an i7 2600k and Nvidia 1060 OC, and a gaming laptop with Ryzen 9 4900 and RTX 2060. The solution that worked for my case is the following:

    • Update the drivers of your card.
    • Delete the cache directory in "My Documents>Assassin's Creed Valhallla>cache".
    • Play the game NOT in "Full Screen" but in "Borderless Windowed" mode and Vsync OFF
    • In the "Graphics" options choose a lower setting, in my case "High>Medium".
    • If the game asks for a new save, create a new manual save.

    After these settings, I can play more than 4 hours continuously without any of the aforementioned problems.

    I hope that helps. Stay safe and enjoy an otherwise fantastic game!

  • XenticPL
    3 posts

    Every 1 hour or so my game crashes after 1.04 update. It just freezes and I need to kill the process through menager.

    Before the patch 1.04 the game had never crashed.

    Any fix?

  • Coach811981
    34 posts

    Do you still hear sound when the game is frozen?

    Alot of people still have that issue amongst other things.

    There's a big thread on this, have a look when you have the time:

  • blemiglute
    9 posts

    @davidho719 Thx but i don't know how to do that.. i never turned it on myself anyway..
    Been playing 2 dayx without crashes, and when entering wincestre, 2 freezes every 10 minutes of playing...

  • Keelorpse
    3 posts

    @wanimar Still freezes on me frequently. Usually, just when I am about to defeat a zealot... This is probably the buggiest, glitchiest, most unstable PC game I've ever seen.

  • Umweltminister.
    6 posts

    @ubi-spud since the last update the bug appears more often like when zooming the map in and out and so on

  • charlieslade
    2 posts

    Same here, PC version 1.0.4.

  • FireForkTS
    11 posts

    I've been having random crashes where the game freezes, stays on that image for a few seconds... then crashes out and updates the saves to the cloud on PC (Ubisoft Connect). No option to report the bug or crash. This only started when the last patch hit. This usually happens right after combat starts. I usually have time to kill 1-2 guys in a group of 4 and then FREEZE, crash, desktop... and now I'm hunting for that roving wealth icon on the map again (because they aren't in the same location nor nearby when I load back into the game).

    This isn't an issue of not having enough RAM or Video memory... as those are having moderate use... but never maxing out.

  • Jutzukan
    14 posts

    Same here. Latest patch f'd up everything. Been trying to play consistently since release, had these same issues before. Submitted a ticket and it took several emails back and forth til the game was playable. Now it's back to crashing at the splash screen, frozen video w/ music looping in the background. [censored]?!
    Hey Ubi, I'd have more than 6% progress if I could actually play this game without it freezing up. Putting in another ticket seems like a waste of time.

  • AnolinMcGinnis
    25 posts


    I just wish they’d at least acknowledge it. All these posts here and on Reddit, and it’s STILL not on their list of known issues!?

    I tried opening a ticket and using their “support” but it was a joke.

    I unfortunately just started over, deleted all my saves and left myself at the beginning of the game and now I’ll wait until until they can get their crap fixed.

    Same with Cyberpunk 2077. Sheesh.

  • Tomo1985
    5 posts

    Since the patch 1.04, everytime I have played the game, at some point it freezes. It could 30 min or 2-3 hours in, but everytime freezes and stops working. I have updated drivers, check game files... but nothing works. Yesterday, it freezes just looking the map. AC Origins and AC Odyssey had some bugs, but nothing like this game. I hope Ubisoft release a new patch soon, this is NOT the way.

Suggested Topics