Welcome to discussions

Quick Suggestions

  • Tomo1985
    5 posts

    @charlieslade Same here, PC version since path 1.0.4.

  • coronass1
    1 posts

    My game keep crashing
    this is the last game from Ubisoft i will buy on realase day this game i so bad for me payed 80 euro for it and
    here is my crash plan for the last 30 min
    started crashed
    18,37 18,52
    18,54 18,55
    18,57 19,00
    19,03 19,05

  • Coach811981
    34 posts

    Hi all

    I just wanted to give my experience of the crashes/freezes that i have logged since the start of playing the game since release date.

    Overall in just under 240hrs of gameplay i've counted 15 crashes/freezes. Not enough that its a constant worry but its still too much to call it "stable"

    All nvidia drivers are up to date. i resisted the temptation to roll back as it wasn't a constant issue that warranted a roll-back.

    I could go days without any issues then all of a sudden one would pop up. I will say that i never had more than 2 on any given day so in that regard i was lucky.

    5 of them were CTD, some of them were CTD's without any error messages and a few actually had me doing the whole sending of error reports to Ubisoft.

    The rest were the freezing with the sound still playing in the background issue (this is the main one that i see popping up regularly in the forums)
    I wanted to focus on this issue as its happened the most and there's no clear indicator what actually triggers it.

    Looking at the event ID's each time the one that popped up the most was D3DDRED2.

    Some of the things that i was doing when the game froze:

    • in combat
    • general exploring
    • in distrust areas (happened in Ledecestre, Cent, Wincestre and smaller area called Wandrie)
    • on horseback
    • leap of faithing

    So in general - anything! I will say the freezes in the distrust area were a bit odd but ill put that down to mere co-incidence.
    Crashes usually happened within the first hour of gameplay but there was the odd occasion when it froze after 4+ hours though.

    This is still a big issue that i see pop up and to my knowledge this isn't even on the "known issues" list
    Looking at the list i'm a little shocked as to what they deem "priority" when there are many people who cant even play 5 minutes.

    I'm probably gonna take a break from the game for a bit. Think the only thing i need to finish is the fishing collection and complete a few mysteries (a few are bugged so don't know when they will get patched)

    Hopefully Ubisoft can actually start tackling the real problem for players and get the mess sorted.

    Thank you

  • kronograf
    3 posts

    I'm having the same D3DDRED2 errors - it's happened to me in Hamtunscire during monastery raids / clearing of restricted area forts at least 4-5 times by now, just randomly. Would really appreciate if the devs can add this to the known issues list.

  • Alarick7
    14 posts

    I'd consider you lucky. After patch 1.04 I simply crash 3-4 times per session then I just simply stop playing. I've tried everything. A billion verify the files, delete caches, update drivers, downgrade drivers to 44x.xx, sacrificed a virgin (myself), everything. Same timeframe for crashes. Sometimes with the "send error report", sometimes without. I'm tired. This game beat me to submission. gg ubisoft.

  • Tomo1985
    5 posts

    @alarick7 same here. Random freezes and crashes, sometimes send error info, sometimes I have to kill the game from task manager. All since patch 1.0.4.

  • DRock_Kill
    3 posts

    I did exactly that and it didn't work, I have a gtx 1060 6gb and i5 7400, with this setup I can run it on ultra, but the problem is in the save that you have to send to the server, the problem is clearly in the system they made on Ubsoft Connect.

  • kamidon74
    1 posts

    Hi there,
    My game keeps freezing, I'd be more than happy to submit any error logs that are surely available.
    So I load my save, i play for about 5-10 minutes and the game crashes, I'm 99 hours into the game. I have...one territory left from the looks of things to take over, uhh power level...250 or whatever. Small town surrounded by the over 300 power level territory...yeah anyway.
    Doesn't matter what I do, birdy flies, crashes after a few minutes. I walk somewhere, game crashes.

    It's happened before, a computer restart seemed to have resolved the issue, but I've done that here.
    Nvidia 2080ti super in an HP Omen with an i9 10th gen processor, 64GB of RAM. Nvidia drivers are the latest version that have recently been optimized for Cyberpunk 2070 (which I haven't played yet because I'm still on this game lol)

    I also checked the known bugs, I didn't see anything about game freezes so, thought I'd bring this up.
    Thank you
    Oh also of course, windows 10, fully updated to...whatever Microsoft is now calling their builds. 20Hsomething.
    Edit: I just got done with the Verification of files. so...that came back clean I guess. Going to try the game again.
    Edit2: OH and I already tried that valhallaplus.exe version. Is that a beta? Eh still had the same issue.

  • Alarick7
    14 posts

    @kamidon74 Same issue here mate. Only Hamtunscire left and it just crashes now whatever I do. Before that, the game crashes pretty rarely. Around 1 or 2 per game session. Now it's just guaranteed to crash after 5-10 minutes or so. I've tried rolling back drivers, deleting caches, verifying files, loading old saves, lowering the graphic settings. I bet my life that it's not on my end since even consoles have reported crashing.

  • RedIndianRobin
    188 posts

    I've been playing CBPK with the latest drivers and absolutely no crashes in 30 hours. Ubisoft needs to get their heads out of their [censored] and fix their [censored].

  • launzzz
    1 posts

    I am now about 80 hours into the game and since patch 1.0.4:

    • the game crashes about two times per hours. Given the long time it takes to start the game, this is extremely annoying.
    • the loading times (e.g. before talking to someone) are getting longer and longer
    • trying to do a feast results in a crash as well

  • Wilko0o
    3 posts

    The game loads me into the pre game area where you run around as your character then after that i go to a loading screen that loads forever, i even left it overnight to see if it was just slow but nothing. I have updated drivers, verified files, updated windows and reinstalled the game but still not working

  • scottyusceaser1
    34 posts

    @wilko0o Try going to your 'Documents - Assassins creed Valhalla - delete catche folder and the AC_Valhalla Config file and start the game in Admin mode.'

  • Wilko0o
    3 posts

    @scottyusceaser1 '

    hey, i couldnt find the files but i ran the game file as administrator and it worked and i started to play but i am now fighting Kyotve and when he charges you off the ledge it sends me into another infinite loading screen

  • Nanna_shaker
    6 posts

    Tried everything suggested by Ubisoft, and Wilko... no dice. Downgraded graphics quality and ran windowed (which I shouldn't have to) - crashed immediately. Even worse than higher quality.

  • Wilko0o
    3 posts

    @nanna_shaker its a shame honestly, spend $90 to play the only good viking related game in so long and u cant even play im sick of it

  • camokillo
    13 posts

    Cyberpunk 2077 I'm able to play flawlessly and no crashes with full settings ultra everything. Meanwhile in Valhalla I'm still crashing every dame session. it might have some glitches in Cyberpunk but at least the game doesnt CRASH. Damn CD Projekt Red can actually make more stable games than Ubisoft. What a shame. Get your crap together UBI

  • Furmano81
    11 posts

    Nothing changed for me with this patch
    I need to be extremele lucky to play the game:
    Ryzen 5 3600
    16GB RAM
    Nothing is overclocked and game is freezing after a few minutes or less
    New win 10 in installed after format
    I 've lost hope

  • RedIndianRobin
    188 posts

    @camokillo IKR. In today's patch, I played for like 15 minutes didn't crash yet with the latest drivers.

  • Phoxfire.ttv
    1 posts

    I am having similar issues. When trying to load into the game I sit on the "When the Game is saving you get this icon" screen for about 15 minutes. Loading times after fast traveling have slowly gotten worse.
    My game is installed on M.2 Drive, I am running with: CPU: Intel i7 8700k, GPU: Nvidia RTX 2080 Super, 16GB of RAM

Suggested Topics