Welcome to discussions

Quick Suggestions

  • kjenningsiii
    6 posts

    Really hoping this can get figured out soon... this has been happening more and more for me as well. Randomly freezing or quitting to the desktop. I should not be having issues with my config.... I have tried every solution I've seen online and the game will run for about 2-50 minutes randomly quitting. Today, I've played for MAYBE 10 minutes.. Log files look like there's a connection issue.

    Core i5 9600k @ 4.3GHz, MSI AMD RX 5700 XT 8GB, 16GB Corsair Vengeance @ 3200, WD 1TB NVMe, 1000W Corsair Modular PS, MSI Z390 Gaming Edge AC.

  • UbiExcellent
    Ubisoft Support Staff 756 posts

    Hi TDG_CRASHFIRE and carlosj-1982. Thanks very much for reporting this crashing error that you both are encountering on your PCs. Please try running Ubisoft Connect with administrator rights to see if that resolves this crashing error for either one of you. In addition to this, disabling background applications may help ensure that other programs aren't preventing the game from launching. Please share the results of both of these steps here if the problem persists, so I can continue assisting you both with this issue!

    Official Response
  • kjenningsiii
    6 posts
    This post is deleted!
  • rinks3611
    10 posts

    @ubiwan Your 1.04 update is literal garbage. If anyone even tested this before releasing it I would be surprised. It's clearly causing problems across the board. Roll back to 1.02 until you guys get your [censored]e together.

  • longjohn119
    775 posts

    @tdg_crashfire
    I wish they would just send the crash report to my computer when it crashes so I could just fix it myself ..... It gets sent to them and gets put in a pile with 10,000 other crash reports never to be seen again ..... I just turn the stupid thing off like I do all the other Phone Home garbage software is riddled with these days

  • longjohn119
    775 posts
    Hi TDG_CRASHFIRE and carlosj-1982. Thanks very much for reporting this crashing error that you both are encountering on your PCs. Please try running Ubisoft Connect with administrator rights to see if that resolves this crashing error for either one of you. In addition to this, disabling background applications may help ensure that other programs aren't preventing the game from launching. Please share the results of both of these steps here if the problem persists, so I can continue assisting you both with this issue!


    I'd like to add that if giving an INTERNET CONNECTED app Elevated Privileges doesn't work then turn it back off ...... It's a security risk to leave an INTERNET CONNECTED app like that for anything other than testing purposes ...... It's a workaround not a proper solution

  • longjohn119
    775 posts

    @kalpdal86
    That's because the Ubisoft Connect app is a broken piece of junk ..... It's causing a lot of problems with both Legions and Valhalla and possibly any other game that Phones Home a lot during gameplay ..... They can't even figure out how to unlock the Club items we already own In Odyssey when everything is already one our computers and they have to do is send the unlock codes ..... It's been over a month and they still haven't figured it out .....

    They didn't need to patch the game, they need to fix the Connect app .... I'm telling you that is the reason they didn't catch any of these Bugs during testing because the game wasn't tested with the Connect app hooked up ...... But what would I know I've only been a systems troubleshooter for 40+ years ......

  • crusaderofblood
    5 posts

    I am still not able to even play the game on my pc. they quit responding to me last week and just says an internal team is working on with no updates.

  • longjohn119
    775 posts

    @n00l3ilici0us
    Just because that worked for you doesn't necessarily mean it's going to work for everyone else .... It could be your ram was always running on the edge of stability since it was new because of the way it was binned at the source ..... I've had sticks from the same manufacturer when one was barely stable at it's suggest XMP setting of 3200 while having another stick just like it that could clock up 4000 Mhz at the same 1.35 V ..... It's all just the luck of the draw in the Silicon Lottery .....

    It's a OK idea for testing but if it doesn't help then I'd set it back to the XMP setting so you don't nerf your entire system for everything else ..... They had a problem in Origins with Ryzen CPUs when they introduced the Animus Control Panel where you could make it work by turning off SMT (Simultaneous Multi-Threading) but that just killed the performance for video editing and compiling programs and such so I just didn't play the game until they got it fixed .....

  • longjohn119
    775 posts

    @longjohn119
    I'd even suggest that they still aren't testing the game with the Connect app hooked up which is why they think they had fixed all these problems when most of them are still a problem ..... They are looking in the wrong place for the problems

  • UbiExcellent
    Ubisoft Support Staff 756 posts

    Hi everyone! I'm very sorry for the continued difficulties caused by this crashing issue while using Ubisoft+ to access Assassin's Creed Valhalla. For those of you who haven't completed our basic troubleshooting guide for the PC, please give these steps a go in order to ensure that your PC is running optimally. If the crashing persists after, or for those of you who've already completed these steps, please then attach your MSINFO and DxDIAG files to a support ticket via our support website, so our teams can look into what may be causing this crashing error to occur.

    @kalpdal86 I've had a chance to review your support ticket and would like to see if you'd be able to reattach your MSINFO file, but as an NFO file please.
    @Hergelee01 Just to confirm, do you own the game via Ubisoft+?

    For those of you experiencing this crashing issue but on a different platform, please let me know the following:

    • What platform are you on when this happens?
    • When did you first notice this crashing error? Before or after update 1.0.4?
    • Does any specific in-game action cause the crash to occur?
    Official Response
  • RedIndianRobin
    188 posts
    This post is deleted!
  • Shadywack
    40 posts

    @ubiexcellent I submitted a ticket with dxdiag.txt and msinfo.nfo files, with some details on what I've tried.

    For the benefit of everyone here troubleshooting, I'm on a Ryzen 7 5800x with an MSI 5700XT, 32GB of RAM on an XMP profile (technically Asus DOCP since they don't directly license XMP).

    I've tried underclocking my card per the Reddit AMDHelp thread by 20, still crashes.

    Ran AMD's driver removal utility and reinstalled w/fresh drivers, still crashes.

    Verified gamefiles with the Epic launcher and then with Ubi Connect, still crashes.

    I was wondering if I had a hardware fault, stress tested on 3DMark, Borderlands 3, AC:Odyssey, and Shadow of the Tomb Raider benchmarks and have no instability (even on my 5800x boosted to 5.1 GHz ..... 😄 😄 😄 )

    Only AC:Valhalla exhibits any instability whatsoever. Other games on other API's or the same API are all stable, only getting crashes on this game and only this game, nothing else.

  • Enhance89
    2 posts

    UPDATE: The glitch kept happening to me at night, so I moved time forward to daylight and was able to complete the raid on the first try.

  • zelikris
    1 posts

    Same issue. Started happening after the new patch

  • Bob__Gnarly
    49 posts

    @redindianrobin
    LOL read the OP for your answer.

  • Bob__Gnarly
    49 posts

    I had the same problem after the 1.0.4 patch, my game would crash during raids and other intense battles.

    I had to lower my graphics settings, which I shouldn't need to do with my rig, but in any case have been playing crash free for hours.

    Here's my specs below:

    OS: Win 10
    GPU: GeForce RTX 2080 Ti
    GPU Driver Version: Latest
    CPU: Intel Core i7-9700K
    RAM: 16GB
    Storage Device: SSD

  • hiles_adam
    3 posts

    Ever since the update I can no longer play Assassins Creed Valhalla.

    Everytime I click load game my game crashes pretty much instantly, I get the load symbol for a few seconds and then it crashes. I have restarted the game, verified files, updated grahics drivers and its still not working.

    Edit: Ok I loaded up a game thats like 3 hours older then my current save and its working now.

  • RedIndianRobin
    188 posts

    @hiles_adam Your save file is corrupted. You have to use an old save.

  • hiles_adam
    3 posts

    @RedIndianRobin I mean it seems odd that 2 hours of save files would all corrupt after the update, but not this one?

Suggested Topics