Welcome to discussions

Quick Suggestions

  • andy2029
    1 posts

    Same issue here; crashes that seem to happen either in specific locations or just as missions/events complete.
    Ticket open with Ubisoft Support, reference 15209743
    Dxdiag and sysinfo files uploaded.
    Running on Windows 10 Pro 21H1, fully patched.
    Intel i9-9900KF, not overclocked
    Palit 3060ti, not overclocked
    Game installed to C:\ drive (1Tb M.2) and excluded in antivirus.

  • grooners
    23 posts

    I can see two sorts of crash
    - repeatable ones at a specific location (like the cursed object area near Chertsey Abbey for me) so maybe there is some problem in the game data. The game freezes and needs to be killed in task manger
    - random crashes (days to weeks interval) where there is a short freeze, crash to desktop, and a driver error logged. Not improving with game updates so I assume this is Anvil game engine related, seems more common for Nvidia cards (this title favours AMD)

    The location ones could be fixed as they will affect everyone but the random ones wont - the game doesnt gather crash dumps to analyse

  • LightmanN7
    10 posts
    This post is deleted!
  • LightmanN7
    10 posts
    @skylinee87 My game was crashing at almost every game session. So over a week without a crash is a victory. But i will come back here if i ever crash again. This is also the only game that I have these problems for.


    @Skylinee87 You were right, after several weeks of happiness without crash. Here I am again with 2 crashes in 2 hours. Impossible to finish my river attacks ...

  • weeswolf
    3 posts

    After extensive experimentation, I think I found a solution that worked for me. I progressed from 95% completion to 100% completion over the course of 21 hours and did not encounter a single crash. In my case the culprits were depth of field and motion blur. Although I played on the high preset, I always disabled depth of field and motion blur as a matter of choice. However, out of desperation I re-enabled the high preset the other day and forgot to disable depth of field and motion blur and my game has not crashed since. When I disable these two settings my game crashes randomly. This is repeatable in my case.

  • SkarrLorn
    2 posts

    I can replicate a crash almost every time just going into the skills page. The cursor gets slow, jerks alittle, and then the game hangs and won't shut down without force quitting. Ughhhh...

  • grooners
    23 posts

    Another similar crash - just looking at the map a little while after battling with an order member

  • longjohn119
    706 posts

    I started replaying the game a few days ago I cleared everything in Rygjafylke except the Drengr and am now in England, maybe 2 hours worth. I had one crash so far about 8 hours in when I went to assassinate Sulke (The Silver Tongue Traitor) When it went into the assassination cut scene it just frozen and while I still had some CPU activity (18% - 20%) the GPU usage dropped to zero and it unloaded all graphics memory from about 6 GB down to 0.2 GB indicating a graphics driver or DX12 API problem .... Other than that as far as FPS I'm not really seeing any difference from what I was getting back in November when I quit playing or my testing of an update back in February

    Asus TUF Gaming X570-Plus
    Ryzen 3700X CPU
    MSI RTX 2080 Super Seahawk X (hybrid watercooled)
    32 GB 3600 G.Skill DDR4 RAM
    Page File set to "Automatically manage paging file size for all drives" (No valid reason to run it any other way anymore)
    Exclusion for the Valhalla game folder in Windows Security

    We'll see what happens as I get further into England

  • longjohn119
    706 posts

    @longjohn119

    Well that didn't take long ..... Sailed from Ravensthorpe over to Meldeburne and raided the Monastery with no issues, no stutters or drastic drops in FPS but as I was leaving to go over to grab the Black Peak sync point it just CTDed without warning ... No error message in the game or in the Windows Events, it just died making it impossible to troubleshoot other than it is likely a graphics issue that's out of my hands without any debugger/error logs

  • noneofyou
    12 posts

    Ok so for me it seems that they actually did something in the recent TU, after 4 months of crashing I'm not able to get any crash (I'm not talking location/quest related crashes but completely random ones while freeroaming anywhere in the game world). Before the patch I've done everything that support asked and still the game was crashing, after the recent 'stability and performance' patch game stopped crashing. I've done nothing more, it simply won't crash on DDU installed 21.8.2 Optional AMD driver on 6800XT.

    @UbiStorm
    here's a list of things that support team asked me to do, you can find all the details, evidence and like 6 msinfo/dxdiag files in support ticket that you already automatically closed 15142162
    - clean installed Adrenalin 21.8.2 Optional (non-WHQL, not recommended)
    - disabled every third party software/all autostart programs (also AMD External Events Utility that should not be disabled)
    - playing on new clean local Windows account
    - COMPLETELY UNINSTALLED antivirus program (you should not ask people to disable security, your software should be compatible with most popular AV software)
    - game files verify/reinstall
    - System File Check (SFC)
    - Microsoft Safety Scanner (the newest version deletes files without a promt and they can't be restored, I would be carefull with this one)
    - disabled Game bar, Game DVR, Game mode (you should not ask people to disable default components of Windows 10 that are enabled by default, so is Windows 10 required to play the game or not? Decide.)
    - using 60Hz refresh rate (you should not ask people to lower refresh rate when their hardware and software fully support higher)
    - before each gaming session/running UBI launcher- sync time in Windows settings

    ... and the game was crashing, then I've done nothing and after TU 1.3.1 with following these steps I'm was not able to get a single crash. I finished Paris DLC, part of Ireland map, new and old river raids, I even done unnecessary river raid marathon with prolonging but the game just won't crash. 

    There are 2 things to notice:
    1. when you ask people to disable third party software and send them link with a guide- for the AMD users it also disable AMD External Events Utility. This is a part of AMD driver's default settings and it should not be disabled, it is known to cause problems in some games when it is disabled (might be freesync related). I had to switch it on aswell AMD Crash Defender Service because you can't report crashes to AMD otherwise. 
    Update you disabling third party troubleshooting guide with a notice that AMD user should not disable these two default components of AMD GPU driver. I really understand that you want to blame any third party software possible, but leave alone default components of GPU driver, especially when there are GPU related problems.
    2. in-game FPS limiter is completely broken as I said in my previous message (in both fullscreen/windowed)
    - it exceeds set value- causing stuttering becasue FPS is higher than refresh rate. For example if it is set to 65 I should sit on 64-65FPS, not 66-67FPS. (I checked this with UBI launcher FPS counter)
    - it does not work in menus, eq, map ect causing very big FPS jumps and drops when entering/leaving menu, this actually can cause problems
    - it does not work in some in-game dialog scenes

  • longjohn119
    706 posts

    @noneofyou

    Game bar, Game DVR, Game mode are garbage and not needed ..... Game Bar is a known problem for crashing many games, You are better off using the graphics driver's built-in recording app than Game DVR and Game Mode doesn't really do anything, it's supposed to shutdown background apps but has never actually worked correctly .... It is however a great way for Microsoft to grab personal data about your gaming habits so they can target you with advertising (or sell the info to someone who will)


  • longjohn119
    706 posts
    @longjohn119

    Well that didn't take long ..... Sailed from Ravensthorpe over to Meldeburne and raided the Monastery with no issues, no stutters or drastic drops in FPS but as I was leaving to go over to grab the Black Peak sync point it just CTDed without warning ... No error message in the game or in the Windows Events, it just died making it impossible to troubleshoot other than it is likely a graphics issue that's out of my hands without any debugger/error logs


    Well it looks like I'm done with this game for another 10 months ..... I can't keep the game running for 3 minutes without it crashing

    Here is crash #2 (I didn't record the first crash)



    And crash #3



    And crash #4



    And crash #5




    Don't ask me for anything more because I'm taking this hunk of garbage off my SSD because it's just a waste of frigging drive space that I can use for games that do work

  • AnolinMcGinnis
    25 posts

    @longjohn119 But but - they neeeeeeeed your MSINFO, DXDIAG and blood type because they are too inept to figure this out!

  • longjohn119
    706 posts

    @anolinmcginnis What they need is to send me the EXE with a debugger enabled so I can get something like the following to work with ,,,, This is partial debug log for a similar crash I was having in Skyrim entering a cave.(Full debug log is 979 lines long) With this information I was able to determine I have a bad head NIF (mesh) and with the stack dump I was able to figure out which mod and which character was bad. Then I imported the mod into the Creation Kit and redid the "face gen" for that one NPC and crash gone ..... I entered the cave and sure enough there was that female Imperial NPC lying dead just inside the entrance to the cave. I notified the mod author and he corrected the problem. He knew he had a problem but it's a randomly generated NPC so it is in a different place in every game and sometimes not used at all so he couldn't find it based on the bug reports he was getting

    Unhandled native exception occurred at 0x7FF765E35590 (SkyrimSE.exe+12F5590) on thread 3456!

    FrameworkName: NetScriptFramework
    FrameworkVersion: 10
    FrameworkArchitecture: x64
    GameLibrary: SkyrimSE
    GameLibraryVersion: 14
    ApplicationName: SkyrimSE.exe
    ApplicationVersion: 1.5.97.0
    VersionInfo: Successfully loaded
    Time: 28 Aug 2021 17:25:13.385

    Possible relevant objects (5)
    {
     [ 21]  BSDynamicTriShape(Name: `FemaleHeadImperial`)
     [ 92]  NiCamera(Name: `WorldRoot Camera`)
     [ 135]  NiCamera(Name: null)
     [ 153]  BSMultiBoundRoom(Name: null)
     [ 155]  BSMultiBoundRoom(Name: null)
    }

    Probable callstack
    {
     [0]  0x7FF765E35590   (SkyrimSE.exe+12F5590)     unk_12F5590+0
     [1]  0x7FF765E3225F   (SkyrimSE.exe+12F225F)     BSLightingShader::Func4_12F2020+23F
     [2]  0x7FF765E484BE   (SkyrimSE.exe+13084BE)     unk_1308440+7E
     [3]  0x7FF765E47F9B   (SkyrimSE.exe+1307F9B)     BSBatchRenderer::unk_1307E80+11B
     [4]  0x7FF765E482D3   (SkyrimSE.exe+13082D3)     BSBatchRenderer::unk_1308030+2A3
     [5]  0x7FF765E47E52   (SkyrimSE.exe+1307E52)     BSBatchRenderer::unk_1307DD0+82
     [6]  0x7FF765E0CF4F   (SkyrimSE.exe+12CCF4F)     BSShaderAccumulator::unk_12CCE40+10F
     [7]  0x7FF765E0B699   (SkyrimSE.exe+12CB699)     BSShaderAccumulator::unk_12CB2E0+3B9
     [8]  0x7FF765E0ACAD   (SkyrimSE.exe+12CACAD)     BSShaderAccumulator::Func43_12CAC90+1D
     [9]  0x7FF765E24129   (SkyrimSE.exe+12E4129)     unk_12E3E70+2B9
     [10] 0x7FF7658A9DAF   (SkyrimSE.exe+D69DAF)     unk_D69D00+AF
     [11] 0x7FF7658B4F58   (SkyrimSE.exe+D74F58)     unk_D74EC0+98
     [12] 0x7FF7650F2096   (SkyrimSE.exe+5B2096)     Main::Draw_5B1860+836
     [13] 0x7FF765E0B905   (SkyrimSE.exe+12CB905)     BSShaderAccumulator::unk_12CB2E0+625
     [14] 0x7FF7650F1832   (SkyrimSE.exe+5B1832)     Main::unk_5B1710+122
     [15] 0x7FF7653BFE00   (SkyrimSE.exe+87FE00)     NiCamera::unk_87FD40+C0
     [16] 0x7FF7650F1301   (SkyrimSE.exe+5B1301)     Main::unk_5B1020+2E1
     [17] 0x7FF765873E60   (SkyrimSE.exe+D33E60)     BSMultiBoundRoom::QPointWithin_D33E40+20
     [18] 0x7FF764C9AA6E   (SkyrimSE.exe+15AA6E)     TES::unk_15A6E0+38E
     [19] 0x7FF764DDC683   (SkyrimSE.exe+29C683)     unk_29C440+243
     [20] 0x7FF7650F35C7   (SkyrimSE.exe+5B35C7)     Main::Update_5B2FF0+5D7
     [21] 0x7FFCB4CFDEC0   (hdtSMP64.dll+4DEC0)      
     [22] 0x7FFCB3007A94   (gameoverlayrenderer64.dll+97A94)
     [23] 0x7FF7650EF4F4   (SkyrimSE.exe+5AF4F4)     MainLoop_5AF3D0+124
     [24] 0x7FF7650ECC05   (SkyrimSE.exe+5ACC05)     BSGeometryListCullingProcess::unk_5ACBD0+35
     [25] 0x7FF765E8B17A   (SkyrimSE.exe+134B17A)     unk_134B05C+11E
     [26] 0x7FFD21A47034   (KERNEL32.DLL+17034)      
     [27] 0x7FFD23A22651   (ntdll.dll+52651)        
    }

  • AnolinMcGinnis
    25 posts

    @longjohn119 Same here. ONLY Valhalla is having issues on my PC. All other games are as steady as a rock, yet AC Valhalla can crash at any time.

    Who wants to play a game where they are sitting on edge, waiting for the game to crash when opening the inventory, the map, selecting a dialogue choice, etc?

  • AnolinMcGinnis
    25 posts

    @longjohn119 Sad thing is that it's MY COMPUTER. Let me see the logs for what's going on in MY COMPUTER.

    I know I may sound entitled right now, but I cannot count on them to look at my DXDIAG log, go out and assemble a computer just like mine with the same hardware/software and troubleshoot it. It's beyond ridiculous.

  • longjohn119
    706 posts

    @anolinmcginnis DXDIAG is the last thing I look at for troubleshooting because it doesn't really tell you anything other than whether your DirectX files are up to date or not ... It was probably relevant 10 years ago or more so it's been part of the checklist ever since .... The only thing relevant is the crash log it sends back but they don't let us have access to that ... They should drop a copy on our computer and have us send that in or post it online .... All the information that they ask you for is useful for is finding if there is a common fault with a piece of hardware .... Something like all crashes are happening on Ryzen CPUs or a certain motherboard manufacturer but that's not the case here, it's a problem with all systems, motherboards, CPUs and GPUs .... There is no common fault other than the game itself

  • AnolinMcGinnis
    25 posts

    @longjohn119 Very true.

  • arturocojonudo
    3 posts

    Good Morning. Today I have tried to install Valhalla in (C: > x86 > ACValhalla) (ssd and OS directory) and the game works correctly without any glitches. I'm thinking that the general failures are mainly due to the hard disk, perhaps due to Ubisoft's error for not having good optimization in the hard disk

  • rapozaum
    13 posts

    I played this game for 70+ hours I think, had maybe 5 crashes, nothing worrying.
    Bought the Season Pass last week, updated my game and now I simply cannot play it. I have crashes seconds after the loading screen (I don't mean the Continue button, I mean after the Ubi logo).

    I've done a myriad of things to test, tweaked a lot of things: Nothing works permanently. I play a bunch of other games on this PC without issues (Apex Legends on a daily basis).

Suggested Topics

Community Details

181
Online
218.4k
Users
36.8k
Topics
182.8k
Posts