Continue your odyssey

Welcome to discussion

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • Asvpxnicholl
    7 posts

    @r3dl1nes Nice, good to know

  • Ubi-Borealis
    Ubisoft Support Staff 2133 posts
    Best Answer

    Hello all!

    I apologise for the double post, but I would like to reach out to you all with an update following the announcement of TU 1.2.0. The development team plan to permanently resolve this issue following the release of this update.

    This update is due to be deployed 16 March, 2021 at 1PM CET/8AM EDT. You can read the patch notes and learn more here.
    If you are still unable to meet with Randvi following the deployment of TU 1.2.0, please can you provide us with a video that shows the following:

    • You have TU 1.2.0 installed. You can check this in the title menu in the bottom right-hand corner.
    • Randvi doesn't meet up with Eivor and Valka during "A Wise Friend."

    Thanks all! 😊

    Official Response
  • Zaphikiel
    4 posts

    @lucien_aus I've got the same problem on PS4. Reloading and restarting the game doesn't work for me. Even tried earlier save file, didn't work.

  • gamerojc
    1 posts

    I had the same problem on Xbox One, however restarting the game sorted the problem... Although I have not gotten very far in the game, I've noticed a few bugs already... Floating NPCs, NPCs who suddenly vanish etc...

  • pufftuff814
    1 posts

    Wise friend valka just stops walking.

  • zimpirate1
    9 posts

    Did they fix it yet?

  • Atomslicer_
    2 posts

    @r3dl1nes how did you get valka to continue walking????

  • Jonte76
    2 posts

    @r3dl1nes what book? Please help. Very frustrating atm

  • NGL_Apex
    2 posts

    @r3dl1nes "in ur book" - Please elaborate because this is frustratingly cryptic.

  • Bezwingr
    1 posts

    @ngl_apex in your quest log / or book as he called it, Randvi will be standing where valka keeps stopping and both quests work after

  • R3dl1nes
    Original poster 5 posts

    you have to go talk to Randvi first in the longhouse for the quest - The Alliance map quest then u can go talk to valka and start her quest from the docks

    they have to be done in this order or Valka gets stuck or randvi becomes untalkable

    be warned if u saved it pass this point u might have to reload an older save

  • fvb97
    1 posts

    I Have the same proplem she just stand still and it doesnt work to restart the game for me and i am on a ps4 pro and for some reason i need one last skillpoint in the skill tree but i cant seem to get more even tho it says im getting them and XP

    11 posts

    @fvb97 Try doing a couple of other quests, then restart the game again and see if that works, that what fixed it for me.

    11 posts


    Try doing a couple of quests nearby and then restarting the game again and see if that works

  • runenqiu
    1 posts

    If you have Wise friend and Alliance Map quests activated, Valka stays in the hill freezed because in theory she has to talk with randvi in that hill before she continues walking, but randvi is in the alliance table waiting for you to talk to her, but if you go to do the alliance table mission, it is bugged as well as you cant talk to rendvi neither.

    2 solutions:
    1- first do the Alliance Map mission before you start upgrading the village (buildings) so valka does not come and it does not activate A wise friend quest.
    2- If you did upgrade and got stuck, restart game, then fast travel to norway and then come back. If you cant do the Alliance Map quest by now because rendvi is now where valka got stuck in the first place (the hill), try doing now A wise friend quest.

    Hope this works for you.

  • Gilidan6
    2 posts

    Just go to a point were Valka just arrived and she’s stuck at the longhouse road from the dock. [censored] is this? How do I fix? Not happy about this “bug”

  • Gilidan6
    2 posts

    To give a detailed description it’s in the quest “a wise friend”. Valka gets stuck on the fork in the road right before the longhouse. She just doesn’t move. Tried everything except uninstalling the game and reinstalling which I’m not keen on doing. Ran into another problem when I am supposed to talk to randvi after Sigurd leaves in the quest called “the alliance map”. It doesn’t allow me to press Y to speak with her. All these issues are on Xbox one. Right now I can only do side quests and once those are done my game won’t let me play anymore. That’s depending on if there’s another bug during those so I’m not to happy about this.

  • MrCheeseyOne
    1 posts

    so in the mission a wise friend i follow valka with her stuff after talking to the blacksmith she walks up the hill some more and then just stops moving I've tried restarting ect....... but does the same thing

  • TaliesinWard
    7 posts

    Load an earlier save, ignore her quest go talk to Randvi and the young lad in the longhouse first as it triggers a main story quest which you will need to complete first. Once that's done you can go talk to Valka and the quest works fine. The issue is that Valka is waiting for Randvi to come out and greet her at that particular spot outside the longhouse, except Randvi is waiting for you to come talk to her to trigger the main story plot.

    Happened to me as well, this method fixed it.

  • Ubi-Spud
    Ubisoft Support Staff 675 posts

    Hey there! I'm sorry that Valka is refusing to walk to her hut. Are you able to load a previous save, from before you interacted with her?

    Official Response
  • Alexczy
    2 posts

    This has not been fixed in the latest patch 1.0.4.
    I thought and wished it was going to be fixed.

    Yes, I know I have to reload, but come on I never expected the game to have a game breaking bug this bad. I didn't have save point previous to this.
    Besides, hoping It was going to be fixed I continued playing, gathering armor sets, weapons, resources for upgrading, resources for the camp, doing side quests/world events, etc.

    Therefore if i had to start again, I would lose my power 60 progress.
    I have recorded this video in case you want to review it and see if exactly this happens to you or not, and my bug is different.

    I really hope they fix it in the next patch.
    I will try to raise a ticket, but as of now the support website is down haha.Too many bugs I guess.

Suggested Topics

Community Details