Welcome to discussions

Quick Suggestions

  • SOLVED [RESOLVED] Unable to progress with "A Wise Friend" as Randvi does not meet with Valka | POST HERE

    14 Likes/390 Replies/42895 Views
    Morlyx717
    2 posts

    @sanjuanbr

    I...finally...was able to get the horse thing to work. I had to nudge Radvi all the way to Reda's hut, but that did the trick for me. Complete pain in the @$$, but it was worth for me to finally be able to progress. Perhaps give it a try.

    Ultimately Ubisoft needs to fix this. So frustrating!

    Good luck!

  • Ubi-Borealis
    Ubisoft Support Staff 2207 posts
    Best Answer

    Hello all!

    I apologise for the double post, but I would like to reach out to you all with an update following the announcement of TU 1.2.0. The development team plan to permanently resolve this issue following the release of this update.

    This update is due to be deployed 16 March, 2021 at 1PM CET/8AM EDT. You can read the patch notes and learn more here.
     
    If you are still unable to meet with Randvi following the deployment of TU 1.2.0, please can you provide us with a video that shows the following:

    • You have TU 1.2.0 installed. You can check this in the title menu in the bottom right-hand corner.
    • Randvi doesn't meet up with Eivor and Valka during "A Wise Friend."

     
    Thanks all! 😊

    Official Response
  • devilishLuke
    1 posts

    getting the same error but it's now prohibiting me from moving on in the game. So I was in the middle of this challenge, and by this point reverting back to a previous saved game prior to starting the mission will set me back slot, like, I might as well start over. I did what others recommended and tried to talk with randvi and get all out of her... I ended up picking up a new location and finished it... So I can't go back to her and select the next location without finishing this mission... As well I can't upgrade any of my gear from the blacksmith. I am running the game on pc, specifically geforce now, as Im waiting to get the new parts in for my gaming pc.
    Also, version I am on is 1.10

  • SacredWest
    2 posts

    I had this same bug on XBOX One. I had already completed the Alliance map stuff, but hadn't spoken to Randvi about that. I can't talk to anyone in town. No blacksmith, no trader, no hunter. Not even Randvi. The yule festival activities work just fine but I can't progress anything, and Velka keeps freezing at the Y intersection near the longhouse just after the Blacksmith. It's completely corrupted my save, and I am having to restart the entire game. I was easily 24 hours into the game, a level 3 hamlet, had done SOOOO many raids I was getting sick of it, and now I gotta start completely over. FIX THIS BUG. Please!

  • SacredWest
    2 posts

    @sacredwest Update on this, I quit the game back to title screen and reloaded it to try the horse workaround. I loaded in to find Randvi chatting up the girl who runs the yule fight pit, but at the Y. This somehow saved everything.

  • TokkTTH
    1 posts

    @mcud thank you, that worked for me.

  • SomeBunnii
    1 posts

    @dracosoul

    All the prior posts about resolving this glitch above your post did not work for me for A Wise Friend quest. I loaded prior saves completing quests in different orders, redoing quests, going to Norway and back but Randvi was never there, etc.

    I stopped playing for a week because this was so aggravating. I am playing on PC. I I tried your suggestion and it worked for me just a little while ago. I'm not sure if there is any correlation but I did verify my game files before I tried this. It was easy and quick and I didn't lose any prior saves. I'm not saying this is the ultimate fix but for some reason it did work for me and I was finally able to complete the quest. I had not yet built Valka's hut and I had already completed the Lvl 3 settlement quest and completed the Grantebridge alliance quest. The Yule quests are also currently active for me, I started this before completing those quests I just mentioned.

    I started the quest and dropped the box I was carrying while walking up the hill just past the blacksmith while Valka was talking to him, then fast traveled back to Norway and immediately back to England. Randvi was at the top of the hill when I came back so I started the quest again but as we got to the top of the hill she was already gone.

    I restarted the quest again, dropped the box on the path in the same place and traveled again to Norway and walked forward a few steps where the game autosave came on and then fast traveled back to England again. I went to the top of the hill and Randvi was there again. I tried pushing her down the hill halfway-ish with my horse but this was really annoying. I kept getting her stuck everywhere and never made it past the the stone wall in between the tattoo shop and Hytham's hut so I decided to chance it because I'm impatient. I ran down the hill on my horse and started the quest again with Valka chatting while we walked with her boxes. I ran up to the top of the hill a few times during this, stopping Valka from walking and chatting. For whatever reason, Randvi stayed the entire time until I made it there with Valka,they chatted so the quest could continue and Valka continued to walk to her hut until the quest was completed.

    Again, this was just my experience, it could've been completely random but it finally worked for me. I am able to talk to Randvi and access the Alliance Map. I can also interact with any NPCs that I've tried in my settlement. This is my first game I've played on PC and bought then directly played through Ubisoft as well. I hope everyone having issues that cannot find a successful workaround gets a resolve for this soon too!

  • ADSCOPE
    1 posts

    Hi, I fixed the bug by starting the mission so it auto saves and then rebooting the game and selecting continue at the homescreen. It only seems to work if you've rebooted the game, if you try to just load without rebooting, the glitch just keeps happening. I hope this works, it did for me.

  • RagingPancake47
    2 posts

    Having the same issue as everyone it seems, I started the Wise Friend quest and talked to valka but Randvi won’t move from the table (I also can’t talk to her after completing a pledge quest for Grantebridgescire). I tried pushing Randvi with my mount, exiting and restarting my game, loading old saves, verifying the game files, travling between Norway and England and nothing works. I also can’t talk to anyone in the settlement, I think it has to do with the Yule Festival so now I can not progress in my game, try giving people an option to end the Yule event cause it’s not even that interesting so we can actually play the game so people don’t have to wait 11 days for it to end.


  • RagingPancake47
    2 posts

    @ragingpancake47
    I am on PC and Found that loading from Norway to England help spawn Randvi where she should be. I proceeded to shove Randvi with my hours all the way to the black smith, then wedged her between a wall and my hours so she wouldn’t walk away. I sprinted to the box and valka then ran to the blacksmith right away which made Randvi stop walking for me, they both talked quickly before they even reached the top of the hill. This also fixed my issue with Grantebridgescire pledge, this took awhile to figure out but hope this helps people out.
    P.S. Ubisoft is a pathetic excuse for a major gaming company and this game is so disappointing with the overwhelming amount of bugs.

  • RastafComa
    5 posts

    Hello folks, 

    I also had the problem that I could no longer talk to the NPCs in the camp. In addition, I had the quest with Valka active, so where you have to drag her stuff to her accommodation. She then just stops in the middle of the mountain without going further, and every time I started this quest. 
    The solution to both problems was to build the seer's hut in the camp. After that you can accompany valka with her stuff to the hut and after completing this quest also talk to the other NPCs again even with Reda. 
    I hope that solves the problem for you. 

  • Levit4s
    1 posts

    Hi there!

    Dear Ubisoft,

    I have a same problem with this bug - the Valka stop walking near to longhouse. 

    I tried England, I tried to push her with a horse... but nothing.

    Also waiting for help 😕

  • WraithCadmus
    6 posts

    @creepy-spox Not yet, I was missing one of the buildings, going to give that a try today.

  • Schakoww
    5 posts

    VALKA ( A WISE FRIEND QUEST) FIX!!!!!!!!!

    I was stuck like everyone, and then I just did Reda Contracts and log out, I level up 3 times, and then when I came back to Raventhorpe Randvi was in the right place outside Longhall, I just did the quest normally. Might be because of the low level (I was 99), and opened the quest for Knut.

  • tomirodgers
    2 posts

    Unable to progress with "A Wise Friend" as Randvi does not meet with Valka

    I have searched online and tried suggestions like validating game files, leaving to Norway and returning to England and this does not work. Randvi does not appear. I cannot talk to most of the NPC's or Randvi to start the quest with her in Gainsbridge. I no longer have a saved file before the '' A Wise Friend '' quest as they are over written. 

    I have too many hours to start again and this is really disappointing. 

  • RastafComa
    5 posts

    @tomirodgers did you build the seer's hut?

  • Big_Daddy_KS1
    2 posts

    I have same issue and now I can not interact with anyone in Ravensthorpe. This game is so sadly unplayable... I'll try again when more bug fixes get pushed out.

  • tomirodgers
    2 posts

    Yeah I had already built that

  • SummerCat35508
    1 posts

    i had exactly the same problem with Valka stopping and have been trying to sort it out for 3 days now. I have only JUST managed to fix it.

    before you go to speak to her, quit the game. This should allow the game to reboot.

    then when you rejoin, before you do anything else -> go to atlas and fast travel to norway.

    this fixed it for me, but if it doesn’t work for you then maybe try what everyone other people are trying and check the data

  • torind2000
    3 posts

    I'm glad support is taking this problem seriously.
    It's good to know that they have their customers best interests at heart.
    Oh, wait...SIKE it feels like they don't actually give AF at all.

    This basically pushes me towards never purchasing a ubisoft product again.

  • Arylius05
    5 posts

    @r3dl1nes I'm doing the Ledecestrescire alliance quest about half way through. I still cant get Valka to do anything. im not sure what you mean by alliance map quest. can you help? Ive done MULTIPLE restarts, reloads and troubleshooting (including building her hut) but nothing has seemed to work.

Suggested Topics

Community Details

31
Online
130.9k
Users
22.7k
Topics
117.8k
Posts