Welcome to discussions

Quick Suggestions

  • Locked SOLVED [RESOLVED] Unable to progress with "A Wise Friend" as Randvi does not meet with Valka | POST HERE

    14 Likes/392 Replies/45039 Views
    Xantumal
    1 posts

    Same Problem here on PC, same quest, same bug

  • DeaconRayne
    9 posts

    Hello,
    I cannot complete the quest "A wise friend" due to a well known bug. Specifically, when Velka arrives; Randv is not wait outside the longhouse to greet here. So Velka freezes in place.
    I have tried
    - Completing all available quests in the settlement aside from the Yule games. .
    -Attempting the quest during an alliance quest
    -Attempting to complete the quest after completing an alliance quest.
    -traveling to Norway and back.
    - Restarting my game

    I'm ready to declare this FUBAR. Anyone have any ideas? 

  • Ubi-Woofer
    Ubisoft Support Staff 1267 posts

    @fazanac Glad to hear that you've now been able to proceed! Let me know if you encounter any further issues that you require assistance with.

    @Saastan Can you take a look at the video posted by echo_139 on the previous page at the bottom? This is the method I'm attempting to describe, and the video shows it quite well how far you need to push her down the hill. Thanks for sharing, echo_139!

    @Threepsie Glad that the graphics settings workaround for PC worked for you as well!

    @johnsal423 I restored your previous post that you deleted by accident, and have deleted the subsequent one instead. 🙂 Hope this helps!

    @DeaconRayne Have you tried all of the workarounds I posted on the previous page that apply to your platform in addition to those you listed? Are you able to provide a screenshot or short video clip demonstrating the issue? Thank you!

    @Xantumal Can you try changing your graphics settings to high / ultra, restarting the game, and then trying to complete the quest again? This workaround has been successful for a few players on PC according to recent posts. Let me know the outcome!

    Official Response
  • DeaconRayne
    9 posts

    @ubi-woofer yes I did.
    Ultimately it was a hard reboot of the Xbox that did it.
    This game is so buggy I keep expecting Keanu Reeves to show up and tell me "We have a castle to burn"
    👉🤬💥☠

  • imranmohdar
    1 posts

    @deaconrayne same issue as well

  • nestaz1988
    1 posts

    @deaconrayne it works for me when i changed graphics from high to ultra.

  • rowerek156
    1 posts

    WORKS changing the graphics settings to high !!!

  • Saastan
    7 posts

    Tried again today and it worked in the end. Very glad to be moving forwards again I was really close to tossing the game aside, thank you everyone for posting your solutions - lets hope Ubisoft fixes it soon for all players and the need for travelling to Norway and back and pushing people downhill with your horse - without it being part of an actual quest -will no longer be needed.

    (throw the baby in the oven, anyone 😂 )

  • guest-KytSwDSn
    2 posts
    Valka stops at the top of the hill, while in transit to her home, and will not progress any farther. This essentially makes the quest incompletable and, thus, stops all game progression. I have read different solutions and have tried everything from carrying luggage to her house to making sure that certain quests are complete. To further explain, I have completed both "Settling Down" and "The Alliance Map." I enjoy this game, and I don't won't to stop playing it. However, I will have to move on something else if I don't soon find a solution.



    I am experiencing the exact same issue; very frustrating in the absence of any guidance on how to fix the issue.

  • KyraDrachenlady
    5 posts

    @theonehex

    just tried it, she wont sit on the horse and i can´t shove her there. she still stands there sadly

  • SneakyUrchin
    1 posts

    I have the exact same problem. I've reloaded it multiple times. I've put 15 hours into the game up til now and now i'm unable to continue. I don't want to restart just to run into the exact same bug in another 15 hours.

  • Big_Daddy_KS1
    2 posts

    the workaround worked!! I fast traveled to Norway, saved it, reloaded and fast traveled back to England. Ravni was now at top of the hill, so i used my horse to push her down the hill a bit and them blocked her against the rocks with my horse. Grabbed the suitcase and walked up with Valka. Ragni was there next to my horse and mission complete! Thanks for the guidance.

  • TheOneHex
    2 posts

    @kyradrachenlady you have to push her with the horse. It is not easy and took me a long time. But solved the problem.

  • KyraDrachenlady
    5 posts

    i wasn´t able to push her

  • crueljack3281
    2 posts

    @Utzung Thank you SO much! This was literally breaking the game for me.

    @Mambaz Fast travel to Norway and then fast travel back to Ravensthorpe. Don't talk to Valka or pick anything up, just ride to the top of the hill and Randvi will be close to where she stops. Fast travel was the ONLY way she would appear outside the longhouse for me. Use your horse to push her down a bit

  • print_r_delete
    2 posts

    Same issue with me. I can't continue the game it just stops at the top of the hill.. PLEASE HELP HOW TO FIX THIS

  • print_r_delete
    2 posts

    Hi guys I tried this. just reset by going to Norway and just back to England. after that find Randvi at the top of the Hill and push him at the bottom of the Hill just a little and then talk to Valkha again. Then everything will be fine. Here is the link of the sample video -

  • ThePopos12
    4 posts

    During the wise friends quest where you have to carry valkas luggage to her new home, randvi never shows up causing the game to crash and i cant proceed with the story

  • guest-7W4ODl2c
    2 posts

    Was just about to try it when randvi suddenly appeared at the top of the hill

  • GrunnyG2008
    3 posts

    I have this exact same issue. She won't follow me to the house and all I've seen online is to start over. I have put too much time into this game to start over. Also I think this is part of it in that none of the other villagers will talk to me, so I can't advance the game or buy anything at the store, etc. This is so frustrating that this bug exists. I've had good luck with ubisoft products and you guys make some of my favorite games, but for a bug like this to exist after this game has been out this long is pathetic. Playing this on an xbox one.

Suggested Topics