ubisoft discussions

Quick Suggestions

  • Locked Solved [RESOLVED] Unable to progress with "A Wise Friend" as Randvi does not meet with Valka | POST HERE

    14 Likes/392 Replies/50726 Views
    1 posts

    Same here. Valka just stops on her way to the longhouse and nothing I did resolved the issue.

  • ApGOD48
    15 posts

    @nomercy375 same thing with me a wise friend with bugged with east anglia bug as randvi is also bugged and she is not there where she is supposed to be so its more like a game breaking bug where u cant talk to anyone in settlement also u cant do anything in the progressive . i already provided everything to ubisoft now i need an update or refund

  • alecamused
    1 posts

    I have the same problem, nobody in the settlement wants to speak to me, Valka stands up the hill and won't move. Obviously i missed the chance to guide Valka up the hill at the right time, and continued with the story, now Randvi is stuck in the Longhouse and they can't meet. really hope this gets resolved soon, since i cant continue to play and really don't want to throw 13hours of progress away to load the one older savegame i have just to try it in the right order.

  • Mori_moto
    2 posts

    Same issue. Cant progress. Really frustrating...

    No one in the settlement can interact. Randvi sometimes jumps to the right location when i switch to Norway and back but then disappears when i start the quest with Valka.
    Savegames didnt help. Did put in about 8-10 hours of my lifetime... Reinstalling, Loading, Restarting, Switching Gender and Location,

    Is there a way to just end Julefest? Its pretty worthless anyways and might help some players to continue.

  • Ubi-MrM
    Ubisoft Support Staff 4172 posts

    Hello everyone,

    I have merged several threads into this new megathread for this issue with "A Wise Friend" whereby Randvi does not meet with Valka at the top of the settlement near the longhouse. Thank you all for continuing to reach out about this and provide new images, videos and workarounds - your input is greatly appreciated.

    We currently need further videos of the issue and save files to pass to the developers, so if you are able to provide either (or both!) then that would be amazing. You can read about how to send your save files over in this article, and can submit them to us in either a support case or Live Chat. If you find that you are unable to make a case on our website, or that Live Chat is not available, you can also message us on social media (Facebook / Twitter: (https://www.twitter.com/UbisoftSupport)) and a case can be created for you that way.

    In the meantime while the issue is investigated, some workarounds that have been effective for other players include the following:

    • Reverting to a previous save before starting "A Wise Friend" and ensuring that "The Alliance Map" is completed first
    • Fast-travelling to Norway and back, causing Randvi to appear outside the longhouse, and then manually pushing Randvi down the hill towards where Valka gets stuck using your horse before running to the docks and helping Valka as before
    • [PC Only] Closing the game, verifying game files, reloading latest save and escorting Valka again to Randvi

    We will keep you updated as the investigation continues. 🙂

    Official Response
  • ph47d3m0n
    4 posts

    They say they are working on it, but they don't show progression in this situation. I've already posted here and even on other places in this forum about this issue. The only thing they say is we are working on it..... Like many others I Payed for the game. Like many others I've invested so many hours into this game that it is NOT possible to load and start a previous save (will lose tons of progression if I do). What we need now is to see results!

    Put your acts where your words are UBISOFT! You are a MILLION DOLLAR INDUSTRY! It whould not be like we are back in the 90's where you could get away with glitches and bugs.... I'm at an age where I saw Ubisoft start and grow and where they were getting bigger and progressing in the quality of their software developing I am litteraly seeing them fall down even harder and faster!

    Don't know who told you to launch a game with these HUGE flaws but I would fire his/her [censored]!

  • ApGOD48
    15 posts

    ok so guys the fix is real i just got it happened . i dont know other bugs but this can be cure by puhsing randvi where she stands to some meters down and then doing the quest the monent u talk to balck smith randvi wont go in the longouse and weirdly but valka will talk to randvi and quest will be done .

    yes it worked and then randvi will be also there hence making it completing the quests

  • ApGOD48
    15 posts
    This post is deleted!
  • Whispium
    1 posts

    Some people use to horse to push Randvi down:

    Hope we get offical fix soon.

  • ph47d3m0n
    4 posts

    @apgod48 Problem is that Randvi in my case is inside the longhouse and she won't budge. My sweet horse also won't enter the longhouse.
    So for me that's not an option. I tried but no luck....

  • ApGOD48
    15 posts

    @ph47d3m0n go norway then come back then she will be standing there

  • legendar77
    1 posts

    I have this bug, that the woman who wants to settle down in my village and i have to carry her stuff to her tent, she waits infront of the longhouse, rendvi should come outside and talk according to the internet, but nothing happens. So I‘m stuck and cant do anything with quests, cant even talk to the blacksmith or the oder shop owners. Can someone help me?

  • dulingdude
    1 posts

    @whispium Thanks for sharing 👍 . This sorted it for me

  • plexxus27
    1 posts

    After attempting every other work around mentioned in these threads, this one finally worked! Thank you very much!

  • CoFactualist
    1 posts

    After many hours of playing I became unable to progress as Valka would walk half way up the hill and wait forever, not going to her house.

    I lost the ability to interact with any NPCs in my village and was totally unable to progress the story. I tried every suggested fix - restarting, changing gender, reloading, travelling to norway and back, and nothing helped.

    I tried verifying the game files and reinstalled it, and now all of my saves are corrupt and I have lost all of my progress.

    This is not ideal.

  • bedlamboy77
    3 posts

    Thank you!

  • SwishaMastaa
    2 posts

    Everytime I attempt the A wise friend quest Valka gets stuck at top of hill. I've completed the settling down quest so I dont know what to do after that. I literally cant progress that story.

  • SwishaMastaa
    2 posts

    Valka keeps getting stuck at top of hill even though I've finished settling down. Is this gonna be fixed?! I cant even progress..

  • UrameshiYuri
    9 posts

    When valka arrive at the settlement we need to walk with her til her new house, but she stops on the middle of the settlement and don't move for nothing, I can't continue the game history because of this bug

Suggested Topics