Continue your odyssey

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • MerkyBallz
    1 posts

    Same 😭😭😭 I'm nervous about playing more until it's fixed. I know their servers have been struggling. Probably just gonna switch to cold war until we hear back.

  • LordxScorpi0
    1 posts

    It happened to me too. Started a Seer mission and the game crashed me out to the Xbox home screen. I load back in to find 4 hours of progress flushed down the drain. I had autosaves and manual saves that were lost in this. This needs addressed ASAP.

  • Nicu9595
    5 posts

    i am on PC same thing happened to me like 2 times i save on manual 1 and my bro on 2 and next time when i have the chance to play for some reason my save is gone and both 1 and 2 are the same save its so frustrating i don't know what to do..

  • GreatestGal212
    1 posts

    At least I’m not the only one with this issue, I can’t even look at the game right now, lost at least 6 hours game play and the idea of doing it all again just infuriates me. Won’t be playing it again until this issue is addressed, it’s just not worth wasting my time over again. 😡😞

  • mlinic1
    1 posts

    The same thing just happened to me. Woke up at 4am to play before the baby woke up. Restarted the game during nap time. Everything I did is gone. I am still in the starting area.

  • camfurin123
    1 posts

    Hi I was playing when I loaded a old save game to play a mission again but when I tried to load my other save it was not their

  • suti383
    3 posts

    same here, I lost the whole East Anglia progress. And the problem is that the saving icon was there in the game time to time. And now Eivor is not even moving..

  • Ynexia
    1 posts

    i just lost a 42 hour save.... i am not happy

  • gengsta19
    5 posts

    Xbox series x. Lost today approx 6 hrs of game..... Please fix it!

  • Gooby1452
    10 posts

    Had some issues last night saying it couldn't connect to xbox live services through the game even though my Internet was fine and I thought nothing of it. Came back on just now and the game was already loaded. After a audio issue started I restarted my game to find my saves hadn't actually saved, both manual and automatic, I lost some gear and progress but luckily I didn't go through a whole mission arc. Really worried about catching up to where I left off and more just to lose it all.

  • ben241024
    1 posts

    Just lost my 16 hour progress. Customer support was useless. All my progress shows in my xbox live achievements and on ubisoft connect, but all the saves are gone

  • Nicu9595
    5 posts

    happened again looks like somehow my save is automatically overwritten every time with the other manual save and now i have 2 saves whit the same playthrough...

  • Diogaralmeidara
    15 posts

    Thank you for the help but it's too late for a picture now since I was the last one to save my girlfriends file save that was also called manual save 1 for some reason disappeared and instead there are two manual saves from my save game when it was supposed to be just one manual save from my character but they are both still showing manual save 1 so ill try and send a picture

  • Diogaralmeidara
    15 posts

    We tried at first doing 1 manual saves each at first it was fine manual save 1,2,3,4 but then no matter what it always says manual save 1 and the person that played last their manual save will disappear after the other person has done a manual save, we tried doing just 1 manual save each to keep it simple but they are both still named manual save 1 and keep disappearing one after the other.

  • Diogaralmeidara
    15 posts

    @nicu9595 that's what it happening to me and my girlfriend but for some reason mow its always named manual save 1 and the autosaves seem to be mostly mostly all between the same time 17:39 to 17:40 I would expect some of them to be at least 30 minutes or an hour before 2 days ago autosaves didn't save anywhere near the manul save sometimes autosaving about 2 hours before manual save or more.

  • Nicu9595
    5 posts

    @diogaralmeidara yeah i tried everything i lost 10 hs of progres then i started from the beginning same thing happened it looks like you can't have multiple playthroughs strange because i did not have this problem in Odysea i just let my little brother finish it first

  • Hearthmann
    7 posts

    Yeah, save files disappearing and corrupting is not unusual as it seems to be happening to a lot of people. Some people it keeps happening to on multiple playthru's. I managed to save some corrupted files on ps4 pro using cloud. I am not touching the game for 2 months, since save data integrity being ignored by staff tells me it will be awhile before they fix it. Save data integrity should be most important bug to fix, since no point playing a game in which all progress is going to be erased eventually along with people that have unused helix currency who lose it all upon save corruption.

  • Emcdade12
    1 posts

    Just lost 8 hours. Fix your dumpster fire of a game Ubisoft. This is a new low.

  • freky13
    1 posts

    Same here, tried to save manually, didn't work.. so I restarted the game and hoped auto save was effective, but it wasn't.. so lost a ton of playtime and ressources..

  • romerojg
    2 posts

    I just lost 6 hours, this sucks big time. Please fix auto safe😡

Suggested topics

Community details

39
Online
125.4k
Users
21.7k
Topics
111.6k
Posts