Welcome to discussions

Quick Suggestions

  • DARCY4524
    1 posts

    I've just lost over 5 hours of game play due to corrupted saves.

    Scrap the cloud save idea and give us back traditional saving to the console!

  • xMOOPS13x
    1 posts

    @dacia_and_gauls I was 11 hours into the game, I did a manual save, then I load back onto the game 20 minutes later. the last save was a 9 hour game and I was so far back from where I got to.

  • J1ackass
    2 posts

    Since update 1.04 i have been unable to fast travel or save. Today my game glitched where I got stuck between a bridge and a barrel. My character just died. Now my latest save is from 3 days ago. I have now lost 20+ hours of gameplay. Please advise when this will be addressed, as it's a little disappointing to pay £50 for a game I can't play.

  • mrdeadhead
    10 posts

    on ps4 and same, I was doing the Grantebridgescire quests and about to raid the Ely Monastery with Soma to finish it, and the game crashed (around 11pm the 28th), so I went to bed. and when I restarted the next day all save progress for hours was gone and the only thing I had were saves from right after we reclaimed the city (around 2am the 28th) from me playing the night before. so I have to go through the entiiiiiire investigation thing again, not to mention I lost progress on all the world encounters I had done while bored to death of the investigations. armor, books of knowledge, a couple zealots, skills assigned, an order member, all *poof* gone.

  • Ubiron78
    4 posts

    Can’t save on ps5. I tried the sleep trick and no luck. So frustrating. How is this acceptable?

  • diploidhelix
    14 posts

    I am having save game issues. I see that 2 different ones are created a cloud and local. The autosave cloud defaults to like 1-2 hours prior at least. I’ve lost progress once. Something happened in latest patch. Just make sure to save locally an manually. When it loads to a cloud version you need to load the manual one yo-yo saved locally.

    in regards to bugs. Yes Ubisoft should be ashamed in releasing games that are buggy. And they should at least make an effort to fix them ASAP. Their customers are who they should be listening to for bugs. But I am not going to abandon a game that I have loved and played for a decade now. Those who say they are never playing again are hurting themselves. First Ubi doesn’t give a crap what you think. You already purchased the game, duh. Second, all these bugs will eventually get worked out. Just be patient. It’s not the end of the world. Enjoy w]the awesomeness that has been created. If you can’t collect something come back later once it is worked out. If it is something major that prevents game progression or 100% completion let Uni know and keep fingers crossed it will be fixed soon. It will be fixed just a matter of time.

  • ftsi
    9 posts

    @saddlersm
    Hi,
    I'd like to add to this thread.
    Last week, like many, I lost several hours of game play, due to save game corruption. After restarting my XBOX One X, it seemed to now be saving once more.

    Today, I was about 3Kms away (after Grendel) and hitting as many Sync points as possible. After several hours of attempting to save and - I just wanted to grind away at the quests.
    I noticed I could not even Fast Travel. I had no live sequence or quest ongoing.
    I read these threads and figured I'd head back to Raventhorpe, to have Eivor rest in her own bed (as some have mentioned meditation or sleep helped). Rode the Mount, at full throttle and evaded a few enemies along the way...
    It did not fix my issues.
    So, I went back to the Seer. Drank the elixir to return to Asgard. - I was able to perform saves.
    Went back to England.
    Bumped into Wallace's Sister. This led us to complete this quest.
    At the end of it, I was able to save my game. (will it be corrupted? I certainly hope not).
    I was very concerned that I had lost another several hours (about 5 hours since my last save)

    But, phew....
    I was finally able to save my game.

    I hope neither of these issues return. But, I hope this helps someone else, before reloading an older save...

  • junofall
    2 posts

    My game crashed and I've lost like 4 hours of progress. I had several manual saves that've disappeared. Great game Ubi.

  • surgoshan
    1 posts

    Yup. Logged in to find my game not making any sound. Quit out, reloaded, lost a couple days worth of play. Frustrating.

  • BlitzBStone
    7 posts

    @ubiexcellent

    I just experienced the same issue. I fast traveled and upon loading into ledecestescire, I was able to start the leap of faith and before I hit the ground the screen went black and pulled up the Xbox dashboard. I started the game back up and when I hit continue, it loaded me into a manual save from 2.5 hours earlier. I’d completed multiple stages of a story mission and began killing members of the order and upgrading Ravensthorpe. All of my auto saves disappeared at the crash, and when I checked to see that they were all gone, I had 5 auto saves from having just loaded the game. Playing on the Xbox one, and have been using only two manual save slots, one for my current glitch free play through and one for my 90 hour bugged play through that’s still awaiting a fix for sons of Ragnar

  • ZoFarrZoGood
    1 posts

    I'm about 45 hours into the game on xbox one and now I am unable to save my game.. I have tried saving manually, but I get a message that I cannot save game right now. I have moved into different locations to make sure it isn't caused by something around me. The game is also not saving automatically as I completed a quest that should have had auto saves at each stage.

  • Danshawuk5
    2 posts

    Can't save the game or fast travel

  • Guitarguy212
    4 posts

    Playing on Xbox One X here.

    Just recently went to load my last autosave to retry a mission, having played for about 5 hours until that point. The game entered an infinite "loading, please wait..." screen, which I could not leave.

    So, after having no choice but to restart the game, I come back to my last save being aaaallll the way back to when I first started playing 5 hours before. All manual and autosaves, gone. Not the first time it's happened either.

    With the amount of people I've seen complaining about this issue online, losing saves due to having to quit or game crashing, I'm surprised this hasn't been fixed. This needs to be priority number 1 right now, because me and multiple other people don't feel like they can continue playing until we know it is fixed.

  • RomsXz
    1 posts

    Just lost about 12 hours of progress. Won't be playing for awhile 😞
    Btw I'm getting "could not sync with the cloud storage " error all the time

  • guest-O99FV0aG
    2 posts

    Despite your update, I just lost an entire day's worth of playing. It somehow retroactively made all of my saves from today corrupted. I truly don't understand how you can permit something this outrageous to keep happening. You didn't even have the courtesy to respond to my initial post when this first happened. It's deeply disappointing.

  • ltarqsuperbus
    8 posts

    I started a new chat (after waiting 10 days for a response to the previous one) and the new Ubisoft rep told me they couldn't refund me (even for a broken game) because I had already "accessed" it. Luckily, I explained the situation to my credit card company and they were happy to start a dispute / chargeback. Specifically, I explained to them that I did not receive a functioning product because the save feature (an essential part of the product) is not working properly. I also told them that over 100 people are on the forum complaining about this issue (so it is a known problem) and Ubisoft has not replied.

    If Ubisoft is not going to do jack [censored] about this, perhaps others should consider calling their credit card companies to discuss a chargeback. I know I didn't pay >$100 for a malfunctioning product. I will try to remember to come back and post an update if I hear anything about my chargeback.

  • ltarqsuperbus
    8 posts

    @ltarqsuperbus Update: Apparently Ubisoft changed their mind and decided to give me a refund after I mentioned a chargeback in a help chat with one of their reps. Since Ubisoft is now agreeing to refund me, I will cancel the chargeback I started.

  • Dobbyquan
    1 posts

    So I just lost 25 hours of progress. I started a new game on a NEW manual save slot. Played for two hours, logged in and the 25 hour file was gone with 12 autosaves being on the new file. Why would it clearly show my new game on a SEPARATE file and then overwrite the old file?

    I purchased the game so that me and my brother can have our own playthrough and I don't understand how that is possible if it just continuously erases other files. There is no option to turn off autosave which would solve the problem.

  • guest-SGF51zGI
    4 posts

    @harlow_hh I have got same problem. I uninstalled the game but it doesn't work. 10 hours of play lost. Incredible.

  • kizza0721
    63 posts

    @ltarqsuperbus
    I wish i paid by card. Glad you got that sorted.

Suggested Topics

Community Details

85
Online
142.8k
Users
25.2k
Topics
131.0k
Posts