Welcome to discussions

Quick Suggestions

  • piphuggins
    1 posts

    Just lost about 10 hours. The issue started for me over thanksgiving - and it still isn't fixed? I guess I'm done with the game now. What's the point of creating such big games if so many people who want to experience them can't get through them because of bugs. What a terrible experience.

  • daftpinksuzume
    3 posts

    I I am the sole user of my xbox one. There are no other profiles playing the game and I have not shared any gameplay online or done anything other than play the campaign as it is supposed to be played. There is no "corrupted" save file, all my save files from the past 4 hours or so have just disappeared.

    The most recent is an autosave from not long after I turned on the xbox this morning. There was an issue with the sound in the game - I could hear xbox noises just find but the game sound suddenly stopped after upgrading my settlement to level 3 and completing the Ledecestrescire Ragnarssons arc. I tried to save my game and exit/reopen, but it was sitting on "loading" and wouldn't even let me look at the saves. I left it and it sat there like that for at least 30 minutes. No internet issues either. I finally closed the game, then restarted it. Four hours of gameplay gone. I'm a completionist too, so I have spent the whole day looting literally everything, upgrading my power and gear,, and completing every quest in sight.

    This is the second time this has happened. Three days ago I turned on my xbox after work to continue playing and the same thing had happened. All the hours spent playing the day before were gone and I had to redo everything.

    There are all sorts of people with different theories as to what is causing this but I still haven't been able to see any real comments from Ubisoft about the issue or apologising to players for the massive inconveniences. Literal hours out of our lives for nothing. Considering what we paid for the game, this is pretty [censored] ridiculous.

    And hen after typing out my issue, I couldn't even submit this support request officially, as it said "chat is currently unavailable. Please choose another support method", then does not offer ANY alternatives except to wander over here and complain in the same place as everyone else while ubisoft does nothing to even acknowledge that they're screwing us around because they wanted our money and wouldn't get as much unless they released before cyberpunk.

  • daftpinksuzume
    3 posts
    This post is deleted!
  • daftpinksuzume
    3 posts

    @ltarqsuperbus and now they've blocked the help chat so you can only complain here and not actually speak to anyone at ubisoft... Considering doing this too if it happens again.

  • DRxMEXY
    4 posts

    JUST HAPPENED TO ME AS WELL, LOST 6 HOURS

  • ianabe
    5 posts

    Just happened to me. Knew something was wrong when the music kept playing for an hour and I couldn't fast travel or manual save, so I stopped playing after a mission bugged out. Thankfully only lost 1 hour gameplay, but this is truly unacceptable for AAA title. I can forgive a bugged mission and glitches, but saving should just be a given. I'll try playing offline as something is obviously not working with Ubisoft servers/auto save, but if this doesn't work then unfortunately I'm not risking wasted hours playing for nothing and will play something else (not Legion, or any other Ubisoft game, that's for certain).

  • ianabe
    5 posts

    THIS GAME IS OFFICIALLY BROKEN. Just played a mission with disconnected internet, hoping that would rectify the manual save game issue. It doesn't.

    As of 4 Dec and 30hrs gameplay, I cannot:

    • Manual save. Just says "cannot do this right now" even though I'm not in a mission/have no mission selected.
    • Autosave is broken. As a test, I completed a mission, the game 'autosaved' by the logo in the bottom right corner. I loaded the 'autosave' from 1 min after the mission completed, it decided to load from the start of the mission.
    • Won't allow me to fast travel
    • Won't allow me to exit the Animus
    • Won't allow me to travel to Norway
    • Won't be playing this game again
    • Won't be buying Ubisoft games again


    I was actually starting to really enjoy this game too, the same with Watch Dogs Legion, but this broken save feature is game changing and I don't trust it on this or any Ubisoft games anymore.
    I feel for the people on here who have wasted days on this!

    And not a word from the devs!

    I'm on Xbox Series X btw

  • guest-6SEUZLeQ
    1 posts

    Been grinding Wincestre arc all morning. Just found out the twist and then stopped for lunch. When I came back my last save was in Eurvicscire 5 hours ago. This is unacceptable. I had the wincestre basically finished, theings armour completed and spend a lot of time decorating my settlement. Safe to say I am done with this game and my day is ruined lol

  • MrNukezy
    1 posts

    Hello, I have a save on assassins creed valhalla that i play. I let my friend start a separate save to play the game. He had about 4 hours in it. When he got off I returned playing. After I was done his save file was gone. Maybe it was deleted by accident? Please help I want him to be able to play again without restarting.

  • OzoneHeals
    22 posts

    @ianabe yep, not a single word from Ubisoft since 1.04 broke saves. Haven't been able to play the game since then, 90 hours gone.

  • Phuzzi
    1 posts

    ffs it’s 2020 and a company can’t do game saves properly?! I’ve had this twice now, only lost an hour first time and thought I must have just been stupid but second time I lost several hours and now just can’t be bothered. Bought GoT instead and wish I hadn’t wasted money on Valhalla in the first place 😕 Valhalla’s story appeals to me so I hope they fix it but at this point I’m not sure when I’m going to pick it up again 😕

  • Cub1008
    5 posts

    Just happened to me too, Not as much as 12 hours but i put in a good six in collected all the hard to grind chests at a certain place, just to get back on this morning to find out i lost it all, think im done with the half working game..

  • thedream2017
    1 posts

    I lost a least like 12 hours and I was over twice my level had my max upgraded for the blue thing I forgot what it's called and I had 4 or more alliances done and now ik like [censored] don't even feel like playing anymore wasted my [censored] time

  • ianabe
    5 posts

    @ozoneheals OMG! Have you actually lost 90hrs! Or is there a save somewhere you can't access? This is an all time low for the gaming industry and Ubisoft in general.

  • GetWr3ckd
    1 posts

    Been having issues ever since my game crashed during Sons of Ragnar. Reloaded from a manual save and had to go back to the end of the fight for Tamworth then played without issues for 4 hours after. I got killed by a Templar, or whatever the hell they are, during a quest capturing lady Aethelswith and after death it loaded the auto save from f***ing Brothers of Ragnar and all my saves were gone. [censored] all that progress just lost!!!?? What is going on and what’s to keep this from happening the next time I die if it’s just going to delete my saves? This is such bs how much of players time is being wasted when we are already wasting time just playing your game..Ubisoft can’t even come up with a compensation for all the players this has happened to which is sad. I’ll take a damn refund because I don’t even want to play it anymore.

  • ianabe
    5 posts

    @phuzzi It's embarrassing and I don't feel safe playing any game that saves to the cloud these days. A similar story happened with SnowRunner and I stopped playing because of that reason. If I've lost 30hrs of Valhalla I most definitely won't be going back to it ever again and will be putting in a complaint.

  • Fink5827
    1 posts

    the sound stopped working on the game so I decided to restart after doing a save. When I came back online I lost over 12 hours of game play. This is very frustrating having to go back and complete things I already did.

  • guest-EkPFmDuu
    4 posts

    I was playing along and noticed that the save icon in the right lower corner of the screen was spinning endlessly and not going away. It got me worried, so I tried to save my game. But it wouldn’t let me save, saying “please wait” forever. Eventually the game crashed and tossed me back to the Xbox Home Screen. When I reloaded the game I had to load a saved game from the cloud but I had lost about an hour and a half of gameplay.

    This is the third crash I’ve experienced, but the most progress I’ve lost.

    I’m so upset. I don’t even want to play anymore. Shame on Ubisoft for releasing this unfinished game.

    Honestly, if you haven’t bought AC Valhalla, don’t do it. This game is unfinished. Wait until Ubisoft gets their act together.

  • SkeezyPeezy
    2 posts

    @frailunicorn Exact same thing just happened to me. Xbox Series S.

  • Revitzer214
    1 posts

    I just had it happen to me. All my auto saves and manual saves are gone. I was in the middle of a fight when Valhalla crashed. When it came back up my only save was from 7 hours ago! This is the second time it happened. At least the last time I only lost about 30 minutes of game play. Not an entire day.

    They obviously rushed this game before it was ready. Subpar graphic and cut scenes compared to odyssey, not glitches...now this....not impressed.

Suggested Topics

Community Details

163
Online
140.2k
Users
24.7k
Topics
127.8k
Posts