Welcome to discussions

Quick Suggestions

  • 1 Likes/794 Replies/21940 Views
    littlelady3799
    2 posts

    @guest-26l0jqqp I’m in the same boat and I am EXTREMELY frustrated. Have played the games for years and have loved them all, but this SUCKS

  • J0hny_ringo
    1 posts

    @littlelady3799 i lost 6 hours lastnight and its enough for me to want a refund. Sorry for your loss

  • paul110675
    1 posts
    This post is deleted!
  • Pr1nc3ssP3ach86
    1 posts

    This just happened to me for the second time. I lost my first game at 82 hours and I just (five minutes ago) found out my re-started game was lost also. Almost 70 hours into it. I'm going to request a refund on Valhalla through Microsoft. I contacted Ubisoft both times now with a "we sent your concern to developers" with no resolution. At all. I've been an AC fan since the very beginning and I'm not going to keep dealing with this.

  • iz_2SiCk
    1 posts

    I am so angry right now. I just bought Valhalla for my laptop because of the cross progression feature. I also have it on PS5. Booted it up on my laptop and the most recent save us missing 10 hours! If this thing also caused me to lose that progression on my PS5 I'm going to be livid. I don't have much free time so 10 hours of progression loss is a huge blow to me. This is what I get for buying multiple copies???

  • Casablanca1312
    1 posts

    I can report that this keeps happening on xbox series s. I had just gotten to england and raided the first monastry. I closed the game, went home for christmas, came back three days later, quick resume brought me to right were I left. Then an error message popped up saying I should close the game and restart. I had no issues with any game on my series s so far so I blindly followed. Now EVERYTHNG is gone. Its like starting the game for the first time. This was the first Ubisoft title I ever bought and it will be the last one for sure, seein that this seems to be a common occurence.

  • Gamerboy2000543
    1 posts

    I can’t install the game on my Xboxone. A message keeps popping up “Updated Needed. You need this update, but we can’t get it right now. Try again in a while. (0x8b050033)”.
    Does anyone here know why this is happening or what I should do? I’ve freed up storage space, tried uninstalling and reinstalling, checked my isp connection and no issues. Tried Xbox support but can’t get through. Tried Ubisoft support but have to wait for a response during their business hours M-F. I just want to play my new game I got for Christmas!!! 🙁

  • kendall210
    1 posts

    So im around 7 hours in I tried logging in and I cant get back to my save file please help me I am about to do the quest where you get better at raiding.

  • azullFR
    1718 posts

    @gamerboy2000543
    for your issue with "Update needed", you should have a look in this thread :
    https://discussions.ubisoft.com/topic/104041/assassins-creed-valhalla-won-t-update?lang=en-US&sort=newest_to_oldest

    there is a "no guarantee" workaround, maybe this will work for you 🤞

  • thalassashe11
    1 posts

    @casablanca1312 Same here, on the Series X. I initially recovered my save when I got that error message. Kept playing, manual save before I took a break. Played 6 more hours, tried to save again, and no matter what I did, no save file populated, and I couldn’t see load files, either. Everything was gone. A restart got me back to that earlier manual save, but those last 6 hours are gone, even though Ubisoft Connect says I have 13 hours logged.

  • B00MSIE
    395 posts

    @ubi-borealis

    Another couple of months have passed and I still experience this problem on my Xbox series x. Today only an hour, but still… I did download and reinstall the whole game last week.. I did start the game (not quick resume) from start. Did the Reda missions and messed around in a bandit camp for the weekly challenge (all kills were counted). After an hour the spinning never ending saving thing appeared again and I had to restart the game. Had to redo the Reda missions again and all progress from the beginning of my session was gone.
    It has been more then a year now. And still I loose progress multiple times each week, my Beserker gear gets constantly resetted, I have to redo the Reda dailies most of the time because they simply do not count (spinning save wheel bug), can’t participate in the Yule festival, experience multiple crashes and other bugs.… And the game gets more bugs with each update. Bought Ubisofts GR Breakpoint (145 hours played now) and that game has not had one crash, always quick resumes (it automatically reconnects), dailies work flawless and it never disconnects from the servers during gameplay. So I’m sure it’s Valhalla’s bad programming and not my internet.




  • kungfoomf
    1 posts

    I've had this happen a total of 4 times now. Max I've lost at one time is 3 hours. And that has happened twice. Such a frustrating bummer. The worst part is that Ubisoft won't just admit it. Actually the worst part is they still haven't fixed it in over a year!!!

  • dorestes
    5 posts

    So...over 500 hours of progression in game, was most of the way through the Paris DLC (I switched over from XboxOne to SeriesX about a week and a half ago) and I got the error message that my game could not be saved and to restart. I tried manually saving and it wouldn't let me. I restart and....boom. All save progression is completely gone.

    Is it really gone with no way to get it back?? Neither the autosaves nor the manual saves? Someone tell me there's a way to get it back....

    [EDIT: Also, for the last couple of days I've been getting an error in both Valhalla and Odyssey connecting to the Ubisoft server for opal/orichalcum rewards and quests. It's not an internet issue on my end, as other online games are working just fine.]

  • dorestes
    5 posts

    @guest-26l0jqqp yep. This is exactly what happened to me tonight. 500+ hours of progress just...erased.

Suggested Topics