Welcome to discussions

Quick Suggestions

  • Ubi-Wan
    Ubisoft Support Staff 631 posts

    @uncleblazing Hello there! I'm sorry to hear about this happening. I'd like to have you grab a video of this issue occurring for us to review. After returning to the boat, were you unable to leave the boat as Eivor, or was your boat simply stuck in place no matter what was pressed?

    Official Response
  • UncleBlazing
    12 posts

    @ubi-wan
    The boat will not move regardless of what is pressed. I’m sitting down in the boat. I looked at walkthroughs online and the boat should start moving on its own but it does not.

  • UncleBlazing
    12 posts

    @ubi-wan
    it won’t let me attach a video or a photo, but I return to the longboat. I Select interact, screen goes black then I’m still in the same place and the quest says reach Halfdan’s settlement but I can’t move the boat and the boat doesn’t move itself.

  • UbiKoality
    Community Manager 440 posts
    This post is deleted!
    Official Response
  • Ubi-Borealis
    Ubisoft Support Staff 3626 posts

    Hello all!

    I've merged together a few threads about this issue together into a single thread. I apologise if this has disrupted any ongoing discussions. By creating a single thread, it will allow us to keep all information and updates regarding the investigation in the same place.

    I'm sorry to hear that a number of you are having trouble proceeding in "The Swan-Road Home." After reading through this thread, it looks like there are two main issues being encountered:

    • After completing the river blockade and boarding the long ship again, the ship doesn't move.
    • When arriving at the settlement, the cutscene with the bandits doesn't trigger.


    If you are encountering a different issue to this, please can you let us know within this thread? We can then investigate this further as well.

    If you are encountering either of these issues, would you be able to provide us with the following information:

    • Have you tried fast-travelling back to Norway and returning to England to see if this helps you to proceed?
    • If possible, could you try reloading an earlier save to see if this allows you to proceed?
    • Could you please provide us with a video that shows you're unable to proceed in "The Swan-Road Home?" This could either be the boat not moving, or the cutscene not triggering. You can upload the footage to a sharing platform (such as YouTube or Google Drive) and post a link within this thread.


    We can then pass this information along to the development team for a closer look.

    @UncleBlazing - Would you be able to answer the above questions for us?

    Thanks all! 😊

    Official Response
  • UncleBlazing
    12 posts

    @ubi-borealis I am unable to fast travel back to Norway when I go to the map. And I have already tried going to a previous save before the mission has started.

  • Ubi-Borealis
    Ubisoft Support Staff 3626 posts

    Thanks for those updates, @UncleBlazing. Would you also be able to provide us with a video that shows you're unable to proceed in "The Swan-Road Home?" We can then pass this along to the development team for a closer look.

    Thanks! 🙂

    Official Response
  • UncleBlazing
    12 posts

    @ubi-borealis
    I have already tried attaching a video twice before. I can’t get it to work.

  • Ubi-Borealis
    Ubisoft Support Staff 3626 posts

    @UncleBlazing - I'm sorry to hear you're having trouble sending us a video. Could you try uploading the video to a sharing platform (such as YouTube or Google Drive) and post a link within this thread?

    Thanks! 🙂

    Official Response
  • Scrocchia1234
    2 posts

    @ubi-borealis I reached the part where they sail to England, and right before reaching the Sons of Ragnar's village, the game crashes and the error reads: "Cannot continue using the application. The data for the following application is corrupted. Delete the application from the PS4, and then insert the disc again"
    I deleted the saves and restart the game, as soon as I reach the same point, the error appears again, also I can't fast travel back to Norway, I reloaded an earlier save but the error still appears

  • Ubi-Borealis
    Ubisoft Support Staff 3626 posts

    Hello there @Scrocchia1234! Welcome to the forums 🙂

    I'm sorry to hear you're experiencing a game crash whilst sailing to England. Thanks for letting me know what you've tried already. I would recommend trying these other troubleshooting steps. In particular, please can you try rebuilding your PS4 database, as this may help to fix any corrupted files.

    Thanks! 😊

    Official Response
  • Scrocchia1234
    2 posts

    @ubi-borealis I followed the instructions of the error message and worked, thank you for your help!

  • Ubi-Borealis
    Ubisoft Support Staff 3626 posts

    Thanks for the update, @Scrocchia1234! I'm glad that your issue has been resolved 😊

    Official Response
  • UncleBlazing
    12 posts

    How long till Ubisoft patches this issue? I waited a couple months before I bought the game so that some issues were ironed out. But I have been able to play for a month now and this issue has not even been added to the list on the main problems thread. This game is a joke compared to all of the other previous AC games I have played.

  • Ubi-Borealis
    Ubisoft Support Staff 3626 posts

    Hello there,

    I apologise for the delayed response. The development team has been investigating this issue further. They have been unable to reproduce this issue so far during their testing, and would like to know if any players are still affected by this issue in "The Swan-Road Home."

    If you are still unable to progress in "The Swan-Road Home", can you please let us know the following information:

    • Have you tried fast-travelling back to Norway and returning to England to see if this helps you to proceed?
    • If possible, could you try reloading an earlier save to see if this allows you to proceed?


    Could you also send us a video that shows the following:

    • You have TU 1.2.1 installed on your platform. You can check this in the right-hand corner of the main menu
    • The specific issue you're encountering in-game (either the ship no longer moving, or the interaction with the bandits not triggering when arriving to the settlement)


    We can then pass this along to the development team for a closer look.

    Thank you 😊

    Official Response
  • Ubi-Borealis
    Ubisoft Support Staff 3626 posts

    Hello there,

    Following the release of TU 1.2.2, this issue with "The Swan-Road Home" has been marked as resolved by the development team.

    If you're still encountering trouble with this quest, please don't hesitate to update this thread so we can take a closer look. Please include a video which shows the following:

    • You have the latest Title Update installed on your platform. You can check this in the right-hand corner of the main game menu.
    • The issue you're encountering in "The Swan-Road Home."


    We can then forward these reports to the development team for further investigation.

    Thanks! 😊

    Official Response
  • UncleBlazing
    12 posts

    So it’s been 5 months now and I decide to delete and and reinstall the game and get it fully up to date. Sadly the glitch has continued to occur. I don’t know what else to try and I’m thinking of just cutting my losses with the amount of time I have tried to get this game to work. It’s just ridden with bugs

  • Ubi-Borealis
    Ubisoft Support Staff 3626 posts

    Hello there @UncleBlazing,

    I'm sorry to hear that you're still affected by this issue following TU 1.2.2. Thank you for letting us know that you've tried fully reinstalling the game as part of your own troubleshooting.

    Would you be able to send us a video which shows the following information:

    • You have the latest Title Update installed on your platform. You can check this in the right-hand corner of the main game menu.
    • That your longship doesn't move after completing the blockade, preventing your from progressing further.


    I appreciate that you have sent us a video previously. The development team would like to see how the issue behaves on the most recent Title Update, as this was an issue they had hoped to resolve in TU 1.2.2. We can then forward this to the development team for further investigation.

    Thank you 😊

    Official Response
  • Ubi-Borealis
    Ubisoft Support Staff 3626 posts

    Hello there!

    As we have had no further reports of this issue persisting in-game following the release of TU 1.2.2, we will now be locking this thread.

    If you encounter any further trouble with "The Swan-Road Home," please don't hesitate to open up a new thread so we can take a closer look. When opening a new thread, please include as much information about the issue you're encountering as possible. Any images or videos that demonstrate the issue in-game are also helpful for further investigation.

    Thanks! 😊

    Official Response

Suggested Topics

Community Details

78
Online
196.1k
Users
33.2k
Topics
165.9k
Posts