Welcome to discussions

Quick Suggestions

  • CancelToDebug
    11 posts

    Since Ubisoft haven't bothered to even acknowledge this issue I will have to do what others have said and I previously ignored; I will vote with my wallet and not purchase future Ubisoft games if this problem isn't resolved.

  • MattyPollo
    9 posts

    Some already shared this link earlier, but it looks like support responded to this issue here:
    https://discussions.ubisoft.com/topic/79188/screen-tearing-on-xbox-one-x/11?_=1605298505200

    So hopefully it will be addressed.

  • Ehllfhire1
    86 posts

    @vagmc1982 that money was better spent on an actual pc not a wannabe pc.

  • NinjaslayerX
    4 posts

    I'm playing on the Xbox Series X.
    I've noticed screen tearing through some gameplay sequences. I haven't pinpointed an exact scenario yet so no test case unfortunately.

    The more annoying bug I've experienced three times already is my screen goes black, the gameplay continues since I can hear it and my TV shows input info. The input info usually shows after I've switched inputs or when HDR has just been enabled and also if I change the resolution in the Xbox settings.

    This has happened three times so far and I've only just reached Fornburg.

    I've played Forza Horizon 4 to test the TV since it runs at 4K60FPS HDR just as Valhalla but haven't received an issue there. I spent a lot more time on there and multiple sessions. So far it's just AC.

  • NinjaslayerX
    4 posts

    @simleads Yeah same here.

  • NinjaslayerX
    4 posts

    *Another Bug
    The white light shining on my character flickers while I'm changing tattoos. It doesn't seem normal so I'm making a note of it.

  • ImNoHeretic
    1 posts

    Hi Ubisoft

    Any word on a fix for the screen tearing in AC Valhalla on Xbox Series X?

    I would really appreciate a fix for this 🙏

  • NinjaslayerX
    4 posts

    *Bug
    In raven mode some icons appear for a second and disappear.
    If I exit and reposition the icon will be there to interact with.

  • diiorio
    40 posts

    @imnoheretic sounds like Vsync is off. I play on a 4k tv wit ha more powerful PC, and have to have vync on or it tears, so have to set it to 60 fps locked with on.

    Some games have the performance mode for higher frames, series x does as well to down scale spots frames drops and to maintain 60 fps mode. but wondering if vsync is not active which is a must for tv's

    The review shows it doesn't do 4k 60fps with out the adaptive on. its upscaling to 2k, in 4k it will still downscale spots. Check the settings. also if you have a tv with game mode make sure its on. it has a faster rate.

  • arn0low
    14 posts

    It's also happening on Xbox One and Xbox One S, please don't forget us Ubi !

  • RagnarGod85
    3 posts

    Ditto on series x with LG B8. The game looks fantastic in parts, but regular testing is really breaking the experience.

  • fatamericanhero
    1 posts

    Ubi, please fix the screen tearing. Let's have some vsync. No excuse for it

  • Simleads
    9 posts

    @imnoheretic There’s a LOT of complaints on social media about this. I’m playing on SX with LG C8 and hate all the screen tearing as well. Seems mainly on Xbox platforms for some reason. By now Ubisoft should be aware of the problem (they should have been aware before shipping tbh), so hopefully a fix is being worked on. Even a statement from them saying they acknowledge the problem would be a start.

  • Darkmidgar
    7 posts

    @simleads same problem

  • Darkmidgar
    7 posts

    Same problem one serie x and one X !! Sony bravia kdx & Samsung 4k...!!

  • RICHxyz
    1 posts

    I have an LG OLED65CX6LA and the screen tear is very noticeable even with instant game response and vrr activated


  • PiersSaunders
    8 posts

    @richxyz Which is rather worrying, as this is the gold standard TV for VRR, which begs the question what was the game tested on, and is tearing known and was acceptable? I really hope not. I played again and it was frustrating to witness, not least because the game wouldn't progress the "Follow Sigurd" and then would get repeatedly stuck at assasin training. Loading a very early save fixed it.

  • Darkmidgar
    7 posts

    @jeffclaire083 acces denied!?

  • MattyPollo
    9 posts

    @darkmidgar all of a sudden the link to the other post where ubisoft actually responded says access denied... weird

Suggested Topics

Community Details

54
Online
138.4k
Users
24.2k
Topics
125.6k
Posts