Welcome to discussions

Quick Suggestions

  • il.cirozse
    1 posts

    i've tried to run ac valhalla but the game is stuck in mini window,can someone help me??

  • RED-SPIRIT-K
    3 posts

    @il-cirozse none of us have had any luck yet. ive tried everything to fix mine.

  • onigiri03
    2 posts

    mine just randomly freezes all my game file integrity seems fine, tried increasing my page file as well nothing works

  • Daleth42
    3 posts

    Ok, I spoke with a support tech, and they had me update a setting in the NVIDIA control panel to use the high-performance NVIDIA processor instead of letting windows determine which processor to use (integrated vs high performance). If you are using a laptop with multiple GPUs, windows may be choosing the integrated one by default. To check (for NVIDIA users), go to NVIDIA Control Panel (available via right clicking on the desktop) and click on "Manage 3D settings", you can either update the global settings to always prefer the high performance one or click the "Program Settings" tab and add Valhalla and tell it to use the high performance processor.

    Note, this worked for my issue and may not be a fix for everyone, but for those who have run out of things to try it might be worth it.

  • Jutzukan
    14 posts

    Same boat since launch. Frustrating AF. As many of us that seem to be reporting this it's not listed as a technical issue in the top pinned post on this sub. Why release a broken game??? Take a cue from CDProjekt and delay until it's worth releasing.

  • RadhikalZ
    1 posts

    I'm having the same or at least a similar issue on my end. It's initial start up is a bit slow, then it goes through the opening fine enough, then when I tried the game - it's slooww as all get up, the graphics keeps spazzing and having flashing bars or random lines then eventually freezes to a black screen where the sounds are still there, but I can't see or do anything. The farthest I've gotten is slightly past when the kid talks to his dad and is ready to go talk to the king, then nothing and black screen.
    I've made sure my system has been all updated, attempted to change the graphics to medium, low, all that jazz and yaah.. nothing. Even uninstalled other games to make sure I had room or they weren't blocking the game from running well.
    I've got a
    Intel(R) Core(TM) i7-9750H CPU @ 2.60GHz  2.59 GHz
    which I thought would be fine - who knows maybe that's the problem

  • arnonie
    5 posts

    same my game just keeps freezing after 2-3 minutes it has been like this since launch not a single response

  • gnowitzki
    2 posts

    I was relieved that there was a player with the same symptoms as me.
    Support just asks for Dxdiag and Msinfo and doesn't admit any bugs.

  • topchip35
    1 posts

    Happens on xbox series x aswell don't think its a hardware issue as lots of people are being impacted across all platforms, needs fixing as it makes the game unplayable.

  • Skinfaxe_DK
    5 posts

    @onigiri03 Same for me - freezes every now and again - think it has to do with the adaptive settings during graphic-intense moments/areas. Switching them off seems to help?

  • MissMDee
    4 posts

    Same for me except I’m on PS4. It freezes every time I try to start the game now. I can’t play at all.

  • snaazex
    2 posts

    Same here for me on a PC.

    Starting the game just ends up in a permanent popup just after launch, then nothing else happens no matter how long I wait. Issue registered with support, no life signs from the company at all. Frustrating to wait this long without being able to use the product you've bought.

  • Abhi_TheGamer
    Original poster 7 posts

    Looks like the 1.0.4 patch does nothing for me and still have issue. Same config, Ryzen 7 2700X, GTX 1060 6 GB Version, game is installed in a SSD in exFat file format.

  • jaanarasanen
    1 posts

    I finally was able to get the game and was excited to start playing but mine keeps crashing also.
    I have a bit of an older PC but I've had lot's of games without issues in the past year and for this I even went the extra mile and got a separate cooling pad to keep the PC cool.
    My specs
    Processor Intel (R) Core(TM) i5-7300HQ CPU @ 2.50GHz
    RAM 8.00GB

    I also had to download an update for it but looks like it did nothing to help fix the issue.
    I can't get anywhere from the first black screen with epilepsy warning.

  • arnonie
    5 posts

    @gnowitzki they dont even respond to the messages

  • Breakabletie
    6 posts

    same here i try to launch the game but it freezes on the launch screen i have submitted a support cases and they told me to disable all of my starting apps and then go 1 by 1 turning them on to find what is causing the issue but i tried to launch the game with no starting apps enabled and it still does not work

    i bought AC valhalla through the ubisoft store

  • arnonie
    5 posts

    @breakabletie they havent told me anything i have the game since launch and they didnt respond then still dont now

  • Breakabletie
    6 posts

    @arnonie i submitted a ticket and they are currently responding to me but i have had 4 different people respond and of all the instructions they have given me (update windows/graphics drivers, delete temp files, disable antivirus & start up apps, and uninstall/reinstall Microsoft visual studio c++ redistributables(several things). and of all these things (and they asked me to do some of these things several times) have not worked. after every step they give me i try to open my game but the valhalla launcher freezes as soon as it appears on screen

    i feel like i am getting nowhere with the support team and am going in circles. at this point i just want my money back because this is ridiculous

    also because i have 'launched' the game from the ubisoft connect i cant request a refund from my end.... i am posting a message on my support case notifying ubisoft of this forum page and the lack of support to those who have posted here. i am also requesting that i get someone with the authority to grant me my refund

  • Plan3tCrackr
    46 posts

    @jaanarasanen I had a similar problem when I initially installed the game on the drive that contains all my other Ubisoft games, including Odyssey. One or maybe all of the following steps got the game to finally launch for me, I am playing with the Ubisoft+ subscription service and did not outright purchase just the lone game (this is my first experience with both Ubisoft Connect that replaced UPlay and the Ubisoft+ subscription service):

    My PC has 5 drives, boot/OS NVME(SSD), 2 SSDs and 2 HDDs. My fix to get to the actual start screen to access options, benchmark and new game and finally play the game was to uninstall and reinstall Ubisoft Connect, install the game on the C : OS boot drive in the default Ubisoft Connect location while also renaming the game's folder from "Asassin's Creed Valhalla" to "ACV" as some users claim the apostrophe can cause problems, not sure if true. Also, I am in online mode, not offline, as playing Ubisoft+ version of games requires constant online connection. I am using Ryzen 2700X CPU and 5700 XT Nitro+ GPU and get intermittent game freezes requiring a force close of game using task manager but those can occur anywhere from 5min to 3+ hours of game time and seem to occur on not just PC but other systems too; freezes beat not fully launching.

    Pic of install location and folder rename:
    undefined

  • arnonie
    5 posts

    @breakabletie yeah me 2 at this point i just want a refund its been 3 weeks and nothing has been done i havent even received a response.

Suggested Topics

Community Details

89
Online
140.5k
Users
24.8k
Topics
128.3k
Posts