Welcome to discussions

Quick Suggestions

  • Asryan2a
    55 posts

    @bendelaboombr It's insane and not logical. I played 30h without any issue and now the game is unplayable and not even sure Ubsoft said anything about it

  • ImSIEBEL4TOdaY
    7 posts

    Just to update.

    Ive updated my geforce experience app to november 9th 2020 and it doesnt crash no more. Give it a try.

  • Asryan2a
    55 posts

    I don't have it installed at all weird

  • VanZan1985
    1 posts

    @bendelaboombr yes , stright up reinstall worked for me , I had constant freezes when playing dice or talking to npc. Now works fine for 1h we will see more.

  • BendelaBoombr
    Original poster 42 posts

    @imsiebel4today I already did that I played for about 3 hours it froze, and it was freezing every 5 minutes having to close in the task manager, I restarted the computer and ran for 2 hours and started freezing again

  • Asryan2a
    55 posts

    Same for me.

    i tired to mail ubi, posted some topics on the forums, tried to contact via facebook or twitter, NO ANSWER.

    We payed for a game and since the issue isn't isolated it's coming from the game !

  • MoZz-DK
    2 posts

    same problems here, it started after 30hours gameplay, my gpu is around 140f/60c and cpu is around 90f/40c ingame.
    i have downgraded to 456.71 drivers still crashing.

  • MANHATTAN_GOON
    1 posts

    having the same issue, crashing 15-30 minutes in rendering the game unplayable. happens usually during combat, on a mount or sailing. i9900k/2080Ti/32gbRAM. first it was crappy FPS optimization, stuck in walls, crashes, broken quest, glitchy skies, now I can't even play the game. please Ubi investigate this and hear our pleas!

  • Legionary_Ant
    2 posts

    If I run the game with environment settings on High the game freezes after some time but if I change the environment settings to medium all crashes are gone.

    I read that this a VRAM leak problem which Ubisoft addressed in the latest patch 1.04.
    But the game keeps freezing with environment settings on High.

    My Specs:
    RTX 2070 S
    i7 8700k
    32 GB RAM

  • Ryusennin
    71 posts

    Same random freezes on Ryzen + Vega, especially since patch 1.04.

    I can play 5 hours straight without any issue, then another game session can crash 20 minutes later (be it while in combat or looking at the inventory).

  • MountainMadman
    1 posts

    Same. Sporadic freezing occurring on a Ryzen 5 3600, 16GB RAM and RX5700 XT. Didn't used to happen before the latest patch. I've found that closing the Internet browser before launching the game helps.

  • Ciaossu-
    25 posts

    I can play this game like 4-5hrs with no crash, then this past few days since new patch I've been experiencing sudden freeze in game 😞

  • Bushwickedly
    109 posts

    I notice rare character freezes (can't move but camera moves and game still runs) which seem tied to auto saves. Would be nice if we could either turn them off, or lower their frequency to once every 15 minutes or something. Seeing 5 autosaves occur every minute over a 5 minute span isn't normal and can introduce a ton of unwanted bugs.

  • Asryan2a
    55 posts



    I managed ot played hours withotu crash yesterday and right now 2 crashes in 30m.. it's driving me crazy

  • LopataTURBO
    4 posts

    Game clearly started crashing after patch.Till patch i had 100h ingame and not a single crash.Its that simple..

  • YazX_
    143 posts

    today i got my first 2 freezes, music plays but everything else freeze, had 72 hours on record, not a single crash nor freeze before, but i had my first freeze while fighting a zealot, then killed process and played again, now it froze while in raid, looks like something goes wrong while fighting especially if the fight is taking long time, this is the common situation between both.

    and one more thing, all happened in Essexe, i'm around 60% progress in the story and had many locations completed.

    Ryzen 3700X
    Asus ROG 1080 Ti
    16 GB G.Skill Royal 3600 Mhz RAM

    Nothing Oced, all stock.

  • Plan3tCrackr
    46 posts

    I use Ubisoft+ and have had crashes with both 1.02 and 1.04 patches, didn't start playing until 1.02 patch. Using older Radeon 20.9.1 drivers seem to cause fewer crashes than the latest 20.11.2 drivers, but crashes can still occur at random whether in menu, a battle or simply standing around scratching twigs and berries. I've completed every troubleshooting step but no improvements. One note, I couldn't get the the New Game / Options start screen until moving the game to my OS drive and renaming the game folder without an apostrophe; I'm not sure if one or both of these actions caused the game to finally fully launch. Regardless, the first crash happened 10 minutes after first gameplay.

    Please allow showing of signatures that worked when the Beta forums launched so I don't have to keep posting PC specs: X470-F, 2700X, 5700 XT Nitro+, 16GBCL14, NVME, 650WGold, 1080p60Hz, 1440p144Hz

  • DutchDerq
    11 posts

    @lopataturbo Same here. Problems started after latest patch.

  • DutchDerq
    11 posts

    Try this fix guys:

  • DutchDerq
    11 posts

    @dutchderq so far so good. Seem to work.

Suggested Topics

Community Details

38
Online
131.1k
Users
22.7k
Topics
118.2k
Posts