Continue your odyssey

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • name_is_gone
    19 posts

    So, uhm... Any info on this? What's the point of bringing back good old mechanics of blending when I cannot blend because guards instadetect me cause I move like injured snail? Also, not sure if this has anything to do with walking speed when in disguise, but whenever I even look at guard, they just attack me. I don't do anything, just stand with random people, don't do any sudden move and they still attack me. This whole blending mechanics is really badly implemented.
    Btw, I play on K&M, don't have controller and I agree with what others said here - it's not our hardware issue, it's game issue.
    Kindly provide update and better, fix for this.
    God I so wish I waited with my purchase -_- I'm not even interested in playing anymore because the immersion and experience are broken already.

  • RevenantSP1
    32 posts

    Waited for the 1.1.0 update with anticipation and guess what? This issue is still not fixed. Really? The disguise is part of the core mechanics and it's not working as intended. Are we going to have to wait another 15 days before this gets fixed? It's a simple issue - my bet is it could be fixed by an intern and deployed in a 500kb hotfix. It's an important fix that is needed with a very tiny amount of time needed to fix it.

  • Minominop
    7 posts

    I have this same issue as well.

  • Javier_Pazdan
    7 posts

    Hello people,
    In this video I'm showing how to configurate our mouse to walk faster with hood puted on. We need anyway pad from console to configurate it.

  • Javier_Pazdan
    7 posts

    Hello people,
    In this video I'm showing how to configurate our mouse to walk faster with hood puted on.
    We need:
    -Any pad controller from console connected to our computer,
    - Program for Playstation pad like "ScpToolkit"
    -and "reWASD" program

  • RevenantSP1
    32 posts

    @javier_pazdan Thanks for the info. But I'll pass. I'll do some [removed] (neither of which have a solution available currently). But I'm not getting and plugging in a controller for a workaround like this.

  • Javier_Pazdan
    7 posts

    @revenantsp1 Ye mod would be great but nobody have make one, it would be great if someone have make that we can put only hood on without cape like Sigurd 😕

  • RevenantSP1
    32 posts
    This post is deleted!
  • Merf220
    1 posts

    @revenantsp1 it’s insane that even after the 1.1.0 update this immersion breaking bug still isn’t fixed. Shame I have to swap between controller and keyboard. Be better, @Ubisoft

  • RoachSandeson
    5 posts

    @merf220 I know man, let's hope they toss it in with the next round of updates, whenever that is. I've sworn to not proceed into Wincestre until they fix it because I wanna try to do that part super stealth like.

  • CarnageGGWP
    1 posts

    such a big bug like this should be among the top prio shouldnt it? how is this yet to be fixed? get it sorted as its straight up ruining a big part of the game!

  • Spidermonk111
    10 posts

    Something I noticed is this acts the same as Odyssey's walking bug. The game seems to put you into certain states that will naturally slow down your walking speed.

    This includes:

    • Entering a cave or inspection zone
    • Walking near tall grass or bushes (anywhere the character will put their hand out to brush it)
    • Using the cloak

    All of these places will cause Eivor to slow down further regardless of the selected player walking speed. It may be a problem with how walking is designed and implemented in the game engine as Odyssey had this exact same problem with caves and it was never fixed.

    Note: The cave problem may just be in Odyssey. That was where I noticed it and can't test right now to see if it's the same in Valhalla.

  • RoachSandeson
    5 posts

    I thought I'd add something of use to the conversation.

    I am currently using a Razer Blackwidow Chroma V2 alongside a Logitech G604 mouse.

    Walking speed is currently set at the max 10/10. It is stuck at 1/10 when using cloak and pressing crtl to change from running to walking.

    Best of luck to the developers! I hope you find a solution.

  • coolhawk2010
    2 posts

    Ubisoft doesn't understand the problem. They think that it only breaks the immersion, but in fact it breaks the mechanics stealth, I put aside the game, and wait for it to be fixed.

  • Yell0cake
    27 posts

    Well this issue persists over a month now and no ubisoft employee wants to answer on this issue after the fact is known that it isnt an hardware issue. Seems to me as they just ignore it and all their game testers are playing on controllers. I switched now to Cyberpunk because of this issue even tho it is buggy as hell but at least its gameplay features arent broken like this one. Aint planning on giving Ubisoft any more money until its fixed, because they are pushing the "starter pack" out with weapons that are bugged and have no perks. Its just embarrasing.

    But to at least add something positive to the thread, here are my specs that i tested this walking issue on.

    Sharkoon Purewriter ; doesnt work
    Sharkoon Purewriter TKL ; doesnt work either

    I even put the walk speed key and movement keys on mice and it didnt work:

    G502 Lightspeed
    G900 Chaos Spectrum

    I managed to work around this issue with reWASD but im not going to pay money after the free trial to fix an issue that shouldnt be my JOB to fix.
    Its ridiculous that ubisoft released an ASSASSINS CREED game with broken SOCIAL STEALTH mehanics that make you walk slower than the 90+ years old altair in Revelations.

  • RoachSandeson
    5 posts

    @yell0cake Hey thanks for the feedback, the more that post the more likely the problem will get fixed or so I hope! I still can't believe I tolerated over 100 hours of gameplay without asking for a solution within the forums. I guess I just took it as this is how the cloak mode was intended to be in this Assassin's Creed but now I know better and will not play another minute until the resolve the issue.

    I guess the one positive is that the non-stealth elements of the game are at least decent, otherwise I probably would have quit this game at around 10 hours or so.

  • Yell0cake
    27 posts

    The funniest thing is that the now present dunkness bug somehow indirectly fixes the slow walking issue by making Eivor fast walk instead of jog in cloak mode. (for a minute at least, as long as you are drunk)
    This just proves that its [censored] easy to solve that problem by even just adjusting the overall speed (to 80% or so) with cloak on so you would walk instead of jog and jog instead of sprint in the corresponding movement modes with cloak on, but nah lets just push out an reskin of the hunter armor and an drunktard update instead.

  • xtwitch29479
    3 posts

    The best part is that this was also an issue in previous AC games iirc that had been fixed in later patches. Like??? I really am not picky and understand devs are humans too but c'mon this is just laziness.

  • larrykop1967
    65 posts

    Yeah, the cloak has never worked for me at normal speed, i get spotted every single time, on horseback too, but i can't play at the stealth walking speed, it is too slow, hopefully a future patch will change it, i'm 99 percent finished in the game and hardly used stealth at all due to this issue.

  • RoachSandeson
    5 posts

    @larrykop1967 That sucks that you completed an Assassin's Creed game without being an Assassin. I commend you and at the same time feel sad that this wasn't an immediate fix as soon as the game was released. I hope that once they do fix it I'll be able to enjoy the last third of the game as it was intended to be played LOL

Suggested topics

Community details