Welcome to discussions

Quick Suggestions

  • Rogue-Reaper13
    13 posts

    @krvpt I still can't get in... since launch day....

  • Andrepisa89
    9 posts

    @beaudoinbros

    I have windows with bootcamp. Reinstalling windows is not so easy (files and program ecc). So I stay with the vhd that has resolved the problem for the moment.

  • Unit921980
    3 posts

    My problem was being on the Windows Insider Dev Channel.
    I have resolved this for me after trying everything listed here.

    • Updated windows
    • Updated Graphics Drivers (RTX2080)
    • Removed epic games/ubisoft/assasins creed and deleted all the residual files including appdata/local folders.
    • Older version Geforce experience/Newer version of Geforce experience
    • Changed Firewall rules
    • New versions of VCredist(though i have these anyway for Visual Studio development work)
    • Rebuilding Windows media services, adjusting file permissions (admin user etc)


    It turns out that the latest release of Windows Insider changed some memory addresses relevant to the way Ubisoft loader calls Assasins Creed Valhalla, I had to roll back 2 versions of Windows Insider.

    It's under settings -> Recovery -> Go back to the previous version of Windows 10.

    This worked for me. YMMV

  • Lavayo
    5 posts

    @unit921980 Whats your exact windows version? I'm in the normal user ring, nevertheless have the new 20H2 update.
    I even reinstalled windows with formatting C:, a complete clean reinstall. Still not working...(!)

  • Unit921980
    3 posts

    @lavayo I have now pushed back to 20251.fe_release.201030 Windows update is trying to install 20257.1.fe which I believe is what breaks it. I have paused for 7 days to see how it tracks.

  • krvpt.
    63 posts

    @rogue-reaper13 yep... same boat brother

  • Boogie7601
    7 posts

    Same here.

    Assassin's Creed Valhalla crashes shortly after displaying the blue-green logo splash screen. I have tried every fix and the game actually worked for me for a few hours on release so I know my system runs it just fine. I've narrowed it down to the Windows Insider's Preview update 20257.1.fe (as others have confirmed) My system took the update the night it stopped launching this game.

    Unfortunately I am unable to roll back to the previous Windows build and I am not willing to reinstall my entire system to fix a (probably easily remedied) bug in one game. Actually, my copy of Assassin's Creed Odyssey is behaving the same way.

    Does anyone know exactly what about the latest Windows build is causing this crash? I'd like to know how likely we are to see a timely fix for this, either from Ubisoft or via another Windows release. Should I pause my Windows updates for the time being while Ubisoft fixes the game or should I continue taking them in the hope that a newer Windows build will solve the bug?

  • trolsopol
    Original poster 31 posts

    @boogie7601 not sure it's 100% due to the insider windows update. I'm not on the insider version, and I have a problem only with Valhalla, i can play all other assassin's creed games, and wildlands/breakpoint as well. I think this AC is running on the same engine as Breakpoint, even though it's modified. So i would say the problem is still with this game specifically.

  • Exaudio
    19 posts

    I am the only one left whit this problem or do you still wait for a solution?

  • Joint361
    4 posts

    @exaudio i think ubi doesnt care of us , most % of guys playing sooo they think we have crap pc or i dont know, Odyssey works normal ,this piece of crap crash with this very helpful message " ohh its crashed " i think the problem is with api change from dx 11 to dx 12 i remember i had the same [censored] with anno 1800. Just add dx 11 api or fix this dx 12 crap UBIIII or say something in this threat how many years we must wait for something????????????? i cant play on i7 8700k and geforce 2080S gpu its ridiculous and nooo i will not create virtual disc or reinstall/update windows , all games are running normal sooo problem is with this uplay [censored] / or just game. thx

  • alan.temmer
    2 posts

    Same problem, so sad.

  • trolsopol
    Original poster 31 posts

    @exaudio nah man I have the problem still, no response from Ubisoft. I requested a refund a week ago and still nothing. And now their customer support portal is in maintenance until the 23rd so i guess i'm not getting my money back any time soon and i'm not playing the game and it's f**cking great...

  • beaudoinbros
    14 posts

    Ubisoft STILL hasn't even acknowledged my support ticket🙄 I had to fix it on my own by re-installing Windows, which for now, seems like the only option to get Valhalla working. I am playing in 4K with all settings set to max, and everything is silky smooth. So the game does work, it's just that Ubisoft is too damn lazy to bring out a simple fix. I know, I went to extremes to play this game, but I want to say that the game isn't a total waste. Hopefully Ubisoft gets off their asses and releases a fix for people who are still in crash hell.

  • Andrepisa89
    9 posts

    In my opinion is the version of window that create the problem. I’ve bought assassin creed origins, I’ve installed it and also this game now is blocked on the symbol of the game like wahlalla. So the problem isn’t the game, but maybe the ultimate version of windows. Before the update, I never had this problem

  • Exaudio
    19 posts

    Also heard the latest win update did something strange, but It doesn't make sense that Odyssey, Origins, Far Cry 5 etc is working flawlessly on my system

  • Exaudio
    19 posts

    Can we get a shout out from everyone still not getting the game to start? Wondering how many of us there are

  • CaveJensen
    1 posts

    @exaudio I'm able to launch the game, start a new game, make it through the first cutscene, then just a white screen with the sounds of people inaudibly talking and a never ending loading symbol in the bottom right. Tried all the possible solutions aside from reinstalling my OS, that's as far as I have ever gotten.

  • BeefStanks
    2 posts

    im at 11 days on my support ticket, still cant launch the game. one reply from ubi asking me to do eveything that i have already done and stated so in my ticket to them, submitted my msinfo to them, so now im waiting again.

  • alessio0212
    4 posts

    On microsoft insider forums there is topic about this problem, and microsoft responded that they are investigate that issue.

    i didn't want to reinstall windows, so i created partition with 30 GB, installed windows 10 side by side and installed only ubi connect. ACV works perfectly. So if you dont want to reinstall windows, just create partition and install windows only for ACV. 

  • Boogie7601
    7 posts
    i didn't want to reinstall windows, so i created partition with 30 GB, installed windows 10 side by side and installed only ubi connect.

    @alessio0212

    I might just do this, I really would like to play the game I paid for, but I can't reinstall my entire system over it (for a variety of reasons. I was hoping to see a fix rolled out before it came to that..

Suggested Topics

Community Details

88
Online
220.2k
Users
37.2k
Topics
184.5k
Posts