Welcome to discussions

Quick Suggestions

  • Lavayo
    5 posts

    @exaudio Same problem, still after all the time. 20H2 too.

  • trolsopol
    Original poster 31 posts

    @boogie7601 I am on 20H2 but not running insider versions. The problem is only with this game, so definitely not worth reinstalling and setting up windows again.

  • Joint361
    4 posts

    @trolsopol new patch still not working 😞

  • Exaudio
    19 posts

    Not working here either after the patch. Come on Ubi !! There are hundreds of users not being able to play the game at all with all system requirements met and a load of trouble shooting skills. We have tried every thing. Please answer us!!

  • Boogie7601
    7 posts

    Still not working with the latest patch. It's also not mentioned in the changelog so I suspect the patch didn't even address it.

    This bug needs more attention! It's easily reproducible, let's get a fix rolled out!

  • prmax007
    3 posts

    Tried all their troubleshooting advice and finally I just went ahead and installed a fresh new copy of Win10 20H2 and now ACV is working. Did not want to go this route, but decided that I had to do it. Took me most of yesterday to reinstall all my work and personal apps, files, etc. What helped out is that I have a portable drive with all my apps and serial numbers. Not the solution I wanted, but it is the one that worked for me. Could not wait , since their recent update did not fix the issue.

  • Joint361
    4 posts

    @prmax007 yes for me also now working , i installed fresh win 10 20H2 and game looks amazing ❤

  • Exaudio
    19 posts

    I actually got the game working now after trying everything stated on this forum and else where, and the fix is not as frustrating as a clean boot of win 10.
    I downloaded the "Windows USB/DVD Download Tool" and choose to reinstall win 10 but KEEP personal files and apps. It took about 20 min to reinstall, and everything was as before after the install with all my apps etc.
    And now the game starts !!!!!!!! Hallelujah

  • dattiloe
    2 posts

    @crazydonkey88 I have this problem, tried a bunch of things ,nothing works.

  • Ubi-Borealis
    Ubisoft Support Staff 3626 posts

    Hello there @dattiloe!

    I've reached out to you in the thread you created. Can you check it out when you're next able to?

    Thanks! 😊

    Official Response

Suggested Topics

Community Details