Welcome to discussions

Quick Suggestions

  • emmaj95
    66 posts

    @zhead_ Tried all that many days ago and still nothing. I just tried reverting my Nvidia drivers to a previous version and that also did nothing.

  • babooshka_
    5 posts

    @trolsopol Hello. Any response from support team? Ubisoft Connect is dead for me second day straight. And it's not limited only to Valhalla. Other games are having the same issue as well.
    Best regards

  • rcmedia69
    4 posts

    UPDATE:
    I fixed my problems by updating my Nvidia drivers again using their GeForce Experience app.
    I downloaded it from their website and installed, and it was very easy to update my drivers to the latest version using that.
    AC Valhalla runs great now!

  • emmaj95
    66 posts

    @rcmedia69 Lucky you! Sadly I have already tried this twice now and I am still crashing at the splash screen.

  • beaudoinbros
    14 posts

    @rcmedia69 No joy here😢 At least someone can play Assassin's Creed Valhalla. The rest of us are still stuck in crash screen Hell😱😱😱


    Edit: I even tried running the .exe in different compatibility modes, NOT gonna happen. Tried running the .exe as Administrator, NOPE!! 🤬🤬

  • zhead_
    31 posts

    @beaudoinbros did you select the option to disable full screen optimisations?

  • emmaj95
    66 posts

    @zhead_ Tried this and while running from the .exe still gives me the splash screen crash, trying to run through the Ubisoft Connect launcher is now just making it sit at this loading window. Feels like backwards progress, hah.

    undefined

  • emmaj95
    66 posts

    I want to go ahead and add that I had the chance to sit down on a few chats with customer service this afternoon to go through troubleshooting. Nothing that was suggested worked for me (updating directx, visual c++, checking sfc scan, and disabling startup apps through msconfig). The latest person I chatted with said that they would be escalating my ticket to the dev team and that I would be updated soon. Might be worth it if other people with this issue can have this done with their tickets as well, if the previous troubleshooting hasn't worked yet.

  • Z31Turbo
    7 posts

    @emmaj95 I think Ubisoft is having a lot of problems with upset customers. Someone tried to SWAT their Montreal office yesterday and Ubisoft Connect has been going up and down a lot, I suspect probably a DDOS attack. Very uncool as these sort of disruptions will only hamper any help that can be given.

    For best results, just try launching the game from the .exe directly, even if Ubi connect is down, it will fail the cloud save sync but let you skip it and proceed.

    REALLY disappointed that they cannot even acknowledge us.

  • BeefStanks
    2 posts

    im at 3 days on my ticket, i get the splash screen and it just closes. i dont even get an error or anything

  • emmaj95
    66 posts

    @z31turbo Yeah I've been trying to run straight from the .exe for the last four days with no luck. Basically every time I try a new troubleshooting method I try from the Ubisoft launcher as well as straight from the .exe as an administrator.

    I can't say I'm angry about this so much I as I am frustrated and disappointed. I understand how hard it must be for the dev team right now but also sucks that we aren't getting any communication. Just a bad situation all around and I really hope it gets resolved soon.

  • Staky000
    9 posts

    Just chiming in, same problems.

    I've gotten it to launch a couple times.. but it felt mostly random when it worked.

    And re-launching the game has proven to reset the problem.

    Tried every possible fix I can find to no avail.

    I reached the last phase of customer support already (ticket escalated, wait for an email with information)

  • Staky000
    9 posts

    @staky000

    I got it to work consistently every time I launch it.

    I did a full reset.

    Windows Restore > Reset all

    Ya do what ya have to do for the brotherhood I suppose

  • beaudoinbros
    14 posts

    Created a ticket and attached the dxdiag.txt and msinfo32.nfo files. Hopefully Ubisoft gets this mess sorted out soon, as I imagine there are a lot of unhappy campers out there right now. All I can do is hope for the best, or a miracle🙏 🤣

  • emmaj95
    66 posts

    @beaudoinbros Same here! Fingers crossed it’s soon!

  • Konksling123
    6 posts

    Im having same issues launching Valhalla, i click on launch, it brings up the Valhalla logo, and then just crashes. 100% of the time, i cannot get onto the game at all. Which is weird, because it worked for 2 hours. then the next day it never worked again.
    I have tried all things.
    Reinstalled the game, reinstalled onto different drive, reinstalled uplay, reinstalled the VCRedist, updated all drivers, windows, bios, verified the game, removed any overclocks. it just wont start.

    I really hope they fix this soon.

  • emmaj95
    66 posts

    @konksling123 So weird that some people are able to play temporarily before the crashes begin. Is it giving you the “oh no, it crashed” error? I have not been able to load the game even once. All I can do is wait for my escalated ticket to get a response now.

  • Konksling123
    6 posts

    @emmaj95 Yep, just the "Oh no" pop up. I had no issues for a solid 2.5 hours (other than performance) but no crashing at all. And then it just died. It makes no sense, ive never had a game do this before. Good luck though, they dont seem fond of communicating lol.

  • beaudoinbros
    14 posts

    @konksling123 at least you actually got to see what the game looks like😜 All I get is this: 👎

    undefined

  • Konksling123
    6 posts

    @beaudoinbros well.. It is a nice high quality error box. So thats good, right?

Suggested Topics