ubisoft discussions

Quick Suggestions

  • dennik02
    4 posts

    Hi guys, i have a bug in the final Quest in Asgard with the buildmaster. I found the farb boxes but when i bring them beg to the tower nothings Happen and Loki did nothing. My account name is DeNNinho01 on ps4 please fix this, or make it possible to reset a quest

  • priscillarubiad
    6 posts

    @ubi-swaggins
    As I was unable to resolve it, I left Asgard and continued on the main mission. Will I miss all this progress?

  • Peterock528
    1 posts

    I ran to the cave and killed a reindeer (glitch) that was running around. There was another that ran away and disappeared. Apparently they were supposed to transform into blue guys I was suppossed to kill, but glitched out. Loki got stuck mid transformation walking down the path to the cave. It looked like he was repeatedly being struck by lightning.

    I reloaded from a save a few minutes before. The dialogue with loki started right away like I was already at the cave with him, but I was in the tower. I ran to the cave again and killed both the reindeer before they could escape this time. As soon as I killed the second one, after I chased it back near the tower, Loki's dialogue started up again as if I was still in the cave. So I ran back.

    When I got to the cave there was no Loki so I ran around a while looking for him and all of a sudden he appeared at the cave entrance. I ran to the red door as he was walking toward it, when he got close a cut scene played out. At it's end I was able to help him force the door open.

    Once inside a bunch of reindeer turned into blue guys as intended and a couple reindeer (glitches) tried to escape. I killed the reindeer as fast as I could before they could get away, then took out the blue guys.

    I was able to pick up the crate and walk it back to the tower. A couple cut scenes and a successful fight later the mission was complete, sort of...

  • Scuzzya2014
    3 posts

    They should just have a "cancel quest" button, I'd be happy to start the quest chain again, but no way am I re-doing 14-18 hours of gameplay just to progress this, a hotfix should be easy enough!

  • MottledSun
    1 posts

    After talking with the builder under the tower I try To go south to collect the builders paint but nothing happens when I get There the game doesn’t seem to register it as a quest I’ve tried everything restarting, dying, leaving and coming back, carrying all the paint to the tower and nothing. I fear Of starting over and losing over 8hr of play time. Help!

  • Psykztah
    1 posts

    Like asgard is the glitchiest place. The mission where u help the builder. The giants get stuck behind the hill in their spawning zone and dont agro when u run outside to get them to come you die. I had to restart my console and load earlier save plenty of times b4 the mission worked properly. Lost 3 hours to this but this is not the end. The mission where loki and Havi are going to get paint, after clearing the area nothing happens loki just stands there and picking ip paint nothing happens. Im stuck in this mission and carry paibt over and over again to where thor and everbody else is. Please fix this because it frustrates me. And its not okay for triple A title to be this kaotic.

  • crispo971990
    3 posts

    FIXED THE PROBLEM!

    Had an issue earlier in the game, so I couldn't pass a cave. A friend told me to go in to settings and change" FPS LOCK " down to 60 fps.

    This helped me, hope it works for you to 🙂

  • Grimrg
    1 posts

    I'm having same issue however my loki is actually dead as freya as I entered the room and went unto the pillar he just appeared in the room and was attacked but didnt fight back until they killed him.
    undefined

  • kbtaylor18
    4 posts

    @crispo971990

    is this in the settings on the console or in the game itself??

  • kbtaylor18
    4 posts

    @crispo971990

    I figured it out and it worked!!!! At least halfway worked, it won’t let me replay the quest, but it let me leave Asgard so I won’t lost a of my data! Thank you so much for posting this!

  • don_pablo18
    1 posts

    I’ve been having the same issue and this isn’t the first, this is about the sixth issue I had with the game myself after getting into the room, I can clearly see the paint but the game doesn’t recognize that i am already finished with that part of the mission, it’s ridiculous how much money I paid for this game when none of my other games has this issue, y’all need to fix this already or I’ll never be buying a assassins creed game again like what type of [censored] is this, literally one of your teams solutions for this is to restart my progress after I already put 20 hours into this game like y’all out of your mind

  • RandyMar5h
    1 posts

    Same here carry paint to the tower but Loki is still disguised as the queen so there is 2 queens and returning the paint doesn’t register

  • ploffie664
    1 posts

    When entering the builders cave to slay the enemys en get the paint loki’s audio is not working and he just stands like a statue, tried multiple reload from hours before but everytime the same end. Please fix this ubisoft

  • crispo971990
    3 posts

    @kbtaylor18

    Hello, this i dont know. I play on pc, but ill guess you can try both? Maybe it will work on your console as well. Hope this works! Keep me updated

  • crispo971990
    3 posts

    @kbtaylor18

    Glad to hear it worked buddy! 🙂

  • Ehllfhire1
    86 posts

    @ubi-swaggins how about some testing and finishing a product. You dont pay us to do your job.

  • AKNOOB7
    1 posts

    Pls someone help me. I won the fight against the builder in Asgard but when i finished him nothing happened. i was waiting like 2 minutes nothing happened. I was stuck in that cage so i left asgard. Now every time i get in it says i have to do the fight but i killed him and thats why he is not here. So i cant play anymore in Asgard until this will get fixed, Does this happened to anyone else?

  • Alphad115
    1 posts

    I stumbled upon a game breaking bug.

    I managed to glitch the boss to be in a "forever kneel" stance in which I could deal damage without him raising up. Upon reaching a certain threshold, I was able to do what I assume is the 'finisher' and he died. However, I was not given any cut scene, nor was I able to leave the force field. However, I was able to teleport to a sync point from which I ventured back to the boss fight area and it was still active with the force field and I am stuck.

    Some notes:

    I skipped the first "big damage hit" after you hit the weak spot twice.
    Also I skipped the cut scene at about halfway through the fight.

    I have a screenshot as evidence.

  • Grizmine.
    1 posts

    @ubi-spud i think the problem is loki, he is at the door but still in the tower as freya... You take the paint boxes but nothing happens .
    Impossible to finish the quest hum...

  • prudcop
    4 posts

    meme problème ici!!
    xbox one j’ai 100hrs de jeu, si je dois recommencer je crois que je vais juste laisser le jeu dans mon armoire
    apres le speech avec loki dans la mission grand achèvement il reste coincer dans la porte et ne bouge plus!
    peu importe ce que l’on fait:
    quitter revenir
    reload save game
    etc
    rien ne fonctionne arranger cela svp
    des bug de texture ok sa peut arriver, bug de physique du jeu sa peut arriver aussi il est tout récent
    mais des bug aussi grossier que cela vous vous foutez de notre geule?!

Suggested Topics