Welcome to discussions

Quick Suggestions

  • SamuraiBrackm
    2 posts

    @samuraibrackm @Ubi-Spud

    I was experimenting with a few save states and ended up making it through the mission successfully. My noted are below if helpful in troubleshooting for other.

    What I did differently:

    • Save state was an "Exclusive quest save".
    • The quest name eludes me, but it was when the Builder is testing out the shield and you fend off various giants.
    • I did not explore the island for the wealth before starting "The Big Finish". (I suspect this may be a major cause for whatever reason.)
    • Dialogue options differed. First time through, I chose the more coy responses about Freyja. Second time through, much more direct about defending Frejya. The game dialogue doesn't change much, but figured I would add this info. (Thought maybe something in "memory" for choices... Maybe, maybe not.)

    Notable impact on quest:

    • [Unsuccessful] After the initial cutscene, the game would jump to Loki being in the cave fighting giants just before opening the sealed door. Dialogue would play before I was able to control character.
    • [Unsuccessful] Loki continued to be disguised as Freyja in the tower and assist in retrieving paint in cave.
    • [Unsuccessful] I could pick up the paint crates, but the quest would never update.
    • [Successful] Loki had dialogue I hadn't heard before about removing the disguise. He does so successfully and walks with PC to the gave and investigates giants.
    • [Successful] Upon clearing the cave, Loki says to hurry with the paint and the quest objective updates.
    • [Successful] There did appear to be another bug where Loki continued to stay in the paint cave and continue dialogue but this was not breaking and allowed me to continue.

  • OGSithLrdMalgus
    26 posts

    still an issue cant progress the paint sill remains unfound lol looks like people have been having lots of issues lol good ol rushed games

  • TheRealNLMohawk
    1 posts

    Same issue here!
    The completionist in me was trying to clear the map before finishing the questline. Interacted with the closed door in the cave after killing the two Jotuns (one outside the cave, one inside the first part of the cave).
    Nothing happened so continued the quest.
    After the cutscene I went to the cave with Loki, killed the 2 Jotuns again, broke down the door and retrieved the paint but Loki disappeared and the quest objective remained the same.
    I cannot interact or talk to anyone at the tower, bringing the paint does nothing to change this and reloading autosaves has not helped me. I am extremely reluctant to load a previous manual save as it would cost me over 10 hours of gameplay.
    Please come with a hotfix ASAP!
    The last update by staff I've seen on here dates from november 13th, THAT'S 5 DAYS ALREADY!
    I'm enjoying the game very much but it's honestly FAR from a finished product...

  • jjmugs1
    11 posts

    @memeofcheese lmfao exactly post a link on where the save data is located then literally just posted the link to ubisoft website showing no method of uploading save data. What the heck is this?

  • Shirukien2020
    2 posts

    http://imgur.com/gallery/JLgX8EJ. Loving the game, but this broken quest is killing me.

  • Dylagent_
    1 posts

    Just thought I'd contribute here.

    I've experienced the same issues that others have described.

    I believe what may have broken the quest for me is interacting with the red door before getting to the cave with the paint before interacting with the Builder to build up to the final fight.

    Loki is both still disguised as Freyja standing in the tower, but also comes with me to fight the Jotun in the cave as actual Loki.

    Once all of the Jotun are defeated, the paint is highlighted with Odinsight, but upon picking the paint up, nothing happens and bringing the paint back to the tower does nothing.

    Loki is also just stuck at the doorway, looking like he's going to start fighting something and just stays in the doorway.

    I can't recreate it now, but the first time I ran to the cave containing the paint, I did hear about 3 different dialogue lines go off at once about interacting with the door (presumably due to the fact that I had already interacted with it before I was supposed to) and the fact that there was Jotun disguised as deer (dialogue from both Havi and Loki here.)

    In an earlier post from a Ubisoft employee, they asked for game save data, but the link they included just goes to the main Ubisoft Support website.

    I have instead included it in this reply to hopefully aid in fixing this game. The save I took here is after the initial trigger of the paint-finding part of the quest, but is before fighting the Jotun in the cave where Loki is in two places at once and the quest cannot progress.

    Hopefully it helps, and thank you Ubisoft for your attention to this.

    I cannot attach the save file directly, so here is a link to my OneDrive that will let you download the save file: https://1drv.ms/u/s!AhQTo7rs881oicJcb0jzJYMh155Z1w?e=9Vqh7G

  • Shirukien2020
    2 posts


    Link up there is broken, maybe this one? Come on Ubisoft https://imgur.com/gallery/JLgX8EJ

  • MemeOfCheese
    12 posts

    @shirukien2020 Same thing for me, but Loki is not a woman. I pick up the paint and nothing happens. even tried delivering them all to the tower, nothing happens.

    Oh well, atleast they put all their development hours into diversity and including women and poc in a viking setting instead of fixing the game!

  • Spetznozi
    3 posts

    @fsocietylp my outcome is the same, Loki is present both at the cave and at the tower as Freyja as if he never followed.

  • elbreve
    2 posts

    @socl0s3 you are correct, I had same issue, by going to the cave *before* talking to the builder, you glitch the game. Just reload and talk to builder first.

  • elbreve
    2 posts

    I dont know if this has been posted, but I read through the long list and well....
    Here is the solution, as far as i know in xbox, either after A patch or not, i DO know that if when going to talk to the builder you try to check the cave underneath first, you glitch the mission. Go straight to the builder, THEN the cave. That worked for me, luckily my last save was just before the wolf fight, so what, replaying 15-30 min. of the game.

    But yeah, as of now, on at least xbox, if you enter the cave BEFORE speaking to the builder (during that exact quest) you glitch the mission, just reload and go straight to the builder, THEN the cave.


  • Olgit_aka_Tiglo
    5 posts

    To be fair -

    This quest needs an ending stage at the paint.... a chance to save.... before starting the fight.

    It's a horrible fight for an older gamer and I ended up having to go back an hour of game play saves, just to get out of it. This is a habit around the game itself also. You're in a level 55 area and quest ends up being level 340. This is not fun and the person who thought it was a good idea, should leave the company and never play games again.

    People like the flow to be correct..... not giant leaps into stupidity.

    If we clear an area - THEN and only then, should higher level content be added to it, with a note on the map stating that.

    Ubisoft developers - you really need to start learning how the "Average" player copes with your mechanics.

  • BigMac834
    1 posts

    I play on PS4 and for some reason when I go to fetch the Builder's paint, my Mission wont update. "Activity south of tower."
    This sucks because there is no why for me to continue with the story.

  • Achilles31635
    1 posts

    I got it to work. I restarted the quest and took it really slowly. Interacted with the footprints on the way. Didn't attack before interacting with the door. Snuck across once in the room (don't attack) then picked up the paint and it changed to deliver it to the tower. Then dropped the paint and killed everything. Hope this helps 👍👍

  • Olgit_aka_Tiglo
    5 posts


    I don't have the problem of it starting.... the problem was, I was locked into that battle once the paint was handed in and I was not prepared and unable to deal with the consequences of this quest. Sorry, trying to avoid spoilers. As a result, I went back an hours worth of saves in the end, to finally get out of it.

  • Sicinthemind
    3 posts

    Same here issue here, cannot progress - Triggers appear to be broken, from seeing a few different walkthrough videos on youtube, the ones I noted were

    1. Picking up the paint with remaining enemies doesn't trigger the main character remark, "I have the paint!" and Loki replies, "Then let us fade like shadows in the light"
    2. Defeating the remaining enemies in the room where the main character asks Loki, "Is that all of them?" and Loki replies, "I hope so, let's get the paint and go"

  • talvikar
    2 posts

    @delboyspencer yes and then did the big fight begin. i have power level 74 and 12 arrows, so no change to win the battle. he kills me all the time and fight starts over and over again, can't get out, wake up button don't work , so my game ends here

  • Sicinthemind
    3 posts

    Yours seems more like poor planning than an actual bug. you didn't level up enough. Gotta go back to a prior save. Recommended power for the area is 90.

  • Sicinthemind
    3 posts

    if you open the map, Asgard recommended level is 90.

  • talvikar
    2 posts

    @sicinthemind so you think it's ok that you can't end the quess

Suggested Topics